Talk:Development/Tutorials/Kate/KTextEditor Plugins Advanced

Jump to: navigation, search

Contents

Thread titleRepliesLast modified
completely broken018:50, 12 June 2018

completely broken

even with CMakeLists.txt like below, it does not build ! sick and tired of captchs round here !! dang !!!!


cmake_minimum_required(VERSION 2.6.0)

set(KDE_MIN_VERSION "4.00.82")

find_package(KDE4 REQUIRED) include(KDE4Defaults) include(MacroLibrary) include(CheckIncludeFile)

add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})

include_directories(${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} ${KDE4_INCLUDES} ${KDE4_INCLUDE_DIR} ${QT_INCLUDES})


set(ktexteditor_timedate_PART_SRCS timedate.cpp timedate_config.cpp )

kde4_add_plugin(ktexteditor_timedate ${ktexteditor_timedate_PART_SRCS} )

target_link_libraries(ktexteditor_timedate ${KDE4_KDECORE_LIBS} ktexteditor )

install(TARGETS ktexteditor_timedate DESTINATION ${PLUGIN_INSTALL_DIR} )

install(FILES timedateui.rc DESTINATION ${DATA_INSTALL_DIR}/ktexteditor_timedate )

install(FILES ktexteditor_timedate.desktop

             ktexteditor_timedate_config.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
Firef (talk)18:50, 12 June 2018

This page was last modified on 12 June 2018, at 18:50. Content is available under Creative Commons License SA 4.0 unless otherwise noted.