Getting Started/Build/KDE4/Kubuntu and Debian (ru)

Jump to: navigation, search


Здесь приведено уточнение всех зависимостей, которые должны быть удовлетворены в Kubuntu 7.10 (Gutsy) и Debian (Testing/Unstable), чтобы получить минимальное работающее окружение. Их можно установить с помощью команды, приведённой ниже:

sudo aptitude install build-essential cdbs debhelper cmake \
kdesdk-scripts subversion ssh xserver-xephyr doxygen libqt4-dev dbus-x11 \
libstreamanalyzer-dev libstrigiqtdbusclient-dev \
libxml2-dev libxslt1-dev shared-mime-info libungif4-dev libssl-dev \
libboost-dev libgpgme11-dev libxine-dev libqimageblitz-dev

Будут установлены некоторые необходимые для любой сборки пакеты (такие как build essential) и будут удовлетворены все зависимости, выполнение которых необходимо для сборки KDE 4, и установлены некоторые рекомендованные пакеты (например, libssl-dev для поддержки https). Soprano, рекомендованный к установке, следует устанавливать из svn. Остальные необязательные и рекомендованные пакеты перечислены ниже.

После установки всех требуемых пакетов вернитесь к сборке KDE 4.


Необходимое для сборки программное обеспечение

В Kubuntu 7.04 (Feisty) и Debian (Testing/Unstable) необходимое программное обеспечение можно установить следующей командой:

sudo aptitude install build-essential cdbs debhelper cmake \
libxml2-dev libxslt1-dev libbz2-dev libclucene-dev librdf-dev \
shared-mime-info libgl1-mesa-dev libglu1-mesa-dev mesa-common-dev \
libxext-dev libjpeg-dev libpng12-dev subversion libsm-dev libxinerama-dev \
libxrender-dev libfontconfig-dev libboost-dev libxcursor-dev doxygen \
libungif4-dev libdbus-1-dev libssl-dev libgpgme11-dev \
libasound2-dev kdesdk-scripts libpth-dev libjasper-dev \
ssh libxine-dev libqimageblitz-dev libqimageblitz4 libglib2.0-dev \
libxkbfile-dev libenchant-dev libbluetooth-dev network-manager-dev \
libsmbclient-dev libxcb1-dev libcaptury-dev libxcomposite-dev \
libxdamage-dev libusb-dev libgpgme11-dev libldap2-dev

В Kubuntu 7.10 (Gutsy) и Debian unstable следует добавить:

sudo aptitude install dbus-x11  libqt4-dev libqca2-dev libeigen-dev \
libstreamanalyzer-dev libsoprano-dev libstrigiqtdbusclient-dev \
libxklavier11-dev libxml2-utils libdbus-1-dev libxslt1-dev cmake libbz2-dev \
libungif4-dev libgpgme11-dev libboost-dev libxine-dev libxkbfile-dev

Для того чтобы задействовать всю функциональность системы документации (API documentation framework), также выполните:

sudo aptitude install graphviz

В Kubuntu Gutsy и Debian unstable нет никакой необходимости компилировать qt или kdesupport. Все необходимые пакеты доступны после процедуры описанной в настоящем разделе, потому переходите сразу к сборке kdelibs, перед этим только создав отдельного пользователя в системе для запуска программ KDE4.

noframe
 
Note
При возникновении проблем при компиляции KDE4 Beta4 или выше в Kubuntu 7.10, похожих на:

Soprano version is too low

strigi xxx.h not found...

Необходимо обновить и собрать соответствующую часть исходного кода kdesupport. Это описано в разделе о сборке kdesupport.

Также удалите пакет soprano: sudo apt-get remove libsoprano4 libsoprano-dev (этот пакет мы соберём из исходников самостоятельно)

If you still get an error in the kdelibs section about soprano like: CMake Error: Error in cmake code at $src/KDE/kdelibs/cmake/modules/FindSoprano.cmake:78: FILE Internal CMake error when trying to open file: /usr/include/soprano/version.h for reading.

then delete kdelibs/CMakeCache.txt

This page was last modified on 15 July 2012, at 10:50. This page has been accessed 6,556 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal