Difference between revisions of "Projects/Mobile/MaemoPackages"

Jump to: navigation, search
(add SDO)
(Dependencies needed for the KDE Platform)
Line 17: Line 17:
 
{{FeatureTodo|gpgme|version: 1.2.?|Noone|Noone}}
 
{{FeatureTodo|gpgme|version: 1.2.?|Noone|Noone}}
 
{{FeatureTodo|Shared Desktop Ontologies|version: 0.2||}}
 
{{FeatureTodo|Shared Desktop Ontologies|version: 0.2||}}
 +
{{FeatureInProgress|libattica|version: 0.1.2|gladhornKDEorg|Frederik Gladhorn}}
 
|}
 
|}
  

Revision as of 00:25, 3 February 2010

Dependencies needed for the KDE Platform

Status Package Details Maintainer
IN PROGRESS qt4-maemo5 sql-mysql support pending Harald Fernengel <haraldDOTfernengelATnokiaDOTcom>
TO DO raptor minimum version: 1.4.20, recent enough version to build Soprano is already in extras-devel Noone <Noone>
TO DO rasqual minimum version: 0.9.16, recent enough version to build Soprano is already in extras-devel Noone <Noone>
IN PROGRESS virtuoso version: 5.0.12 (6.x is not yet supported by Soprano!) Bjoern Ricks <bjoernDOTricksATgooglemailDOTcom>
IN PROGRESS mysql version: Currently 5.0.51a New from scratch 5.0.89 Bjoern Ricks <bjoernDOTricksATgooglemailDOTcom>
TO DO shared-mime-info version: 0.70, tricky dependency problem since Maemo platform packages depend on the exact installed version Noone <Noone>
TO DO cyrus-sasl version: 2.1.23, recent enough version to build kdepimlibs already in extras-devel Noone <Noone>
TO DO gnupg version: 2.? Noone <Noone>
TO DO gpgme version: 1.2.? Noone <Noone>
TO DO Shared Desktop Ontologies version: 0.2 [mailto: <>]
IN PROGRESS libattica version: 0.1.2 Frederik Gladhorn <gladhornKDEorg>

KDE Platform

Status Package Details Maintainer
IN PROGRESS Automoc version: trunk (0.9.89), only needed during build time Bjoern Ricks <bjoernDOTricksATgooglemailDOTcom>
TO DO Strigi version: ? [mailto: <>]
IN PROGRESS Soprano version: ? Bjoern Ricks <bjoernDOTricksATgooglemailDOTcom>
IN PROGRESS Akonadi Server version: trunk Bjoern Ricks <bjoernDOTricksATgooglemailDOTcom>

KDE Plasma Mobile

Status Package Details Maintainer
TO DO all N/A <Noone>

KDE PIM

Status Package Details Maintainer
TO DO all N/A <Noone>

Experimental Repository

The current KDE Maemo development packages can be found at http://files.kolab.org/local/maemo Please be aware that these packages are highly EXPERIMENTAL and use it without any warranty. To start e.g. akonadi you have to set LD_LIBRARY_PATH (export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/kde4/lib:/opt/qt4-maemo5/lib)


Content is available under Creative Commons License SA 4.0 unless otherwise noted.