Revision as of 20:57, 29 June 2011 by Neverendingo (talk | contribs) (Text replace - "</code>" to "</syntaxhighlight>")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Installing third party softwares in terminal

The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

aaaaaaaaaaaaa Are not the make && make install instructions missing for the part describing the installation of kdelibs and kdebase ...?

No, KDE4 uses CMake. the cmakekde function does everything.

Kunalthakar 19:07, 21 January 2007 (CET)



When compiling kdebase from source I get the following errors:

/home/kde-devel/kde/src/KDE/kdebase/apps/konqueror/konq_extensionmanager.cc: In member function ‘void KonqExtensionManager::reparseConfiguration(const QByteArra
y&)’:
/home/kde-devel/kde/src/KDE/kdebase/apps/konqueror/konq_extensionmanager.cc:101:
 error: cannot call member function ‘void KSettings::Dispatcher::reparseConfigur
ation(const QByteArray&)’ without object
make[2]: *** [apps/konqueror/CMakeFiles/konquerorprivate.dir/konq_extensionmanag
er.o] Error 1
make[2]: Leaving directory `/home/kde-devel/kde/build/KDE/kdebase'
make[1]: *** [apps/konqueror/CMakeFiles/konquerorprivate.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

Does anyone know how to help me out? Thanks, scarecrow

Hello scarecrow, Please post your errors to kde[dash]devel[at]kde[dot]org. I have some errors with kdebase myself, I'll post them to that mailing list. Bogdan Bivolaru 07:22, 12 March 2008 (CET)

kdebindings make fails cannot find -lsopranoindex

It gets to 19% Built target smokesolid Then get this:

Linking CXX shared library ../../lib/libsmokesoprano.so /usr/lib/gcc/i486-slackware-linux/4.2.4/../../../../i486-slackware-linux/bin/ld: cannot find -lsopranoindex collect2: ld returned 1 exit status make[2]: *** [lib/libsmokesoprano.so.2.0.0] Error 1 make[1]: *** [smoke/soprano/CMakeFiles/smokesoprano.dir/all] Error 2 make: *** [all] Error 2

?????????????????????

Any ideas? Thanks

-- Hi, exact same issue with 4.3.3. As far as I know, sopranoindex.so is not built because Clucene isn't installed. But why does kdebindings than refer to that lib?


This page was last edited on 29 June 2011, at 20:57. Content is available under Creative Commons License SA 4.0 unless otherwise noted.