Difference between revisions of "User:Skierpage"

Jump to: navigation, search
m (markup typo)
(Nepomuk indexing mystery: more)
 
Line 95: Line 95:
 
== Nepomuk indexing mystery ==
 
== Nepomuk indexing mystery ==
 
I'm slogging through all this crap to try to figure out why Nepomuk isn't indexing my NTFS volumes. It could be something to do with "System Settings > Nepomuk/Strigi config > File indexing > Removable media handling > Ignore all removable media", but I can't find the glue that links this KCM with the actual indexing. I know this is in nepomuk/kcm/nepomukserverkcm.cpp (No thanks to the three search engines, I found it in Google), but searching for "RemovableMedia" doesn't find anything.
 
I'm slogging through all this crap to try to figure out why Nepomuk isn't indexing my NTFS volumes. It could be something to do with "System Settings > Nepomuk/Strigi config > File indexing > Removable media handling > Ignore all removable media", but I can't find the glue that links this KCM with the actual indexing. I know this is in nepomuk/kcm/nepomukserverkcm.cpp (No thanks to the three search engines, I found it in Google), but searching for "RemovableMedia" doesn't find anything.
 +
 +
The result is <code>.kde/share/config/nepomukstrigirc</code> gets:
 +
  [RemovableMedia]
 +
  ask user=false
 +
  index newly mounted=false
 +
 +
but I can't find these terms in KDE source.

Latest revision as of 02:29, 15 November 2011

I first used Projects/KDE_on_Windows but now run Kubuntu as my main operating system. I wrote an occasional journal of my adventures in getting Kubuntu working at userbase.kde.org user page

I mostly do documentation and support for Semantic MediaWiki, an extension to MediaWiki.

Contents

[edit] Techbase problems and what I'm going to do about them

2011-11-14: I'm frustrated as hell trying to figure out a problem with KDE (Strigi not indexing my stuff), and TechBase is not helping.

Some wiki woes also apply to userbase.

[edit] Service page problems

The Nepomuk blog's Documentation page has a Strigi Service link that goes to Development/Tutorials/Metadata/Nepomuk/StrigiService unfortunately this suffers from the same problems as the blog's Documentation page

  • BUG: doesn't say where the source is
  • BUG: doesn't say where the API is
  • BUG: doesn't say what the service looks like. Is it a process I can look at? What's the process name?
  • TODO: techbase needs to have {{source}}, {{api}}, {{processname}} templates for creating links to these, and should have a series of form template that presents this sort of information about a project in an infobox:
 {{service| source= | api= | processname= | bugtracker= | kdemodule= | blog= }}

[edit] Too many wikis!

TODO: the split between userbase and techbase is dubious. I'm a user, but I want to go beyond the user documentation. You're just going to duplicate information like the processname, the blog, the bug tracker and the kdemodule in two wikis.

And it turns out there's a third wiki, http://community.kde.org. <rant>That is completely f***ing ridiculous.</rant> Three times the infrastructure to maintain (Help pages, templates, interwiki links, common images, vandal patrolling), three copies of all these bugs, and for what? Users are three times more likely to look in the wrong wiki.

[edit] Techbase minor bugs

BUG: Template:Info is undocumented! Use <noinclude> </noinclude> to document what templates do!

BUG: Help:Contents says to use

 <span class="bsBugLink bsError bsError-NoConnection"><span class="bsBugLink bsError bsError-NoConnection">{{bug|123456}}</span></span>

surely this HTML formatting junk should be part of a template, i.e. Template:Formatted bug

BUG: Template:Template has a silly confusing warning "If this page is not already in the "Template" namespace, it should probably be migrated to that location."

Instead, someone should just periodically look at Special:WhatLinksHere/Template:Template and see if pages outside Category:Template are using it.

[edit] techbase interwiki issues

interwiki prefixes] let you link between wikis. But the interwiki prefixes on techbase have some problems:

  • There is a bug prefix, e.g. 1234, but why is it language="ᨅᨔ ᨕᨘᨁᨗ" attribute? Maybe that's why on userbase this doesn't do anything?
  • Why is there an empty bugs prefix, e.g.1234 ?
  • techbase and userbase have different interwiki maps, e.g. techbase has no wikipedia prefix, but userbase does e.g. wikipedia:Git; userbase has [[mediawikiwiki:, etc.!

[edit] Stylistic issues

  • Don't capitalize each word in titles and section headings. It Makes the Wiki Look Imperious and Official, it conflicts with the default heading style (See the Toolbox links) and it makes linking to pages in the flow text flow unnatural to read. Compare

[edit] Layout issues

I think all these bugs are in the Chihuahua skin, and they all apply to userbase.kde.org as well.

BUG: In three-column listings like Category:Template , the techbase wiki skin makes the listing overlap the right-hand "Share your Knowledge" column.

BUG: In revision history the

Revision as of 21:55, 20 May 2009 by JRT (Talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

crashes into the light header with [View the content page] [Discussion about the content page] icons.

BUG: justified text looks bad in a narrow window. Allow ragged right column

BUG: when you select, the highlight color makes highlighted text look identical to a link. Try it, select this text and link Schedules and this text. You can't tell!

MAYBE: pre text just goes on and on off the right side. Consider using the wrap attribute of pre so that stuff wraps.

[edit] TechBase problems fixed!

  • I fixed Template:Template to explain what it does.
  • I pulled in Template:Tl from Wikipedia, so that instead of fiddling with {{ you can use e.g. {{bug}} to generate a nicely-formatted {{bug}} which is also a link to a template.
  • I revived a "Browsing the code" section in Getting Started, it's critical! Someone deleted the old "Getting the source" section.

[edit] Searching and browsing source

I brought back Getting Started#Browsing the code but the situation is confusing. There are three systems that let you browse and search source code:

http://projects.kde.org
The git repositories, most KDE source code is in Git these days.
http://api.kde.org
API docs generated from the source code, but you can also scroll down and click to view the source code
http://lxr.kde.org
Cross-reference to files and names in the KDE source code.

But they give different results. Try searching for the class StrigiIndexWriter in 4.x ("the trunk"?) in each, or equivalently the file nepomukindexwriter.cpp

BUG: Ideally api.kde.org would generate a link to the actual file in Git.

[edit] Nepomuk indexing mystery

I'm slogging through all this crap to try to figure out why Nepomuk isn't indexing my NTFS volumes. It could be something to do with "System Settings > Nepomuk/Strigi config > File indexing > Removable media handling > Ignore all removable media", but I can't find the glue that links this KCM with the actual indexing. I know this is in nepomuk/kcm/nepomukserverkcm.cpp (No thanks to the three search engines, I found it in Google), but searching for "RemovableMedia" doesn't find anything.

The result is .kde/share/config/nepomukstrigirc gets:

 [RemovableMedia]
 ask user=false
 index newly mounted=false

but I can't find these terms in KDE source.


This page was last modified on 15 November 2011, at 02:29. This page has been accessed 3,755 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal