Difference between revisions of "User:Lemma/GPU-Performance"

Jump to: navigation, search
(NVIDIA Linux driver 177.70 beta)
 
(2 intermediate revisions by 2 users not shown)
Line 1: Line 1:
{{Template:I18n/Language Navigation Bar|User:Lemma/GPU-Performance}}
 
{{warning|Before making any changes to your system, please read everything carefully and try to understand what you are doing. If you're modifying any files on your system, keep copies of the unmodified version and be sure you can revert to those old version - even if your Xserver is not starting any longer.}}
 
  
{{warning|Some of the changes mentioned below are said to '''increase the temperature of your GPU'''. In any case, monitor your graphic card to make sure it isn't getting too hot!}}
 
  
= Primer =
+
{{note|This page has been moved to Userbase. The new URL is: http://userbase.kde.org/GPU-Performance.}}
  
Several popular graphics cards out there - especially NVIDIA ones - exhibit performance problems with KDE4. These performance hits mostly concern [[Projects/Plasma|Plasma]] - the KDE4 desktop - and [[Projects/KWin|KWin]] - the KDE window-manager. Generally speaking this isn't due to KDE4 being unoptimized but a problem with the cards' graphics drivers. This page encompasses certain problems that might arise and how to get rid of them.
+
Unfortunately I couldn't keep the history but thanks to everyone contributing information and translations to this page!
 
+
= General hints =
+
 
+
== Graphics driver ==
+
For both of the ''big'' graphics chip manufacturers there's 2 seperate graphics drivers each:
+
 
+
* For NVIDIA cards there's the free '''nv''' and the proprietary '''nvidia''' driver. While KDE4 should work fine with the former, it doesn't offer 3D acceleration, so the latter may be your only choice. <s>All</s> Most NVIDIA subsections herein only refer to the proprietary driver (there's also a 3rd free driver called ''nouveau'' that's currently being written. Unfortunately I don't know how usable it is so far). Due to licensing restrictions most distributions don't install the proprietary driver by default. Please refer to your distribution for information on how to install it.
+
 
+
'''Update:''' Nvidia has recently issued a new beta driver which is supposed to address most of the performance problems seen with KDE4. It can be downloaded in [http://www.nvidia.com/object/linux_display_amd64_177.67.html] 64bit and [http://www.nvidia.com/object/linux_display_ia32_177.67.html] 32bit. You need to add some options to your xorg.conf and enable certain feature at runtime, see [http://www.nvnews.net/vbulletin/showthread.php?t=118088] this post on the NvNews forums for details. '''Note:''' Only install beta drivers if you know what you are doing.
+
 
+
'''Update 2:''' NVIDIA have released a new version 177.68 of beta drivers which fixes a couple of bugs and should improve performance with the KDE 4 OpenGL compositing manager. More info and downloads [http://www.nvnews.net/vbulletin/showthread.php?t=118244 here]. The latest beta version is 177.70 and it should enhance performance when dragging Plasma applets and fix some text rendering performance and corruptions. More info [http://www.nvnews.net/vbulletin/showthread.php?t=118602 here].
+
 
+
 
+
 
+
{{note|TODO: section about radeonhd and fglrx driver - I don't own an ATI card [[User:Lemma|Lemma]]}}
+
 
+
It's usually advisable to stay up-to-date as improvements are being made in the drivers. Thus a first step in improving your KDE4 experience should be checking your current driver and updating if it's outdated. Please refer to your distribution's documentation on how to do that.
+
 
+
While it might further increase performance, I do '''NOT''' recommend installing beta quality drivers because your system's stability will most likely suffer.
+
 
+
== nvidia-settings ==
+
Attributes set using the ''nvidia-settings'' utility aren't permanently saved. Thus you have to set them every time you restart your Xserver. This can be done conveniently by adding the lines to set the features to your <tt>~/.xinitrc</tt>.
+
 
+
== systemsettings ==
+
KDE4's ''systemsettings'' allows you to tweak some kwin settings as well. You can find the settings in ''Desktop -> Desktop Effects -> Advanced Options''. Depending on your card either '''OpenGL''' or '''XRender''' might work better. For OpenGL changing the '''OpenGL mode''' might change performance as well. Please bear in mind that changing some of the tweaks mentioned below might force you to change your settings.
+
 
+
Example:
+
* Setting ''InitialPixmapPlacement'' to 2 might improve plasma's performance but might make kwin hang sometimes.
+
* Setting ''OpenGL mode'' to ''Shared Memory'' might make kwin more responsive again.
+
(note from a user)* Not selecting "Use Vsync" helped a lot in a gforce 6800 (and also on a GeForce 8400M GT).
+
 
+
If for some reason your Xserver hangs after hitting the ''Apply'' button on the dialog and your settings get reverted because you can't confirm your changes in time, try again. Usually it will be faster on one of the subsequent tries. If it doesn't you can still change your settings in <tt>~/.kde4/share/config/kwinrc</tt>.
+
 
+
= Problems =
+
 
+
This section summarizes several symptoms you might encounter and tries to explain possible causes.
+
 
+
== Resizing certain windows is choppy ==
+
;Explanation : This might be due to your card advertising ''ARGB Visuals'' (basically translucency) without having proper support for them. Applications/windows concerned are the plasma desktop, the krunner dialog (Alt+F2), plasma's ''Add new widget'' dialog or a konsole window.
+
 
+
;Test : If you want to make sure this issue is a problem for you, run <pre>$ XLIB_SKIP_ARGB_VISUALS=1 konsole</pre> on the command-line and try to resize the new konsole window (setting the environment variable <tt>XLIB_SKIP_ARGB_VISUALS</tt> turns off ''ARGB visuals''). If it resizes without problems, then this is certainly one of the problems you're facing.
+
 
+
Note: I have found that this fixes Dolphin's preview delay too for me. Please confirm. --[[User:Dpalacio|dpalacio]] 17:33, 27 July 2008 (CEST)
+
 
+
=== General ===
+
 
+
* You can set the BackingStore options in your xorg.conf:
+
<pre>Section "Device"
+
    ...
+
    Option "BackingStore" "true"
+
    ...
+
EndSection "Device"</pre>This works for some (eg. konsole) but unfortunately not all windows.
+
 
+
 
+
* As a last resort you can try setting <tt>XLIB_SKIP_ARGB_VISUALS=1</tt> in your <tt>~/.xinitrc</tt> but this isn't pretty.
+
 
+
=== NVIDIA ===
+
 
+
* You can set the ''IntialPixmapPlacement'' with the ''nvidia-settings'' utility: <pre>$ nvidia-settings -a InitialPixmapPlacement=2</pre> This works for some (but unfortunately not all) NVIDIA cards.
+
 
+
=== NV ===
+
 
+
* You can enable EXA Acceleration
+
<pre>Section "Device"
+
    ...
+
    Option "AccelMethod" "EXA"
+
# optional, may improve performance but introduce visible artifacts
+
#    Option "MigrationHeuristic" "greedy"
+
    ...
+
EndSection "Device"</pre>
+
 
+
Performance will be somewhat better on older X servers (<=1.4.2) and significantly better on the latest prerelease X servers (>=1.4.99.901) with this option.
+
 
+
=== ATI ===
+
 
+
TODO
+
 
+
== Plasma performance is bad ==
+
 
+
;Explanation : Unfortunately the reasons for plasma being choppy seem to be numerous so it's hard to tell where your choppiness comes from.
+
 
+
;Test : Usually plasma performance problems can be seen best on the ''Folder View'' plasmoid. Moving it or scrolling inside the folder might be pretty slow.
+
 
+
=== General ===
+
 
+
* Please make sure this is not (only) related to the '''ARGB Visuals''' mentioned in the above section.
+
 
+
=== NVIDIA ===
+
 
+
* You can set the ''IntialPixmapPlacement'' and the ''GlyphCache'' option with the ''nvidia-settings'' utility: <pre>$ nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1</pre> This works for some (but unfortunately not all) NVIDIA cards. Some cards reportedly work better using <tt>InitialPixmapPlacement=1</tt> (or maybe even <tt>3</tt>)
+
 
+
* Options that are said to work well on 8xxx cards but are untested (by me)
+
** Option "RenderAccel" "True"
+
*** enabled by default
+
** Option "TripleBuffer" "True"
+
*** Enables triple buffering. "Decreases the time an application stalls while waiting for vblank events, but increases latency slightly" (NVIDIA Readme)
+
** Option "DamageEvents" "True"
+
*** Recommended by NVIDIA if running composite+glx, increases performance, enabled by default
+
** Option "UseCompositeWrapper" "True"
+
*** Enables the X server's composite wrapper instead of the builtin one.
+
** Option "AllowIndirectPixmaps" "True"
+
*** Could improve hardware rendering on G80+ cards with more than 256 MB of video memory.
+
** Option "BackingStore" "True"
+
*** Cache overlayed areas in case they get redisplayed later
+
** Option "PixmapCacheSize" "200000"
+
*** allocate said number of pixels for pixmap caches
+
** Option "OnDemandVBlankInterrupts" "True"
+
*** only fire VBlank interrupts in modes where they are needed
+
 
+
=== ATI ===
+
 
+
TODO
+
 
+
== Folder View and other plasmoids look badly rendered ==
+
 
+
;Explanation : Folder View and some other plasmoids use hardware accelerated rendering. There are two methods to do this, and Plasma requires the newer EXA method.
+
 
+
;Test : This is best seen on the ''Folder View'' widget, which will appear as a distorted and seemingly random region on the screen.
+
 
+
=== Open Source radeon driver ===
+
 
+
The Open Source radeon driver uses the older XAA hardware acceleration method. To work around this issue, you have to change the 2D acceleration method from XAA (X Acceleration Architecture) to the newer EXA. As this involves editing your xorg.conf file, bear in mind that such a modification may damage your system. ''Do it at your own risk''.
+
 
+
To make the switch, edit your xorg.conf file (make a backup just in case) and locate the Device section for your graphics card. Add the line
+
 
+
<pre>Option "AccelMethod" "EXA"</pre>
+
 
+
before the "EndSection" line. If there is already a line with AccelMethod, change it from XAA to EXA. Save the file and restart the X server.
+
Notice that EXA is still marked as unstable, and that some other applications such as some KDE3 programs may render incorrectly.
+
 
+
When using EXA it is strongly recommended to use a recent X server, at least 1.4.2 or even better the 1.5 release candidates.
+
 
+
= Links/References =
+
 
+
* [http://www.nvnews.net/vbulletin/showthread.php?t=118088] -- Performance tweaks to the 177.67 Nvidia beta driver
+
* [http://www.nvnews.net/vbulletin/showthread.php?t=115916] -- Thread about graphics issues on the NVIDIA forums.
+

Latest revision as of 16:33, 15 July 2012


noframe
 
Note
This page has been moved to Userbase. The new URL is: http://userbase.kde.org/GPU-Performance.

Unfortunately I couldn't keep the history but thanks to everyone contributing information and translations to this page!


This page was last modified on 15 July 2012, at 16:33. This page has been accessed 55,740 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal