Talk:Projects/KDE on Windows/Installation

Jump to: navigation, search

Use this page to record your experiences with KDE on Windows.

Before reporting problems with the installer please make sure that you are using the latest installer version because your problem may already be fixed.


Click the + tab and enter ~~~~ as the subject to add your experiences. Include both your installer version and the KDE version (from the "installed" column for the kde* package names in the installer, or from the Help > About KDE dialog).

Please use only meaningful descriptions (the content will be edited). The software is in early beta now. The installer will receive usability improvements before the final release.

Contents

4.00.80 progress - skierpage (18 February 2008)

Amarok installs a phonon package, and sounds play!

Enabling sound in KHangMan doesn't work, when it tries to play .ogg file it crashes. Amarok hangs at 98% CPU trying to play .ogg file. This could be my Windows install of codecs, but .ogg files play fine in WMP, VLC, MPC, etc.

KHelpCenter: Search doesn't return anything (known issue). Top sections such as "Welcome to KDE" and "KDE Users' Manual" don't do anything (bug #158030).

Clicking on known filetypes in Dolphin gives C:/Program Files/KDE/share/applications/kde4/some app.desktop' is malformatted. alert (bug #156442). You can't run a .exe from Dolphin, it prompts you to choose an application to open it with (bug #158034).

Help > Report Bug still broken.

A Blog "review" with screenshots - MrCopilot (30 January 2008)

See http://mrcopilot.blogspot.com/2008/01/can-kde-save-dying-windows-platform.html , with screenshots and comments on many KDE applications running in MS Windows.

Version 0.8.5 notes - 75.128.118.56 (26 January 2008)

Since I am not what you call a Linux guru, I tried initially installing as an end-user. However, that seems to not install certain things, and once you have made that choice, there is no going back - you can't change the installer settings from End User to Developer, and I think that may be why several packages are not being installed (for example, the kruler.exe program is not installed, and is not available to be installed)

kruler.exe is part of kdegraphics, and as "Status" says, not currently packaged

Another example: When running konquerer.exe, if I type http://www.google.com into the search bar, it complains about the following missing files: konq_aboutpage.dll, libkhtmlpart.dll, and katepart.dll. None of those files were available to install. Perhaps they are available if you say you are a developer, but I had no way to test that because the buttons that select end user or developer are grayed out.

Works for me, did you set KDEDIR and add the lib directory to your PATH as per "Summary of Steps"?

I do have one request, after you get the problems fixed, please consider adding krusader to the list of supported packages.

Skierpage 11:33, 18 January 2008 (CET) using 3.97

Here's User:Skierpage's experience using kdewin-installer-gui-0.8.4-4.exe to install 3.97 2007-12-31 files on Windows XP SP2.

Continuing

  • No khelpcenter, so no Help > Program Handbook
  • Help > Report Bug... > Launch Bug Report Wizard still does nothing (bug #156689 filed)
  • Problems trying to save and open files in apps, KDE complains about their mime type. Fixed by new Post-install steps on install page!
  • Get Hot New Stuff still has problems trying to run gpg.exe.
please file bugs at B.K.O. (bugs.kde.org) --SaroEngels 01:11, 25 January 2008 (CET)

File Open Dialog

  • clicking Network icon crashes (bug #156080 filed, fixed in 4.00.80 it displays Local Network)
  • clicking Home icon does nothing (bug #156690 filed, still true in 4.00.80).
  • clicking Root shows Custom in file path. (still true in 4.00.80).
  • DebugView shows several [5940] class QStringList __thiscall Solid::Backends::Hal::HalManager::findDeviceByDeviceInterface(const enum Solid::DeviceInterface::Type &) error: "org.freedesktop.DBus.Error.ServiceUnknown"

Specific Apps

KStars

  • during startup or Setup Wizard outputs kstars(5344) class KStarsDateTime __cdecl KStarsDateTime::fromString(const class QString &): "Could not parse Date/Time string: " ""
  • can't view Web pages from Object Details dialog > Links > View Resource. No error, but no activity. Possibly at the same time saw output "[5344] kstars(5344)/kdeui (KNotification) void __thiscall KNotification::slotReceivedIdError(const class QDBusError &): Error while contacting notify daemon "The name org.kde.knotify was not provided by any .service files"

"

I know this last error - but I don't know another fix than kill all apps and restart yet. --SaroEngels 01:10, 25 January 2008 (CET)

Issues

Skierpage 07:43, 5 November 2007 (CET) on 2007-11-03

Here's User:Skierpage's experience partially installing files with kdewin-installer-gui-0.8.1-2.exe on Windows XP SP2.

Some of my problems were caused by the KDE Installer silently failing to install kdebase bin.

General

Each app's Help > Handbook fails to start

About the time I tried the handbook the program couldn't find the KDE crash handler drkonqi.exe.

Submit Bug Report fails to load anything when you click [Launch Bug Wizard]; nothing displays in Process Monitor or DebugView.

Okular and KStars crashed just after trying to access ksyscoca and then "launching kbuildsycoca4". I ran kbuildsycoca4 by hand and then both applications got further.

My display got garbled, displaying what looks like a backing store of the current window in the top left. This first happened with kolf.exe, then happened to KDE Installer. Closing every K* app seemed to cure it.

Specific apps

bovo, kblackbox, kgeography pixeltool, etc. worked fine.

Dolphin

1. Even after following instructions in kbuildsycoca4 section below, still mime type id not getting picked up. In the information section it "shows type: mime" instead of correct type. Because of the same reason, I think, it shows all the elements with same icon (binary) including directories.

Fixed in 4.00.80 after running "Post-install steps"

2. If icon is clicked, open with dialog opens and if I choose kate from the list following error box appears "Service 'C:/KDE 4.0/share/applications/kde4/kate.desktop' is malformatted"

Still happens in 4.00.80

KStars

Looks awesome. In the list of cities in setup, accented characters appear incorrectly as multiple characters, as if the encoding is off. See screenshot.

When I clicked [Download extra data], it crashes. In DebugView, last thing it tried to do was open ksycoca and then launch kbuildsycoca4.

After running kbuildsycoca4 and restarting, KStars [Download extra data] created a "Get Hot New Stuff", but that window was obscured by both KStars and its wizard. It had a [Close] button but would not accept input. I was able to [Cancel] the KStars setup window, at which point both the KStars and Get Hot New Stuff windows appeared. There was nothing in Get Hot New Stuff for "KStarsAdd On Installer" (sic -- word layout bug), so I clicked [Close].

Had some problems adding a new location (fumbled original data). Steps to reproduce: Settings / geographic. Add a new location (Foo, norway). Realize something went wrong, edit latitude (change from say 10 10 10.00 to 11 11 11.00). Click OK. Choose OK to Override data. OK out. Open Setting/geographic again - there are now two Foos with location == original, expected was one, updated location.

kbuildsycoca4

As this seemed to be causing problems, I ran it myself in a command window. It said "kbuildsycoca4 running..." then exited, seemingly OK.

The problem is another one: kbuildsycoca4 builds the readonly database ksycoca in C:\Documents and Settings\USER\.kde\ . That requires update-mime-database to have been successfully run.

So after each installation: 1. kill all processes: kioslave.exe, klauncher.exe, kded4.exe 2. enter kdeenv.bat (or a your cmd with KDEROOT set) run: cd %KDEROOT% %KDEROOT%\bin\update-mime-database %KDEROOT%\share\mime %KDEROOT%\bin\kbuildsycoca4 --noincremental

update-mime-database prints lots of warnings; ignore them. Only an error that you should rerun it as root, means that you are in the wrong directory. - Change to kderoot and rerun.

kbuildsycoca has a similar issue: if there are still some processes accessing ksycoca it will ask you whether your disk is full. You should kill all processes that are accessing this file (see process explorer from sysinternals.com ) and rerun it.

This stuff is due to be run by the installer or by emerge. I will hopefully fix this in the next few days. Until then this has to be run by hand. --SaroEngels 01:08, 25 January 2008 (CET)

KColorChooser

crashes when you choose "Named Colors" from the list. (It fails to open several .mo files and .js files, then tries to read rgb.txt from various X11 directories and obviously it's not there, and then crashes.)

kruler

kruler's cursor in North or South orientation shows the vertical arrowhead and line but has black and white garbage on the other half of it where the selection point would be.

okular

First time it started klauncher.exe process but hung without displaying anything. I killed the okular process and tried again; second time okular crashed; DebugView indicated it was trying to open ksyscoca, and when that failed it tried to launch ksyscocabuilder.exe:

 [4644] okular(4644)/kdecore (KSycoca) bool __thiscall KSycocaPrivate::checkDatabase(class QFlags<enum KSycocaPrivate::BehaviorIfNotFound>): We have no database.... launching  kbuildsycoca4

After running kbuildsycoca4 by hand okular appeared OK. When I chose File > Open I got an alert

 Windows - No Disk
 Exception Processing Message c00000013 Parameters hex hex hex

I clicked [Continue] and got this alert again. I think each time Windows was spinning up my empty floppy or CD-ROM drive. Then the file dialog appeared but also an alert

 Error - okular
 The process for the file protocol died unexpectedly.

Meanwhile DebugView showed

 [2916] not able to find 'kio_file' because KDEDIRS environment variable is not set. 
 [2916] Set KDEDIRS to the KDE installation root dir and restart klauncher to fix this problem.

I clicked Root in the file dialog and okular generated a ton of DebugView output in kdecore (KUrl) and then crashed.

I followed the instructions about setting up KDEDIRS, killed klauncher.exe, restarted Okular. I still got errors about No Disk but no more "file protocol death". Howeer, clicking Root in the file dialog still generates a ton of DebugView output and Okular crashes.

Even when I navigate to a folder with .png images in it, Open a document displays nothing. Even if I choose PNG image, it displays nothing. However, if I enter *.png in the Filter, it displays appropriate files.

However, choosing a png file results in okular displaying

 Can not find a plugin that is able to handle the passed document

and then an error alert. Same for selecting a *.bmp.

Weirdly, entering *.jpg in the Filter immediately exits okular, with no errors.

KBUILDSYCOCA4
UPDATE_MIME_TYPE_ERROR --SaroEngels 00:52, 25 January 2008 (CET)

ktouch

Exits, DebugView shows

 [3452] ASSERT failure in class Phonon::PlatformPlugin *__thiscall Phonon::FactoryPrivate::platformPlugin(void): "The plugin 'C:/KDE4/lib/kde4/plugins/phonon_platform/kde.dll' uses incompatible Qt library. (Cannot mix debug and release libraries.)", file D:\kde-msvc\tmp\kdelibs-beta4-3.95.1.20071029\work\kdelibs\phonon\factory.cpp, line 283
In 4.00.80 displays friendlier alert "Unable to use the Fake Multimedia Backend: The shared library was not found."

kbruch

The accelerator [Alt+e] for [Next Task] does not work.

KDE World Clock

Is pitch dark. The tooltip shows current city and add flag works. DebugView shows:

 [4524] QImage::scaled: Image is a null image
 [4524] QPainter::begin: Paint device returned engine == 0, type: 3
 [4524] QPainter::setCompositionMode: Painter not active
 [4524] QPainter::begin: Paint device returned engine == 0, type: 2

Its context menu has Map Theme > Surface Depth / Flat World / Surface Depth / Flat World , i.e. two entries repeated. Whatever you choose is checked twice.

I can't uncheck Show Daylight, Show Cities, Show Flags in the context menu, they remain checked.

All fixed in 4.00.80 version!

kteatime

It does display a fabulous notification bubble from the system tray when the tea is ready! Howeer, DebugView indicates "error while contacting knotify server" (I had configured KTeaTime to Play a sound, Show a message in a popup and Mark taskbar entry) :

 [6052] kteatime(6052)/kdeui (KNotification) unsigned int __thiscall KNotificationManager::notify(class KNotification *,const class QPixmap &,const class QStringList &,const class QList<struct QPair<class QString,class QString> > &,const class QString &): error while contacting knotify server 

khangman

It put up a dialog towards the back about progress, but unlike earlier app, that completed and it then worked great. I chose to, roughly. get words in a new language, chose France from the dialog/ Get Hot New Stuff showed up and worked but displayed an alert:

 Error - KHangMan
 Cannot start gpg and retrieve the available keys.  Make sure that gpg is installed, otherwise verification of the downloaded resources will be impossible.

I installed gpgme and reran khangman, but now Get Hot New Stuff, did not display any categories.

I changed settings to play sounds and it immediately crashed with

 [6072] ASSERT failure in class Phonon::PlatformPlugin *__thiscall Phonon::FactoryPrivate::platformPlugin(void): "The plugin 'C:/KDE4/lib/kde4/plugins/phonon_platform/kde.dll' uses incompatible Qt library. (Cannot mix debug and release libraries.)", file D:\kde-msvc\tmp\kdelibs-beta4-3.95.1.20071029\work\kdelibs\phonon\factory.cpp, line 283

I got around this crash by editing khangmanrc to disable audio. Still nothing in Get Hot New Stuff.

Kig

It worked pretty well, I was able to save a .kig file. It kept prompting

 Format not supported - Kig
 Kig does not support saving to any other format than its own.  
 [Save Kig Format] [Cancel]

but if I choose "Save Kig Format" I get the alert again. Only cancel worked to save the file.


However, when I tried to open that file, the Open dialog displayed its type as "plain text document", opening it led to a "Format Not Supported" alert. DebugView showed:

 [5432] kig(5432)/kdecore (KUrl) __thiscall KUrl::KUrl(const class KUrl &): KUrl::KUrl(KUrl)   path  ""  toLocalFile  ""
 [5432] kig(5432) bool __thiscall KigPart::openFile(void): mimetype:  "text/plain"

So there are problems with mime type handling. (It's scary that mime problems will stop a program from editing a file, how do I force it?)

UPDATE_MIME_TYPE_ERROR --SaroEngels 00:50, 25 January 2008 (CET)
Yup, fixed now with your "Post-install steps", thanks!

KWordQuiz

I was able to download French vocabulary, but when I dismissed it, I got the same alert as KHangMan once displayed

 Cannot start gpg and retrieve the available keys.  Make sure that gpg is installed.

kdelibs/knewstuff/knewstuff2/core/security.cpp is trying to start gpg in a new KProcess. I don't have `gpg` in my path, I'm not sure what package it's in.

PLEASE ASSIGN TO B.K.O --SaroEngels 00:49, 25 January 2008 (CET)

KGoldRunner

The background appears but none of the tiles, and the icons for them in Create New Game are missing. So some directory is missing, could be C:\KDE4\share\pixmaps NAME NOT FOUND, I don't know where the tiles should be.

PLEASE ASSIGN TO B.K.O --SaroEngels 00:48, 25 January 2008 (CET)

KMail

kdepimlibs-msvc-4.1.0, kdepim-msvc-4.0.83-1 KMail won't start because of missing dlls:

gpgme-qt.dll not found

libgpg-error-0.dll not found

my solution: download gpgme-*bin.zip and gpgme-*lib.zip from the kde-repository (directory win32libs) and unzip into your KDE Folder. Installer does not seem to realize this dependency

sqlite3.dll not found

my workaround: sqlite3.dll is not available in the kde repository. Download the current sqlitedll-3*.zip from http://www.sqlite.org/download.html and unzip into your path (I unzipped into kde/bin).

KMail now started.

KolourPaint

Seems to work fine except that when at times when I close it (haven't diagnozed further), the printer suddenly prints out three completely blank papers... Odd.


installation

I tried the installer, but found it very inconvenient. It is very slow in downloading, does not support broken download, had no resume support etc... An option be given to download the required packages through torrent / download express etc. and then run the Installer from downloaded directory. An ISO image to download entire package may also be good idea. What about Localized KDE? I could not found that option either.

bug reports

After several minutes trying to find an adress to submit bug reports for kde on windows I report here that I have given up! This site is the only one I found to tell anyone about the problems.

Please post a link to a forum/bugreport engine or some email address.

Please try to help copy the bugs to http://bugs.kde.org. Try to set Platform MS Windows. Please have a look after your bugs. -- SaroEngels 00:46, 25 January 2008 (CET)

Download needed packages

Question: where are the lists of what's in each package? Having packages like "kdebase-apps..." isn't very useful unless you know which apps are actually in the package.

Unnecessarities in packages?

Some things I noticed:

  • A lot of packages come with both release and debug binaries. The latter one are completely useless, at least to end users. It may be more sensible to separate debug binaries into their own packages.

rhabacker: where do you have seen this ? the qt bin package for example only contain end user applications and libraries. Debug libraries are located in the lib packages which are only installed in developer mode.

  • There seem to be mingw+msvc versions even for seemingly C libraries, e.g. dbus. Such libraries are usually easily exchangeable between compilers (e.g. an MSVC compiled library with a C interface usually works w/ MinGW without problems). Perhaps this is an opportunity to remove some unnecessary packages?

chehrlic: All is fine here, we need it the way it is. We also know how to use mingw libs with msvc and vice versa but it only works under specific circumstances which are not met here.


FIXLATER - SaroEngels 00:41, 25 January 2008 (CET)
No change here - chehrlic 07:04, 25 January 2008 (CET)

Wishes

Everything's workin' perfect. But am i able to fully transform windows desktop environment into KDE ?

jstaniek 18:31, 30 January 2008 (CET) - short answer is NO. Not in the default setup, I guess. The transformation would break many native apps. Even if that can be fixed (really?), most users would still consider any such a full transformation as a breakage of the OS. What to do? As you apparently ask about replacing every part of Windows with KDE equivalents, just install Linux, BSD, etc. and and get all that immediately and natively.

Will kdegraphics be included in the next release? Will the next release be built from 4.0.1 or 4.0.60 sources(from Dirk Mueller's snapshots)?

First attempt at using ANY KDE installer for windows... - 212.32.82.218 ( 9 February 2008)

Guys - it's interesting that i'm in the position of needing to use KDE. I would use Linux in some form without ever going near Windows.

However, I need to provide support for many customers who need Windows and so am stuck with it.

So here we are, I want to get the features of some KDE and then I notice this site.

All goes well... used the latest installer.

It goes well, and the installer stops.

The next instructions are to add Path references. Did that.

Then it is time for the fun...

bin\update-mime-database C:\KDE4\share\mime is the command to run next...

I've restarted so I expect it to do something specific. Nothing... then an error message.

Also, tried different options during the install process but got no further...

"Update-mime-database - Unable to Locate Component" "This application has failed to start because libintl3.dll was not found. Re-installing the application may fix this problem."

I have no idea where to go, i've removed and reinstalled and get the same effect. I'm clearly being thick so will continue to search for the answer myself but any pointers would be lovely.

Cheers all.

rhabacker: This looks like a dependency problem - which requires to know which mirror you are using - without this information we cannot help.

dkintheuk: OK I posted the link i used in the body of this post. http://www.winkde.org/pub/kde/ports/win32/installer/kdewin-installer-gui-latest.exe I'm not sure what you mean by a dependancy problem - what do i look for and how do i determine what you guys need to know to help? Thanks for getting back to me though i do appreciate it.

dkintheuk: ok it's alive - used the next installer and it indicated that several components were not installed even though the previous installer said they were. I have amarok running right now and tried out some interesting things but can't get one thing to work...

I can't get bin\update-mime-database C:\KDE4\share\mime to work at all - it tells me that it doesn have permissions - yet it most definitely does... tested and tested and tested - permissions are properly set.

Ah well - happy bunny here - this is really fun.

Someone somewhere wants to uninstall...

I want to know how to uninstall it. Thanks

(Please sign your edits with ~~~~!) I'm guessing something like:
  • In TaskMgr.exe processes, shut down kded4, dbus-daemon, klauncher, etc.
  • Run kdewin-installer, click each installed package until it shows a garbage can, then complete the installer
  • Remove lib directory from %PATH% and the KDEDIRS environment variable (see Projects/KDE on Windows/Installation#Summary_of_Steps
  • clean up your Download Path of all the downloaded packages, and delete your install directory.
-- Skierpage 23:00, 26 February 2008 (CET)

218.214.47.219 08:35, 3 April 2008 (CEST) KDE 4.00.61 / Amarok

Installer: kdewin-installer-gui-0.9.1-1.exe Amarok: 20080211 Everything else: 4.0.61

Amarok is not playing any sound, the position adjustment bar is also disabled. Tried reinstalling to no avail.

85.180.249.201 12:10, 28 May 2008 (CEST)

kdewin-installer-gui-0.9.2 KDE 4.0.80

Right click in Konqueror is broken. Shift-deleting files in the file Manager is really really slow, and the software will hang for some seconds.

Another thing: KDE should write its settings to %APPDATA% not just in the Userfolder.

kdewin-installer-gui-0.9.2.exe

I have an empty "download server" textearea (or only the last url I added).

I add urls but always I have empty "package selection" textarea. Any idea? I'm on XP pro SP2.

Thx, -- 80.156.46.53 16:35, 10 June 2008 (CEST)

instalando KOffice en Vista

Bajé el kdewin-installer-gui-0.9.2.exe. Lo ejecuté, solicitó varias cosas: End User, y los paquetes, escogi Spanish, arrancó, dió la ventana de finalización, donde manifiesta que los programas están en el folder BIN, pero resulta que no existe ese folder. ¿qué pasó aquí?

118.160.84.128 07:08, 3 July 2008 (CEST)

great concept! some apps don't work because of missing .dlls but the main reason that i wanted KDE is because my new notebook forces me to use Vista (hard to come back to windows after a few years of only linux), and Kmail is not being packaged! i also love Akgregator, and it suffers the same fate. please package Kmail at least! that would make it easier for me to migrate back to linux after the M70S becomes supported in linux.

thanks Michael J. Klein

Phonon dlls for multiple backends 116.12.230.41 14:15, 4 August 2008 (CEST)

When I installed Amarok, no sound came out. Apparently, the phonon_backend folder was empty. You can find the dll to populate this folder by installing quarkplayer here

Version 4.1.00 (KDE 4.1.0), Installer: 0.9.2 -- Akhmad Fathonih

Glen.Ansley 22:59, 10 November 2008 (UTC)

The main reason for using this was for Amorak.

I am using KDE 4.1.3 and Amorak 1.94.

I had to edit .kde\share\config\kioslaverc and add the following lines to get traffic going through my proxy, as the normal tool (kcmshell4 proxy) wouldn't work!

[Proxy Settings] ProxyType=1 ftpProxy=http://proxy.domainhere.com:8000 httpProxy=http://proxy.domainhere.com:8000 httpsProxy=http://proxy.domainhere.com:8000 NoProxyFor=localhost

Obviously proxy.domainhere.com:8000 is the actual name and port of "your" proxy if you wish to use one!

All in all. Things seem to be ticking along nicely. Maybe this information would be nice to add to the "Fine-Tuning" section on http://techbase.kde.org/Projects/KDE_on_Windows/Installation#Fine-tuning ?

Where is KOffice 2?

Hoping to try out Krita, I learned that it's available as part of KOffice, and that KOffice 2 (presumably still beta) is available through the KDE installer. Except that it isn't: not in KDE 4.1.3, not in 4.1.2, not in 4.1.1. There is a "UNSTABLE 1.9.95.10" version in KDE 4.1.0, but why would I want such an extremely obsolete package? Are there alternative installation approaches?

1.9.95.10 isn't necessarily obsolete. Since it's beta they probably just haven't versioned it 2.0 yet, as with amarok2 that's on version 1.94. — 83.251.203.70 11:02, 25 November 2008 (UTC)

KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal