Talk:Projects/KDE on Windows/Installation

Jump to: navigation, search

Use this page to record your experiences with KDE on Windows. Click the + tab and enter ~~~~ as the subject to add your experiences. Include your installer version.

Contents

Skierpage 07:43, 5 November 2007 (CET) on 2007-11-03

Here's User:Skierpage's experience partially installing files with kdewin-installer-gui-0.8.1-2.exe on Windows XP SP2.

General

Each app's Help fails to start

Most (all?) apps print "[2180] kmahjongg(2180)/kdecore (KIconLoader): Error: standard icon theme "oxygen" not found!" in DebugView. Prior to this alert ProcessView shows

20910	10:25:18.5194281 PM	kruler.exe	3792	QueryOpen	C:\Documents and Settings\S Page\.kde\share\apps\kruler\icons\oxygen	PATH NOT FOUND	
20911	10:25:18.5195058 PM	kruler.exe	3792	QueryOpen	C:\KDE4\share\apps\kruler\icons\oxygen	PATH NOT FOUND	

However I do have a C:\KDE4\share\icons\oxygen directory.

The app toolbar in KMahjongg and Kolf is too tall (but that's probably the missing oxygen icons!), see screenshot.

Submit Bug Report fails to load anything when you click [Launch Bug Wizard]; nothing displays in Process Monitor or DebugView.

Okular and KStars crashed just after trying to access ksyscoca and then "launching kbuildsycoca4". I ran kbuildsycoca4 by hand and then both applications got further.

My display got garbled, displaying what looks like a backing store of the current window in the top left. This first happened with kolf.exe, then happened to KDE Installer. Closing every K* app seemed to cure it.

Specific apps

bovo, kgeography pixeltool, etc. worked fine.

KStars

Looks awesome. In the list of cities in setup, accented characters appear incorrectly as multiple characters, as if the encoding is off. See screenshot.

When I clicked [Download extra data], it crashes. In DebugView, last thing it tried to do was open ksycoca and then launch kbuildsycoca4.

After running kbuildsycoca4 and restarting, KStars [Download extra data] created a "Get Hot New Stuff", but that window was obscured by both KStars and its wizard. It had a [Close] button but would not accept input. I was able to [Cancel] the KStars setup window, at which point both the KStars and Get Hot New Stuff windows appeared. There was nothing in Get Hot New Stuff for "KStarsAdd On Installer" (sic -- word layout bug), so I clicked [Close].

kbuildsycoca4

As this seemed to be causing problems, I ran it myself in a command window. It said "kbuildsycoca4 running..." then exited, seemingly OK.

KColorChooser

crashes when you choose "Named Colors" from the list. (It fails to open several .mo files and .js files, then tries to read rgb.txt from various X11 directories and obviously it's not there, and then crashes.)

kruler

kruler's cursor in North or South orientation shows the vertical arrowhead and line but has black and white garbage on the other half of it where the selection point would be.

okular

First time it started klauncher.exe process but hung without displaying anything. I killed the okular process and tried again; second time okular crashed; DebugView indicated it was trying to open ksyscoca, and when that failed it tried to launch ksyscocabuilder.exe:

 [4644] okular(4644)/kdecore (KSycoca) bool __thiscall KSycocaPrivate::checkDatabase(class QFlags<enum KSycocaPrivate::BehaviorIfNotFound>): We have no database.... launching  kbuildsycoca4

After running kbuildsycoca4 by hand okular appeared OK. When I chose File > Open I got an alert

 Windows - No Disk
 Exception Processing Message c00000013 Parameters hex hex hex

I clicked [Continue] and got this alert again. I think each time Windows was spinning up my empty floppy or CD-ROM drive. Then the file dialog appeared but also an alert

 Error - okular
 The process for the file protocol died unexpectedly.

Meanwhile DebugView showed

 [2916] not able to find 'kio_file' because KDEDIRS environment variable is not set. 
 [2916] Set KDEDIRS to the KDE installation root dir and restart klauncher to fix this problem.

I clicked Root in the file dialog and okular generated a ton of DebugView output in kdecore (KUrl) and then crashed.

I followed the instructions about setting up KDEDIRS, killed klauncher.exe, restarted Okular. I still got errors about No Disk but no more "file protocol death". Howeer, clicking Root in the file dialog still generates a ton of DebugView output and Okular crashes.

Even when I navigate to a folder with .png images in it, Open a document displays nothing. Even if I choose PNG image, it displays nothing. However, if I enter *.png in the Filter, it displays appropriate files.

However, choosing a png file results in okular displaying

 Can not find a plugin that is able to handle the passed document

and then an error alert. Same for selecting a *.bmp.

Weirdly, entering *.jpg in the Filter immediately exits okular, with no errors.

ktouch

Exits, DebugView shows

 [3452] ASSERT failure in class Phonon::PlatformPlugin *__thiscall Phonon::FactoryPrivate::platformPlugin(void): "The plugin 'C:/KDE4/lib/kde4/plugins/phonon_platform/kde.dll' uses incompatible Qt library. (Cannot mix debug and release libraries.)", file D:\kde-msvc\tmp\kdelibs-beta4-3.95.1.20071029\work\kdelibs\phonon\factory.cpp, line 283

kbruch

The accelerator [Alt+e] for [Next Task] does not work.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal