Difference between revisions of "Talk:Projects/KDE on Windows/Installation"

Jump to: navigation, search
(installation: "me too")
(installation)
Line 184: Line 184:
  
 
* I can confirm that problem - happened here too.
 
* I can confirm that problem - happened here too.
 +
* Here the same problem, are there any mirrors one can add manually?
  
 
== bug reports ==
 
== bug reports ==

Revision as of 13:06, 24 January 2008

Use this page to record your experiences with KDE on Windows. Click the + tab and enter ~~~~ as the subject to add your experiences. Include your installer version.

Contents

Skierpage 11:33, 18 January 2008 (CET) using 3.97

Here's User:Skierpage's experience using kdewin-installer-gui-0.8.4-4.exe to install 3.97 2007-12-31 files on Windows XP SP2.

Continuing

  • No khelpcenter, so no Help > Program Handbook
  • Help > Report Bug... > Launch Bug Report Wizard still does nothing.
  • Problems trying to save and open files in apps, KDE complains about their mime type.
  • Get Hot New Stuff still has problems trying to run gpg.exe.

File Open Dialog

  • clicking Network icon crashes (bug 156080 filed)
  • clicking Home icon does nothing
  • clicking Root shows Custom in file path.
  • DebugView shows several [5940] class QStringList __thiscall Solid::Backends::Hal::HalManager::findDeviceByDeviceInterface(const enum Solid::DeviceInterface::Type &) error: "org.freedesktop.DBus.Error.ServiceUnknown"

Specific Apps

KStars

  • during startup or Setup Wizard outputs kstars(5344) class KStarsDateTime __cdecl KStarsDateTime::fromString(const class QString &): "Could not parse Date/Time string: " ""
  • can't view Web pages from Object Details dialog > Links > View Resource. No error, but no activity. Possibly at the same time saw output "[5344] kstars(5344)/kdeui (KNotification) void __thiscall KNotification::slotReceivedIdError(const class QDBusError &): Error while contacting notify daemon "The name org.kde.knotify was not provided by any .service files"

"


Installer A Lame Duck

_ The following concerns 0.8.1-2 and 0.8.2 :

  1. It is NOT an installer - it is a transplanter. Too much has to be done manually to qualify it as an "installer".
  2. It hangs far too often (over 50% in more than a dozen runs).
  3. It lacks a "Select all" option.
  4. It does not report correctly as to what it has done - many of the KDE packages and the QT package show as uninstalled after more than a dozen attempts. And yes, the messages scrolled very prettily. And several times the process ran to the point where I could press the "Finish" button and did so.
  5. It does not have a search option so that one can chase down a missing DLL (e.g. "kdecore.dll").
  6. The error message box after a failed download does NOT give the name of the package that failed nor why it failed (not on server, comm.failure, already on local disk, etc.). I narrowed the failed downloads to some of the "tools".
  7. The process does NOT put either a "Start-Here.html" or some sort of read-me file in the base directory (e.g. "KDE4").

Issues

1)The installer seems to also like to crash. Anyone want to post alternative setup instructions?

2)The installer should not install documentation automatically if the user install the binary package

Skierpage 07:43, 5 November 2007 (CET) on 2007-11-03

Here's User:Skierpage's experience partially installing files with kdewin-installer-gui-0.8.1-2.exe on Windows XP SP2.

Some of my problems were caused by the KDE Installer silently failing to install kdebase bin.

General

Each app's Help > Handbook fails to start

About the time I tried the handbook the program couldn't find the KDE crash handler drkonqi.exe.

Submit Bug Report fails to load anything when you click [Launch Bug Wizard]; nothing displays in Process Monitor or DebugView.

Okular and KStars crashed just after trying to access ksyscoca and then "launching kbuildsycoca4". I ran kbuildsycoca4 by hand and then both applications got further.

My display got garbled, displaying what looks like a backing store of the current window in the top left. This first happened with kolf.exe, then happened to KDE Installer. Closing every K* app seemed to cure it.

Specific apps

bovo, kblackbox, kgeography pixeltool, etc. worked fine.

KStars

Looks awesome. In the list of cities in setup, accented characters appear incorrectly as multiple characters, as if the encoding is off. See screenshot.

When I clicked [Download extra data], it crashes. In DebugView, last thing it tried to do was open ksycoca and then launch kbuildsycoca4.

After running kbuildsycoca4 and restarting, KStars [Download extra data] created a "Get Hot New Stuff", but that window was obscured by both KStars and its wizard. It had a [Close] button but would not accept input. I was able to [Cancel] the KStars setup window, at which point both the KStars and Get Hot New Stuff windows appeared. There was nothing in Get Hot New Stuff for "KStarsAdd On Installer" (sic -- word layout bug), so I clicked [Close].

kbuildsycoca4

As this seemed to be causing problems, I ran it myself in a command window. It said "kbuildsycoca4 running..." then exited, seemingly OK.

KColorChooser

crashes when you choose "Named Colors" from the list. (It fails to open several .mo files and .js files, then tries to read rgb.txt from various X11 directories and obviously it's not there, and then crashes.)

kruler

kruler's cursor in North or South orientation shows the vertical arrowhead and line but has black and white garbage on the other half of it where the selection point would be.

okular

First time it started klauncher.exe process but hung without displaying anything. I killed the okular process and tried again; second time okular crashed; DebugView indicated it was trying to open ksyscoca, and when that failed it tried to launch ksyscocabuilder.exe:

 [4644] okular(4644)/kdecore (KSycoca) bool __thiscall KSycocaPrivate::checkDatabase(class QFlags<enum KSycocaPrivate::BehaviorIfNotFound>): We have no database.... launching  kbuildsycoca4

After running kbuildsycoca4 by hand okular appeared OK. When I chose File > Open I got an alert

 Windows - No Disk
 Exception Processing Message c00000013 Parameters hex hex hex

I clicked [Continue] and got this alert again. I think each time Windows was spinning up my empty floppy or CD-ROM drive. Then the file dialog appeared but also an alert

 Error - okular
 The process for the file protocol died unexpectedly.

Meanwhile DebugView showed

 [2916] not able to find 'kio_file' because KDEDIRS environment variable is not set. 
 [2916] Set KDEDIRS to the KDE installation root dir and restart klauncher to fix this problem.

I clicked Root in the file dialog and okular generated a ton of DebugView output in kdecore (KUrl) and then crashed.

I followed the instructions about setting up KDEDIRS, killed klauncher.exe, restarted Okular. I still got errors about No Disk but no more "file protocol death". Howeer, clicking Root in the file dialog still generates a ton of DebugView output and Okular crashes.

Even when I navigate to a folder with .png images in it, Open a document displays nothing. Even if I choose PNG image, it displays nothing. However, if I enter *.png in the Filter, it displays appropriate files.

However, choosing a png file results in okular displaying

 Can not find a plugin that is able to handle the passed document

and then an error alert. Same for selecting a *.bmp.

Weirdly, entering *.jpg in the Filter immediately exits okular, with no errors.

ktouch

Exits, DebugView shows

 [3452] ASSERT failure in class Phonon::PlatformPlugin *__thiscall Phonon::FactoryPrivate::platformPlugin(void): "The plugin 'C:/KDE4/lib/kde4/plugins/phonon_platform/kde.dll' uses incompatible Qt library. (Cannot mix debug and release libraries.)", file D:\kde-msvc\tmp\kdelibs-beta4-3.95.1.20071029\work\kdelibs\phonon\factory.cpp, line 283

kbruch

The accelerator [Alt+e] for [Next Task] does not work.

KDE World Clock

Is pitch dark. The tooltip shows current city and add flag works. DebugView shows:

 [4524] 
 [4524] QImage::scaled: Image is a null image
 [4524] QPainter::begin: Paint device returned engine == 0, type: 3
 [4524] QPainter::setCompositionMode: Painter not active
 [4524] QPainter::begin: Paint device returned engine == 0, type: 2

Its context menu has Map Theme > Surface Depth / Flat World / Surface Depth / Flat World , i.e. two entries repeated. Whatever you choose is checked twice.

I can't uncheck Show Daylight, Show Cities, Show Flags in the context menu, they remain checked.

kteatime

It does display a fabulous notification bubble from the system tray when the tea is ready! Howeer, DebugView indicates "error while contacting knotify server" (I had configured KTeaTime to Play a sound, Show a message in a popup and Mark taskbar entry) :

 [6052] kteatime(6052)/kdeui (KNotification) unsigned int __thiscall KNotificationManager::notify(class KNotification *,const class QPixmap &,const class QStringList &,const class QList<struct QPair<class QString,class QString> > &,const class QString &): error while contacting knotify server 

khangman

It put up a dialog towards the back about progress, but unlike earlier app, that completed and it then worked great. I chose to, roughly. get words in a new language, chose France from the dialog/ Get Hot New Stuff showed up and worked but displayed an alert:

 Error - KHangMan
 Cannot start gpg and retrieve the available keys.  Make sure that gpg is installed, otherwise verification of the downloaded resources will be impossible.

I installed gpgme and reran khangman, but now Get Hot New Stuff, did not display any categories.

I changed settings to play sounds and it immediately crashed with

 [6072] ASSERT failure in class Phonon::PlatformPlugin *__thiscall Phonon::FactoryPrivate::platformPlugin(void): "The plugin 'C:/KDE4/lib/kde4/plugins/phonon_platform/kde.dll' uses incompatible Qt library. (Cannot mix debug and release libraries.)", file D:\kde-msvc\tmp\kdelibs-beta4-3.95.1.20071029\work\kdelibs\phonon\factory.cpp, line 283

I got around this crash by editing khangmanrc to disable audio. Still nothing in Get Hot New Stuff.

Kig

It worked pretty well, I was able to save a .kig file. It kept prompting

 Format not supported - Kig
 Kig does not support saving to any other format than its own.  
 [Save Kig Format] [Cancel]

but if I choose "Save Kig Format" I get the alert again. Only cancel worked to save the file.


However, when I tried to open that file, the Open dialog displayed its type as "plain text document", opening it led to a "Format Not Supported" alert. DebugView showed:

 [5432] kig(5432)/kdecore (KUrl) __thiscall KUrl::KUrl(const class KUrl &): KUrl::KUrl(KUrl)   path  ""  toLocalFile  ""
 [5432] kig(5432) bool __thiscall KigPart::openFile(void): mimetype:  "text/plain"

So there are problems with mime type handling. (It's scary that mime problems will stop a program from editing a file, how do I force it?)

KWordQuiz

I was able to download French vocabulary, but when I dismissed it, I got the same alert as KHangMan once displayed

 Cannot start gpg and retrieve the available keys.  Make sure that gpg is installed.

kdelibs/knewstuff/knewstuff2/core/security.cpp is trying to start gpg in a new KProcess. I don't have `gpg` in my path, I'm not sure what package it's in.

KGoldRunner

The background appears but none of the tiles, and the icons for them in Create New Game are missing. So some directory is missing, could be C:\KDE4\share\pixmaps NAME NOT FOUND, I don't know where the tiles should be.

installation

I went through the installer (version 0.8.5), and when it got to the select mirror screen, all the mirrors are blank.

I have no idea what to add to the list.

  • I can confirm that problem - happened here too.
  • Here the same problem, are there any mirrors one can add manually?

bug reports

After several minutes trying to find an adress to submit bug reports for kde on windows I report here that I have given up! This site is the only one I found to tell anyone about the problems.

Please post a link to a forum/bugreport engine or some email address.

Download needed packages

I started the installer and ended up with the dialog 'Download needed packages'. The docu says something about manual selection of the dependencies - WTF. On Linux nobody would even think to let the user select manually the required ones out of thousends of packages, but on windows one has to select the required ones out of ~100 Packages ? I would not mind to install every package that might be required, but the installer has no option the select 'all'.

So right now installing a kde application on windows is so frustrating that I give up.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal