Difference between revisions of "Talk:Development/Tutorials/Plasma/GettingStarted"

Jump to: navigation, search
(note about applet install dir)
Line 1: Line 1:
 +
I noticed that to successfully install the plasmoid the kdelibs5-dev package is required. Otherwise CMake throws an error and doesn't compile source code.
 +
[[User:Jakub|Jakub]] 15:56, 27 April 2009 (UTC)
 +
----
 +
 
Maybe I have messed something up, but for me copying applet's shared object file (.so) to $KDEDIR/lib will not work (plasma gives: "Could not find requested component: applet_name"). If I copy same file to $KDEDIR/lib/kde4 plasma will find that.
 
Maybe I have messed something up, but for me copying applet's shared object file (.so) to $KDEDIR/lib will not work (plasma gives: "Could not find requested component: applet_name"). If I copy same file to $KDEDIR/lib/kde4 plasma will find that.
  

Revision as of 16:56, 27 April 2009

I noticed that to successfully install the plasmoid the kdelibs5-dev package is required. Otherwise CMake throws an error and doesn't compile source code. Jakub 15:56, 27 April 2009 (UTC)


Maybe I have messed something up, but for me copying applet's shared object file (.so) to $KDEDIR/lib will not work (plasma gives: "Could not find requested component: applet_name"). If I copy same file to $KDEDIR/lib/kde4 plasma will find that.


In the "The .desktop file" section, the X-KDE-ServiceTypes=Plasma/Applet is right? Because, if you look at the source code of the default widgets of KDE4.1 you see: ServiceTypes=Plasma/Applet I will edit the page to conform this.

--Leokolln 00:28, 26 September 2008 (CEST)


There are some infos about a QRectF boundingRect() method, but no such method defined in the actual code, is that normal ?

maybe setContentSize would be better than resize there... Chani 15:44, 11 February 2008 (CET)


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal