Schedules/KOffice 1.5 Release Schedule

< Schedules
Revision as of 14:24, 23 December 2006 by Tbscope (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

All dates given here are subject to revision, but we will try our best to stick to them if possible.

Boudewijn Rempt is acting as release coordinator for the KOffice 1.5 release.

KOffice 1.5 will be released independently from KDE.

Contents

KOffice 1.5 Beta 1

January 15, 2006

The HEAD branch of KOffice is frozen : no new features, bugfixes commits only, no commit that modifies an application's behaviour, and message freeze. This freeze will last till the release of KOffice 1.5! (Original date: Jan. 12, problems necessitated the slippage.)

January 22, 2006

KOffice is tagged KOFFICE_1_5_BETA1. Tarballs are made out of KOffice, for

KOffice 1.5 Beta 1

They are made public immediately, and given to packagers for creation of binary packages.

January 31, 2006

Announce KOffice 1.5 Beta 1.

February 6, 2006

Documentation is frozen. KPlato documentation will not be frozen before 13th February.

KOffice 1.5 Beta 2

February 23, 2006

Last day for translations.

March 2, 2006

Tag KOffice 1.5 Beta 2 (tags/koffice/1.5-beta2), create source packages.

March 3, 2006

Upload source packages to FTP server.

March 7, 2006

Announce KOffice 1.5 second beta

KOffice 1.5 RC1

March 20 2006

Tag KOffice 1.5 rc1 (tags/koffice/1.5-rc1). Test the tarballs.
This week is for packagers to create binary packages.

March 26, 2006

Create changelogs, update the website

March 27, 2006

Announce KOffice 1.5 RC 1

KOffice 1.5 Final

April 3 2006

Tag KOffice 1.5 final version (tags/koffice/1.5.0). Test the tarballs.
This week is for packagers to create binary packages.

April 10, 2006

The source and binary packages are uploaded to ftp.kde.org to give some time for the mirrors to get them.

April 10, 2006

Create changelogs, update the website

April 11, 2006

Announce KOffice 1.5

Frequently Asked Questions

Which version of Qt is required?

Qt 3.3 or later, but not Qt 4.X

Which version of kdelibs is required?

kdelibs 3.3 or later, but not kdelibs 4.X


This page was last modified on 23 December 2006, at 14:24. This page has been accessed 5,249 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal