Difference between revisions of "Schedules/KDE4/4.0 Requirements"

Jump to: navigation, search
(update)
(add Qt requirement)
Line 10: Line 10:
 
== Software Requirements ==
 
== Software Requirements ==
 
=== Basic ===
 
=== Basic ===
 +
{| border="1" cellpadding="5" cellspacing="0" align=
 +
|-
 +
! Package
 +
! Level
 +
! Description
 +
! Explanation
 +
! Modules
 +
|- valign="top"
 +
| [http://www.trolltech.com Qt >= 4.3]
 +
|style="background:red"| Required
 +
||Qt is the C++ cross-platform GUI toolkit upon which the great majority of KDE is built.
 +
|| Qt is required by all KDE modules.
 +
|| kdelibs,<br> kdepimlibs,<br> kdebase,<br> kdeadmin,<br> kdeartwork,<br> kdebindings,<br> kdeedu,<br> kdegames,<br> kdegraphics,<br> kdemultimedia,<br> kdenetwork,<br> kdepim,<br> kdesdk,<br> kdetoys,<br> kdeutils,<br> koffice,<br> kdevelop
 +
|}
 +
 
=== Help ===
 
=== Help ===
 
=== Hardware ===
 
=== Hardware ===

Revision as of 21:36, 11 December 2007

Contents

KDE 4.0 Compilation Requirements

Compilers

Compiler Requirements. KDE is designed to be portable and hence to compile with a large variety of GNU/Linux, UNIX, Windows and MacOS compilers. However, KDE is advancing very rapidly and the ability of native compilers on various systems to compile KDE depends on users of those systems reporting compile problems to the responsible developers.

In addition, the C++ implementation in gcc/egcs, the most popular KDE compiler, has been advancing rapidly, and has also recently undergone a major redesign. As a result, KDE will not compile properly with older versions of gcc or most newer releases.

In particular, gcc versions earlier than gcc-2.95, such as egcs-1.1.2 or gcc-2.7.2, may not properly compile some components of KDE 3.5. While there have been reports of successful KDE compilations with the so-called gcc-2.96 and gcc-3.4 (cvs), the KDE project at this time recommends the use of gcc-3.3.1 or a version of gcc which shipped with a stable Linux distribution and which was used successfully to compile a stable KDE for that distribution.

Software Requirements

Basic

Package Level Description Explanation Modules
Qt >= 4.3 Required Qt is the C++ cross-platform GUI toolkit upon which the great majority of KDE is built. Qt is required by all KDE modules. kdelibs,
kdepimlibs,
kdebase,
kdeadmin,
kdeartwork,
kdebindings,
kdeedu,
kdegames,
kdegraphics,
kdemultimedia,
kdenetwork,
kdepim,
kdesdk,
kdetoys,
kdeutils,
koffice,
kdevelop

Help

Hardware

Networking

Browsing

Security

Graphics

Multimedia

Development


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal