Projects/Marble/PlasmaActiveEnvironment

< Projects‎ | Marble
Revision as of 21:01, 8 May 2012 by Earthwings (Talk | contribs)

Jump to: navigation, search

Marble Touch supports both the Qt Components for Meego and the Plasma Components (for touch). This article describes how to setup and run marble-touch for Plasma Active (using plasma components in the touch platform variant).

Overview

We'll briefly cover the prerequisites needed -- an installation of Qt 4.7 or later, an installation of the plasma components from KDE 4.9 or later and the setup of environment variables -- and the compilation of Marble. At the time of writing KDE 4.9 was not released yet, so we'll perform a local installation of kdelibs and kde-runtime which in turns brings you the required version of plasma components.

Qt and other System Libraries

Make sure to have a development version of Qt 4.7 or later installed. Qt Declarative support must be there. Marble Touch also requires (at runtime) the following declarative extensions of Qt or Qt related packages that you may have to install separately: QtMobility systeminfo, QtWebKit, Qt labs folderlistmodel.

On a Debianish system, install the following packages:

sudo aptitude install libqt4-dev libqtwebkit-qmlwebkitplugin libdeclarative-systeminfo libqt4-declarative-folderlistmodel

KDE Libraries and Runtime


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal