Projects/KDevelop4/Compatibility

< Projects‎ | KDevelop4
Revision as of 00:33, 28 April 2012 by Nicolas17 (Talk | contribs)

Jump to: navigation, search
KDevelop 4.0 KDevelop 4.1 KDevelop 4.2+
KDE 4.3.x Yes No No
KDE 4.4.x Yes Yes No [1]
KDE 4.5.x Yes Yes Yes [2]
KDE 4.6.x+ No [3] No [3] Yes

[1] KDevelop 4.2 was ported from SmartRanges to MovingRanges, and Kate 4.4 only has SmartRanges.

[2] 4.5.0 and 4.5.1 are unusable (constant crashes), use 4.5.2 or later. There was a critical bug in the MovingRanges implementation that got fixed in trunk (4.6), but the developer didn't remember to backport it to 4.5. It was only noticed and backported in KDE 4.5.2.

[3] KDE 4.6 dropped support for the old SmartRanges in favor of MovingRanges. KDevelop 4.0 and 4.1 only support SmartRanges and not MovingRanges.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal