Difference between revisions of "Projects/KDevelop4/Compatibility"

Jump to: navigation, search
(Add kdevelop 4.4 information)
Line 5: Line 5:
 
! KDevelop 4.1
 
! KDevelop 4.1
 
! KDevelop 4.2
 
! KDevelop 4.2
! KDevelop 4.3<br>(master)
+
! KDevelop 4.3
 +
! KDevelop 4.4<br>(master)
 
|-
 
|-
 
! KDE 4.3.x
 
! KDE 4.3.x
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 +
| style="background-color:red" | No
 
| style="background-color:red" | No
 
| style="background-color:red" | No
 
| style="background-color:red" | No
 
| style="background-color:red" | No
Line 16: Line 18:
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 +
| style="background-color:red" | No <sup>[[#kde44mr|[1]]]</sup>
 
| style="background-color:red" | No <sup>[[#kde44mr|[1]]]</sup>
 
| style="background-color:red" | No <sup>[[#kde44mr|[1]]]</sup>
 
| style="background-color:red" | No <sup>[[#kde44mr|[1]]]</sup>
 
| style="background-color:red" | No <sup>[[#kde44mr|[1]]]</sup>
Line 22: Line 25:
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 +
| style="background-color:red" | Crashes <sup>[[#crash450|[2]]]</sup>
 
| style="background-color:red" | Crashes <sup>[[#crash450|[2]]]</sup>
 
| style="background-color:red" | Crashes <sup>[[#crash450|[2]]]</sup>
 
| style="background-color:red" | Crashes <sup>[[#crash450|[2]]]</sup>
 
| style="background-color:red" | Crashes <sup>[[#crash450|[2]]]</sup>
 
|-
 
|-
 
! KDE 4.5.2+
 
! KDE 4.5.2+
 +
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
Line 34: Line 39:
 
| style="background-color:red" | No <sup>[[#kde46sr|[3]]]</sup>
 
| style="background-color:red" | No <sup>[[#kde46sr|[3]]]</sup>
 
| style="background-color:red" | No <sup>[[#kde46sr|[3]]]</sup>
 
| style="background-color:red" | No <sup>[[#kde46sr|[3]]]</sup>
 +
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes
 
| style="background-color:lime" | Yes

Revision as of 00:19, 28 April 2012

KDevelop 4.0 KDevelop 4.1 KDevelop 4.2 KDevelop 4.3 KDevelop 4.4
(master)
KDE 4.3.x Yes No No No No
KDE 4.4.x Yes Yes No [1] No [1] No [1]
KDE 4.5.0/.1 Yes Yes Crashes [2] Crashes [2] Crashes [2]
KDE 4.5.2+ Yes Yes Yes Yes Yes
KDE 4.6.x No [3] No [3] Yes Yes Yes

[1] KDevelop 4.2 was ported from SmartRanges to MovingRanges, and Kate 4.4 only has SmartRanges.

[2] There was a critical bug in the MovingRanges implementation that got fixed in trunk (4.6), but the developer didn't remember to backport it to 4.5. It was only noticed and backported in KDE 4.5.2. KDevelop is unusable in 4.5.0/4.5.1 without this fix.

[3] KDE 4.6 dropped support for the old SmartRanges in favor of MovingRanges. KDevelop 4.0 and 4.1 only support SmartRanges and not MovingRanges.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal