Getting Started/Build/Requirements/kdelibs by module

< Getting Started‎ | Build‎ | Requirements
Revision as of 22:34, 6 May 2012 by Winterz (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

kdelibs Package Dependencies

Package Level Description Explanation
DBusMenuQt Required Support for notification area menus via the DBusMenu protocol
DocBook XML Required Required by the KDE help system to process DocBook XML XML DTDs for DocBook ${DOCBOOKXML_VERSIONS} and ${DOCBOOKXML_OLDDTD_VERSION} are needed
DocBook XSL Required Required by the KDE help system to process DocBook XML
giflib Required GIF image format support Required by khtml.
libjpeg Required JPEG image format support Required by khtml.
libattica >= 0.1.90 Required Support for Get Hot New Stuff
LibXML2 Required Required by the KDE help system to process DocBook XML
xmllint Required Required by the KDE help system to process DocBook XML
LibXSLT Required Required by the KDE help system to process DocBook XML
Perl Required Needed for building kdelibs
libpng Required PNG image format support Required by khtml.
shared-mime-info >= 0.60 Required Allows KDE applications to determine file types
Strigi >= 0.6.0 Required Desktop indexing and search support Required by some critical kioslaves
ZLib Required Support for gzip compressed files and data streams Required by the core KDE libraries and some critical kioslaves
LibACL STRONGLY RECOMMENDED Support for manipulating access control lists
X Sync Extension (libXext) STRONGLY RECOMMENDED Efficient operation of KIdleTime
Libintl STRONGLY RECOMMENDED Support for multiple languages Enables KDE to be available in many different languages
OpenSSL STRONGLY RECOMMENDED Support for secure network communications (SSL and TLS) KDE uses OpenSSL for the bulk of secure communications, including secure web browsing via HTTPS
X Rendering Extension (libXrender) STRONGLY RECOMMENDED Support for compositing, rendering operations, and alpha-blending
Aspell Optional Spell checking support via Aspell This is not needed for spell checking if Enchant is provided or only Hebrew spell checking is required
Avahi Optional Facilities for service discovery on a local network (DNSSD) Either Avahi or DNSSD is required for KDE applications to make use of multicast DNS/DNS-SD service discovery
Bison Optional Allows the Solid predicate parser to be updated Required by the UpdateSolidPredicateParser target (mainly useful for developers)
DNSSD Optional Facilities for service discovery on a local network Either Avahi or DNSSD is required for KDE applications to make use of multicast DNS/DNS-SD service discovery
Enchant Optional Spell checking support via Enchant
FAM Optional File alteration notification support via a separate service Provides file alteration notification facilities using a separate service.
Flex Optional Allows the Solid predicate parser to be updated Required by the UpdateSolidPredicateParser target (mainly useful for developers)
GSSAPI Optional Allows KIO to make use of certain HTTP authentication services A MIT or HEIMDAL flavor of GSSAPI can be used
Grantlee >= 0.1.0 Optional ModelEventLogger code generation (part of the ProxyModel test suite) Grantlee is used for generating compilable code by the ModelEventLogger. Without Grantlee, the logger will do nothing.
X Screensaver Extension (libXss) Optional Support for KIdleTime (fallback mode)
HSpell Optional Spell checking support for Hebrew Hebrew support can also be provided via Enchant, providing the correct Enchant backends are installed
HUPnP Optional UPnP support for Solid Allows Solid to provide information about UPnP devices on the network
JasPer Optional Support for JPEG-2000 images
media-player-info Optional Enables identification and querying of portable media players Runtime-only dependency of the udev solid backend. Support for m-p-i is included even if not found during build
OpenEXR Optional Support for OpenEXR images
PCRE Optional Perl-compatible regular expressions in KJS Without PCRE, KJS will have extremely poor regular expression support, breaking many webpages.
QCA2 >= 2.0.0 Optional Support for remote plasma widgets
Shared desktop ontologies >= 0.6.50 Optional Support for the Nepomuk semantic desktop system
Soprano >= 2.5.60 Optional Support for the Nepomuk semantic desktop system
Soprano Raptor Parser Optional Support for the Nepomuk semantic desktop system
Soprano Redland Backend Optional Support for the Nepomuk semantic desktop system
UDev Optional UDev support for Solid Allows Solid to use UDev to provide information about devices on Linux

KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal