Difference between revisions of "Getting Started/Build/KDE4 (bn IN)"

Jump to: navigation, search
m (Text replace - "<code bash>" to "<syntaxhighlight lang="bash">")
m (Text replace - "<code>" to "<syntaxhighlight lang="text">")
Line 118: Line 118:
  
 
In Kubuntu 7.04 (Feisty) and Debian (Testing/Unstable) the build dependencies you need are installed with:
 
In Kubuntu 7.04 (Feisty) and Debian (Testing/Unstable) the build dependencies you need are installed with:
<code>
+
<syntaxhighlight lang="text">
 
sudo aptitude install build-essential cdbs debhelper cmake \
 
sudo aptitude install build-essential cdbs debhelper cmake \
 
libxml2-dev libxslt1-dev libbz2-dev libclucene-dev librdf-dev \
 
libxml2-dev libxslt1-dev libbz2-dev libclucene-dev librdf-dev \
Line 133: Line 133:
  
 
In Kubuntu 7.10 (Gutsy) and Debian unstable you also have to add:
 
In Kubuntu 7.10 (Gutsy) and Debian unstable you also have to add:
<code>
+
<syntaxhighlight lang="text">
 
sudo aptitude install dbus-x11  libqt4-dev libqca2-dev libeigen-dev \
 
sudo aptitude install dbus-x11  libqt4-dev libqca2-dev libeigen-dev \
 
libstreamanalyzer-dev libsoprano-dev libstrigiqtdbusclient-dev \
 
libstreamanalyzer-dev libsoprano-dev libstrigiqtdbusclient-dev \
Line 141: Line 141:
  
 
For a fully functional API documentation framework you also need:
 
For a fully functional API documentation framework you also need:
<code>
+
<syntaxhighlight lang="text">
 
sudo aptitude install graphviz
 
sudo aptitude install graphviz
 
</code>
 
</code>
Line 186: Line 186:
  
 
The packages you will need to install are:
 
The packages you will need to install are:
<code>
+
<syntaxhighlight lang="text">
 
xorg-x11-devel
 
xorg-x11-devel
 
libxml2-devel  
 
libxml2-devel  
Line 214: Line 214:
  
 
For openSUSE 10.2 and newer do:
 
For openSUSE 10.2 and newer do:
<code>
+
<syntaxhighlight lang="text">
 
sudo zypper service-add http://software.opensuse.org/download/KDE:/KDE4/openSUSE_10.2 KDE4-102
 
sudo zypper service-add http://software.opensuse.org/download/KDE:/KDE4/openSUSE_10.2 KDE4-102
 
</code>
 
</code>
  
 
For older versions of SUSE Linux do:
 
For older versions of SUSE Linux do:
<code>
+
<syntaxhighlight lang="text">
 
su
 
su
 
installation_sources -a http://software.opensuse.org/download/KDE:/KDE4/[YOUR SUSE LINUX VERSION]
 
installation_sources -a http://software.opensuse.org/download/KDE:/KDE4/[YOUR SUSE LINUX VERSION]
Line 225: Line 225:
  
 
Now install the following packages:
 
Now install the following packages:
<code>
+
<syntaxhighlight lang="text">
 
cmake
 
cmake
 
dbus-1-devel
 
dbus-1-devel
Line 239: Line 239:
  
 
And for fully functional apidox framework you also need:
 
And for fully functional apidox framework you also need:
<code>
+
<syntaxhighlight lang="text">
 
graphviz
 
graphviz
 
</code>
 
</code>
Line 602: Line 602:
 
* Here you need the libungif library, otherwise you will get an error message like "<tt>Could NOT find GIF</tt>".
 
* Here you need the libungif library, otherwise you will get an error message like "<tt>Could NOT find GIF</tt>".
 
* Qt-4.3 upgrade: if you get a link error in kjsembed talking about QScriptEngine, edit CMakeCache.txt in kdelibs and remove the lines that talk about QT_QTUITOOLS_LIBRARY, then type make again (that static library has a new dependency, and the cmake code that adds it needs to run).
 
* Qt-4.3 upgrade: if you get a link error in kjsembed talking about QScriptEngine, edit CMakeCache.txt in kdelibs and remove the lines that talk about QT_QTUITOOLS_LIBRARY, then type make again (that static library has a new dependency, and the cmake code that adds it needs to run).
* if you get <code>CMake Error: KDE Requires Qt to be built with SSL support
+
* if you get <syntaxhighlight lang="text">CMake Error: KDE Requires Qt to be built with SSL support
 
</code>, install openssl-devel, remove CMakeCache.txt and re-compile QT.
 
</code>, install openssl-devel, remove CMakeCache.txt and re-compile QT.
* if you get <code>kdelibs/kimgio/ico.cpp:188: undefined reference to `QImage::jumpTable()'</code> it means you compiled QT without QT3 support(no, linking to a true QT3 install won't work)
+
* if you get <syntaxhighlight lang="text">kdelibs/kimgio/ico.cpp:188: undefined reference to `QImage::jumpTable()'</code> it means you compiled QT without QT3 support(no, linking to a true QT3 install won't work)
* if none of the errors above match yours, you might just try a quick'n'dirty <code>make clean</code> in kdelibs.
+
* if none of the errors above match yours, you might just try a quick'n'dirty <syntaxhighlight lang="text">make clean</code> in kdelibs.
  
 
== kdepimlibs ==
 
== kdepimlibs ==
Line 722: Line 722:
 
Many modules in KDE contain a large number of programs which could take a long time to download and compile. In cases where you want to work only on a particular program or programs in a module, it is possible to download and compile particular folders. In some cases, certain folders are required for any build of the module. This is determined in the CMakeLists.txt file of the module. For example the [http://websvn.kde.org/branches/KDE/4.0/kdegames/CMakeLists.txt?view=markup kdegames CMakeLists.txt file] lists:
 
Many modules in KDE contain a large number of programs which could take a long time to download and compile. In cases where you want to work only on a particular program or programs in a module, it is possible to download and compile particular folders. In some cases, certain folders are required for any build of the module. This is determined in the CMakeLists.txt file of the module. For example the [http://websvn.kde.org/branches/KDE/4.0/kdegames/CMakeLists.txt?view=markup kdegames CMakeLists.txt file] lists:
  
<code>
+
<syntaxhighlight lang="text">
 
add_subdirectory(libkdegames)
 
add_subdirectory(libkdegames)
 
add_subdirectory(libkmahjongg)
 
add_subdirectory(libkmahjongg)
Line 760: Line 760:
  
 
For example for RH/Fedora based distros:
 
For example for RH/Fedora based distros:
<code>  
+
<syntaxhighlight lang="text">  
 
  #%PAM-1.0
 
  #%PAM-1.0
 
  auth      include      system-auth
 
  auth      include      system-auth

Revision as of 21:46, 29 June 2011


Contents

Getting_Started/Build/KDE4


সারসংক্ষেপ

এই সহায়িকা কি ভাবে ট্রান্ক থেকে KDE নিয়ে লিনাক্স/বিসডি সিস্টেমে তা দেখায়। এছাড়াও নিন্মলিখিত ওসগুলির জন্য সহায়িকা অাছে FreeBSD, Windows, Mac OS X and Solaris. পুরো সহায়িকাটি bash সেলের উপর নির্ভর করে লেখা হয়েছে।

noframe
 
Warning
সোমবারে খুব বেশি রকম ভাবে বিল্ড ব্যর্থ হতে পারে, যখন kdelibs বদলগুলি জমা করা হয়. Dashboard অতর্কিত বিল্ডের ব্যর্থতা গুলি দেখায়। অাপনাকে ব্যর্থ মডিউল গুলি সারাতে উৎসাহিত করা হচ্ছে।


দরকারী সফ্টওয়ার

সহায়িকটিকে সফল ভাবে ব্যবহার করার জন্য নিন্মলিখিত স্ফটওয়ারগুলি চাই:

  • gcc and g++, preferably version 4.2 or higher
  • svn, the subversion revision control client
  • pkg-config
  • development libraries and headers for X11, OpenGL (mesa-common-dev and libglu1-mesa-dev), libjpeg, libpng, libungif, libclucene, librdf, libxml2 and libxslt
  • the makeobj স্ক্রিপ্ট, যেটি kdesdk তে অাছে। অাপনি এটা kdesdk (kdesdk-scripts on Debian) বা একি ধরনের প্যাকেজ থেকে, WebSVN থেকে ডাউনলোড করতে পারেন।
  • the shared-mime-info package, এটি freedesktop MIME standard যা KDEতে ব্যবহার হয়।
  • boost, kdebase ব্যবহার করে; বিল্ড বা ইনস্টল করার পরে,cmake কে এটি খুঁজে পাবার জন্য (FindBoost), boost ডাইরেক্টরিটি (যার মধ্যে include সাবডাইরেক্টরি থাকে) CMAKE_INCLUDE_PATH এর মধ্যে অথবা একটি environment variable BOOST_ROOT লেখ যা boost ডাইরেক্টরিটি দেখায়।

Ark Linux

In Ark Linux, the build dependencies you need are installed with:

apt-get install devel-core libxml-devel libxslt-devel bzip2-devel \
clucene-core-devel librdf-devel shared-mime-info xorg-Mesa-libGL-devel \
subversion boost-devel doxygen giflib-devel dbus-devel openssl-devel \
alsa-lib-devel kdesdk-scripts qt4-devel
</code>
 
If you prefer a graphical interface, select the packages listed above in the "Install Software" tool in Mission Control.
 
This includes installation of CMake, DBus and Qt - you can skip steps 5, 6 and 7.
 
=== Arch Linux ===
In Arch Linux you need to install the following packages:
 
<syntaxhighlight lang="bash">
pacman -Sy subversion bzip2 libxslt libxml2 \
shared-mime-info mesa boost dbus openssl \
pkgconfig xine-lib clucene
</code>
 
Ensure you don't have Soprano installed (pacman -R soprano) because Nepomuk won't detect the soprano in kdesupport and thus not build.
 
If you want to use qt4 from the Arch Linux repository you can install it with:
<syntaxhighlight lang="bash">
pacman -Sy qt4
</code>
("pacman -Sy qt" if you are running bleeding-edge Arch Testing)
 
<s>For clucene libraries you need the [http://aur.archlinux.org/packages.php?do_Details=1&ID=5968 PKGBUILD] from AUR.</s>
(No longer needed since clucene has been put into the extra-repo.)
 
=== Fedora ===
 
Some of the required packages for building KDE4 on Fedora 7 or higher:
 
<syntaxhighlight lang="bash">
yum install clucene-core-devel libxml-devel libxslt-devel \
dbus-devel boost-devel bzip2-devel openssl-devel alsa-lib-devel \
redland-devel rasqal-devel raptor-devel hspell-devel aspell-devel \
cups-devel xine-lib-devel avahi-devel gamin-devel OpenEXR-devel \
enchant-devel jasper-devel ilmbase-devel pcre-devel gpgme-devel \
libxklavier-devel glib-devel libusb-devel libsmbclient-devel \
libxcb-devel NetworkManager-devel lm_sensors-devel libraw1394-devel \
bluez-libs-devel gcc-c++ libXext-devel cmake subversion giflib-devel \
libpng-devel libXdamage-devel libXcomposite-devel libXrender-devel \
fontconfig-devel libXft-devel libXcursor-devel libXfixes-devel \
ruby-devel libXScrnSaver-devel libkdcraw-devel exiv2-devel \
lcms-devel libtiff-devel sqlite-devel libxkbfile-devel \
imlib2-devel patch gstreamer-plugins-base-devel
</code>
 
Some optional packages for koffice support:
<syntaxhighlight lang="bash">
yum install qca2-devel gsl-devel freeglut-devel \
GraphicsMagick-c++-devel GraphicsMagick-devel
</code>
 
This includes installation of D-Bus and CMake -- you can skip steps 5 and 6.
 
DCH-10/15/07: Note - It may be simpler to spin RPMs. Note that you can edit the variables in /etc/rpm/macros.kde4 (which is provided by Rawhide kde-filesystem).
 
The build stage then looks like:
 (but in what directory?)
%build
 
mkdir -p %{_target_platform}
 
pushd %{_target_platform}
 
%{cmake_kde4} ..
 
popd
 
make %{?_smp_mflags} -C %{_target_platform}
 
I have had better results with creating a kdesupport rpm which means that you should not install the soprano and strigi rpms. YMMV
 
telsh: On a Fedora 8 System I had to install "qt4-devel" too to have qmake.
 
=== Kubuntu and Debian ===
 
In Kubuntu 7.04 (Feisty) and Debian (Testing/Unstable) the build dependencies you need are installed with:
<syntaxhighlight lang="text">
sudo aptitude install build-essential cdbs debhelper cmake \
libxml2-dev libxslt1-dev libbz2-dev libclucene-dev librdf-dev \
shared-mime-info libgl1-mesa-dev libglu1-mesa-dev mesa-common-dev \
libxext-dev libjpeg-dev libpng12-dev subversion libsm-dev libxinerama-dev \
libxrender-dev libfontconfig-dev libboost-dev libxcursor-dev doxygen \
libungif4-dev libdbus-1-dev libssl-dev libgpgme11-dev \
libasound2-dev kdesdk-scripts libpth-dev libjasper-dev \
ssh libxine-dev libqimageblitz-dev libqimageblitz4 libglib2.0-dev \
libxkbfile-dev libenchant-dev libbluetooth-dev network-manager-dev \
libsmbclient-dev libxcb1-dev libcaptury-dev libxcomposite-dev \
libxdamage-dev libusb-dev libgpgme11-dev libldap2-dev
</code>
 
In Kubuntu 7.10 (Gutsy) and Debian unstable you also have to add:
<syntaxhighlight lang="text">
sudo aptitude install dbus-x11  libqt4-dev libqca2-dev libeigen-dev \
libstreamanalyzer-dev libsoprano-dev libstrigiqtdbusclient-dev \
libxklavier11-dev libxml2-utils libdbus-1-dev libxslt1-dev cmake libbz2-dev \
libungif4-dev libgpgme11-dev libboost-dev libxine-dev libxkbfile-dev
</code>
 
For a fully functional API documentation framework you also need:
<syntaxhighlight lang="text">
sudo aptitude install graphviz
</code>
 
There is no need to compile qt or kdesupport on kubuntu gutsy. All required packages are provided by installing the above. Setup the kde4 user etc as explained in the next section, but skip over compiling qt, hal and kdesupport.
 
{{Note|
If you get something trouble on compile KDE4
Beta4 or above in Kubuntu 7.10, such as :
 
Soprano version is too low
 
strigi xxx.h not found...
 
You may need to checkout, and compile the relevant part of
kdesupport source code in the SVN server of KDE4. (svn://anonsvn.kde.org/home/kde/trunk/kdesupport/soprano/)  
 
This is covered when you get to the section on compiling kdesupport.
 
You might also have to remove any installed soprano package : sudo apt-get remove libsoprano4 libsoprano-dev
 
If you still get an error in the kdelibs section about soprano like:
CMake Error: Error in cmake code at
$src/KDE/kdelibs/cmake/modules/FindSoprano.cmake:78:
FILE Internal CMake error when trying to open file: /usr/include/soprano/version.h for reading.
 
then delete kdelibs/CMakeCache.txt
}}
 
=== openSUSE ===
 
In openSUSE 10.2 and newer, you can install packages using [http://en.opensuse.org/Zypper Zypper]:
<syntaxhighlight lang="bash">
sudo zypper install <package-name>
</code>
 
In older releases of SUSE, you can use YaST:
<syntaxhighlight lang="bash">
su
yast -i <packagename>
</code>
 
'''Required Packages'''
 
The packages you will need to install are:
<syntaxhighlight lang="text">
xorg-x11-devel
libxml2-devel 
kdesdk3 
clucene-core-devel 
boost-devel
libjpeg-devel 
liblrdf-devel 
libpng-devel 
libxslt-devel 
libredland-devel
Mesa-devel 
giflib-devel 
subversion 
gcc 
gcc-c++
gmp-devel (needed to build kdesupport)
gpgme-devel (needed to build kdepimlibs)
libxine1-devel
</code>
 
'''Optional Packages'''
 
You can skip the manual and painful installation kdesupport and its dependencies ( Qt 4.3, CMake 2.4.6, DBus, Hal, clucene-core, Strigi,
Soprano and other Nepomuk dependencies) by adding the KDE:KDE4 repository from
the [http://download.opensuse.org/repositories/KDE:/KDE4/ openSUSE Build Service] to your installation sources. 
 
For openSUSE 10.2 and newer do:
<syntaxhighlight lang="text">
sudo zypper service-add http://software.opensuse.org/download/KDE:/KDE4/openSUSE_10.2 KDE4-102
</code>
 
For older versions of SUSE Linux do:
<syntaxhighlight lang="text">
su
installation_sources -a http://software.opensuse.org/download/KDE:/KDE4/[YOUR SUSE LINUX VERSION]
</code>
 
Now install the following packages:
<syntaxhighlight lang="text">
cmake
dbus-1-devel
libqt4-devel
libqca2-devel
libsoprano-devel
libqimageblitz-devel
strigi
strigi-ui
</code>
 
There are a lot more packages that are needed to satisfy the config-check, such as libusb-devel, bison etc., so look out for the config notifications and install accordingly. Please remember to skip any instructions that refer to kdesupport below. Start to compile with kdelibs. 
 
And for fully functional apidox framework you also need:
<syntaxhighlight lang="text">
graphviz
</code>
 
CMake binary packages for openSUSE are available from the KDE:KDE4 repository as well as from the [http://software.opensuse.org/download/devel:/tools:/building/ openSUSE build service].
 
=== Gentoo ===
 
==== Install by hand ====
 
You can use stable ebuilds just remember to sync your portage before you begin.
 
Remember: All commands are executed as root.
 
Required:
 
We need to allow the following keyword masked ebuilds.
 
<syntaxhighlight lang="bash">
echo 'dev-util/cmake' >> /etc/portage/package.keywords
echo 'dev-cpp/clucene' >> /etc/portage/package.keywords
</code>
 
Make sure you have set the berkdb USE flag for redland, otherwise nepomuk won't work.
 
<syntaxhighlight lang="bash">
echo 'dev-libs/redland berkdb' >> /etc/portage/package.use
echo 'x11-libs/qt accessibility' >> /etc/portage/package.use
</code>
 
These are the packages you will need to emerge, I included the update option into the emerge command so you will not re-emerge anything that you might already have installed.
 
<syntaxhighlight lang="bash">
emerge -avu 'sys-devel/gcc' \
  'dev-util/subversion' \
  'dev-util/pkgconfig'  \
  'x11-base/xorg-x11' \
  'virtual/glut' \
  'media-libs/mesa' \
  'media-libs/jpeg' \
  'media-libs/libpng' \
  'media-libs/giflib' \
  'dev-cpp/clucene' \
  'dev-util/cppunit' \
  'media-libs/liblrdf' \
  'dev-libs/libxml2' \
  'dev-libs/libxslt' \
  'x11-misc/shared-mime-info' \
  'dev-libs/boost' \
  'dev-util/cmake' \
  'dev-libs/redland' \
  'sys-apps/dbus' \
  'sys-apps/hal' \
  'x11-libs/qt'
</code>
 
You will also need to emerge either 'kde-base/kdesdk' or kde-base/kdesdk-scripts'.
 
If you emerged DBUS, CMAKE, QT or HAL you may skip those sections respectively.
Good luck!
 
==== Install via portage ====
 
Also you can install the KDE 4 packages directly via 
<syntaxhighlight lang="bash">
emerge -a <packagename>
</code>
 
To get the things you need, [http://gentoo-wiki.com/TIP_Overlays#Layman install layman] and then pull in the "kde" overlay (which contains experimental KDE ebuilds): 
<syntaxhighlight lang="bash">
layman -a kde
</code>
After this you need to adjust some USE-flags for KDE 4 and tell portage to use the testing KDE 4 ebuilds instead of the stable KDE 3 ones. 
 
That way portage will do the dependency tracking for you. 
 
Detailed instructions on building KDE 4 in Gentoo via portage can be found in the [http://overlays.gentoo.org/proj/kde/wiki KDE overlay wiki]. They are discussed in the forum thread [http://forums.gentoo.org/viewtopic-t-530111-postdays-0-postorder-asc-start-0.html KDE 4 monolithic ebuilds], which is continued [http://forums.gentoo.org/viewtopic-p-4359581.html#4359581 here]
 
=== Mandriva ===
In Mandriva the build dependencies you need are installed with:
 
<syntaxhighlight lang="bash">
urpmi gcc-c++ cmake libxml2-devel libbzip2_1-devel \
libclucene0-devel liblrdf2-devel libmesagl1-devel \
subversion doxygen libdbus-1_3-devel libopenssl0.9.8-devel \
libalsa2-devel libgpgme-devel libboost1-devel libxine-devel
</code>
 
If you're running 64-bit environment you should replace all packages starting with "lib..." to "lib64...".
 
If you prefer a graphical interface, select the packages listed above in the "Install Software" tool in Mandriva Linux Control Center.
 
This includes installation of CMake, DBus - you can skip steps 5 and 6.
 
== Create a user account for KDE4 development ==
 
{{Note|
Some people like to have a separate user account for KDE 4 (for instance an old bug deleted files by mistake), and the instructions below were written with that approach.
 
However it is much more efficient to do everything with a single user account, see [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts|Increased Productivity in KDE4 with Scripts]]
for more details. 
 
You can still follow the instructions below, but don't put the environment variables in your <tt>.bashrc</tt>, put them in a separate file that you source to switch to the KDE 4 environment.
}}
 
=== Option 1: Command Line ===
<syntaxhighlight lang="bash">
useradd -m kde-devel
passwd kde-devel
</code>
 
 
{{Warning|
The new kde-devel user will not be added automatically to all the user groups, which will result in not having sound, not being able to sudo, etc. Edit your /etc/groups file to add the kde-devel user to all the groups that you need (probably the groups that your usual username is already assigned to).
}}
 
=== Option 2: Using KControl ===
 
Instead of using the commands above, you can also use the User module in the KDE Control Center if you already have KDE3 installed.
 
=== Setting up the environment ===
 
Copy the {{path|~/.bashrc}} from your normal user account to the new kde-devel account. Next, copy and paste the contents of the [[Getting Started/Increased Productivity in KDE4 with Scripts/.bashrc|example .bashrc]] into {{path|~kde-devel/.bashrc}}. Be sure to comment out the line <tt>alias make=makeobj</tt> if you do not have the <tt>[[Getting Started/Build/KDE4#Required Software|makeobj]]</tt> command available. You will probably also want to modify the path to make sure it doesn't include your kde3 paths. Also if you want to use KDevelop to develop KDE 4 applications you may pass the ''-GKDevelop3'' flag to the ''cmake'' command (to make CMake generate KDevelop project files, it will help to avoid rebuilding in the future, see [[Getting_Started/Set_up_KDE_4_for_development#Setting_up_the_environment|this]]).  
To make it run, you have to open a new bash or to execute 
<syntaxhighlight lang="bash">
source ~/.bashrc
</code>
 
This will provide access to commands such as <tt>cmakekde</tt> that are used in this tutorial as well as ensure that the proper paths are in place for Qt, KDE and CMake binaries.
 
For more information, please read the [[Getting Started/Increased Productivity in KDE4 with Scripts]] tutorial.
 
=== Switching to the New User ===
Switch to the user kde-devel: (don't forget the dash)
<syntaxhighlight lang="bash">
ssh -X kde-devel@localhost
</code>
 
{{Note|
If the ssh command fails, check out the [[Getting_Started/Set_up_KDE_4_for_development#Launching_KDE_4_apps|Launching KDE 4 apps]] section of the [[Getting_Started/Set_up_KDE_4_for_development|KDE4 development guide]].
}}
 
== The development user's shell ==
 
On some systems a new user is configured by default to use {{path|/bin/sh}}. If this is not the case on your system, you can skip this section. Using {{path|/bin/sh}} can be very inconvenient to work with and you may want to change it to {{path|/bin/bash}} or another shell.
On Ark Linux and Fedora, you can skip this step - {{path|/bin/sh}} is {{path|bash}}.
 
=== Option 1: As the kde-devel user ===
 
If you don't have root privileges and your system supports the changing of your own shell with the <tt>chsh</tt> application, then you could try to change your shell to {{path|/bin/bash}} by using:
<syntaxhighlight lang="bash">
chsh -s /bin/bash kde-devel
</code>
 
=== Option 2: As the root user ===
 
If your system comes with the <tt>usermod</tt> application you can run the following command as root: <tt>usermod -s /bin/bash kde-devel</tt>.
 
Another option is to use the <tt>vipw</tt> application as root to safely edit your {{path|/etc/passwd}}. Locate 'kde-devel' in the the file. Change '{{path|/bin/sh}}' at the end of the line to read '{{path|/bin/bash}}', save your changes and exit.
 
The new shell will be started automatically when you log in as the kde-devel user again.
 
== D-Bus ==
QtDBus and KDE are known to work with D-Bus versions 0.62, as well as 0.92 and upwards. Versions 0.60 and 0.61 may work too but are not tested. Versions 0.90 and 0.91 are known not to work. We recommend using post-1.0 release versions (at least 0.94), so consider upgrading if you haven't done so.
 
You may skip this section if you have a recent D-Bus version or if you don't want to upgrade. You probably want to skip building the bindings until/unless you know you will be building HAL (see below).
 
Before running these steps in the recipe, make sure your X11 headers and libraries are available. The configure script run on line 5 of the following instructions should output:
 Building X11 code:        yes
 
=== The Recipe ===
 
{{tip|Make sure you did set up your environment correctly as described [[Getting_Started/Build/KDE4#Setting_up_the_environment|above]]. This is necessary for the <tt>cs</tt> and <tt>cb</tt> functions to work.}}
 
 cs # [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|'cs' is a bash function, click here to learn more]] 
 wget http://dbus.freedesktop.org/releases/dbus/dbus-1.0.2.tar.gz
 tar -xvzf dbus-1.0.2.tar.gz
 cd dbus-1.0.2/
 ./configure --prefix=$DBUSDIR --localstatedir=/var
 make
 sudo make install
 sudo dbus-uuidgen --ensure
 
 cs # see above
 wget http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-0.74.tar.gz
 tar -xvzf dbus-glib-0.74.tar.gz
 cd dbus-glib-0.74/
 ./configure --prefix=$DBUSDIR
 make
 sudo make install
 cd
 sudo chown -R kde-devel:kde-devel *
 
=== What's Happening === 
After changing into the source directory (line 1), D-Bus source code is downloaded from freedesktop.org (line 2) and unpacked (line 3). After going into the newly created D-Bus directory (line 4), the build is set up using the supplied {{path|configure}} script (line 5). After building (line 6) and installing (line 7) D-Bus, we use the <tt>dbus-uuidgen</tt> tool to install a machine identification file that allows the bus to start automatically when the desktop session starts (line 8).
 
Note that you need write access to {{path|/var}} for the last two steps. If your system does not have the sudo command, you can use the <tt>su</tt> command instead, e.g. <tt>su -c "make install"</tt>.
 
The steps for building the glib bindings are similar to the above.
 
When these two packages are done building, we must fix the file ownership because 'sudo make install' has created root owned files and directories in ~kde-devel/kde.
 
== CMake ==
Skip this if you have [http://cmake.org/ CMake] >=2.4.5 installed. 
You should be able to directly use the binary packages available on the [http://www.cmake.org/HTML/Download.html CMake site]. There are also distribution specific packages available.
 
=== The Recipe ===
<!--'cs' and 'cb' are NOT typos!-->
 
 cs # [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|'cs' is a bash function, click Here to learn more]] 
 wget http://www.cmake.org/files/v2.4/cmake-2.4.6.tar.gz
 tar -zxf cmake-2.4.6.tar.gz
 mkdir cmake-build
 cd cmake-build 
 ../cmake-2.4.6/bootstrap
 make
 sudo make install
 
=== What's Happening ===
First, we go back to the <tt>kde-devel</tt> user's source directory (line 1), get the CMake sources (line 2) and unpack them (line 3). We create a directory to build CMake in (line 4) and go into it (line 5). We then run the CMake bootstrap script to set up the CMake build (line 6), then make (line 7) and install it (line 8) using the root user.
 
If your system does not have the <tt>sudo</tt> command, you can instead do <tt>su -c "make install"</tt>.
 
== Qt ==
Next we need to get Qt4. KDE is guaranteed to build against any Qt 4.3. Qt 4.2 and earlier are not supported and will not work. 
 
If your distribution has a recent version of Qt4, that should work. Most distros backport bugfixes, and some distros, like Debian or openSUSE, even use the patches from KDE svn. In other cases, using the recipe below will give you a more stable Qt than your distro. Refer to the distribution specific sections above for more information. 
 
As for now Qt3 compatibility layer in Qt 4 is mandatory, so please <b>avoid</b> using "-no-qt3support" option when building Qt4 from sources.
 
=== The Recipe ===
 cd # Note: qt-copy lives in $HOME/qt-copy. See $QTDIR in [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|<font color=red>.bashrc</font>]] 
 svn checkout svn://anonsvn.kde.org/home/kde/trunk/qt-copy
 cd qt-copy
 ./apply_patches
 ./configure -qt-gif -no-exceptions -debug -fast \
  -prefix $QTDIR -nomake examples -nomake demos
 make -j2
 
 # if we don't install, we'll just clear obj files to
 # save disk space
 if [ $QTDIR = `pwd` ]; then \
 find . -name '*.o' -delete ; \
 else make install; fi;
 
=== What's Happening ===
We switch back to the <tt>kde-devel</tt> user's home directory (line 1) and download the source code using subversion (svn) from KDE's repository (line 2). After changing into the resulting {{path|qt-copy}} directory (line 3), we run a script that manages the patches that come with <tt>qt-copy</tt> (line 4). 
 
Once the patches have been applied, we then set up the build using the <tt>configure</tt> script (line 5-6). The various command line options used are explained in the {{path|qt-copy/README.qt-copy}} file. Finally, we build the minimal requirements for KDE (line 7) and install (line 10) Qt. If install dir is the same as the current dir (line 8), then we just free some space (line 9) instead. If you want all the example and demo applications, you can either build them individually or simply do a <tt>make</tt> from the {{path|qt-copy}} directory. 
 
Note that the installation does not require root as it installs Qt locally into {{path|$QTDIR}}. Anyway, installation is only needed if {{path|$QTDIR}} differs from {{path|$HOME/qt-copy}}, which is not the case if you have exactly followed the instructions.
 
=== Troubleshooting ===
If you get "error: X11/Xlib.h: No such file or directory", install the devel package of <tt>xorg</tt> (the actual name may vary between operating systems, for example it is <tt>xorg-dev</tt> on Ubuntu based systems such as Kubuntu). 
 
If you get an error in the configure step about missing defines, check the value of <tt>$QMAKESPEC</tt>.  Some distributions set this to point directly to the system-installed Qt.  If <tt>unset QMAKESPEC</tt> solves the problem, you probably want to add it to the <tt>~/.bashrc</tt> script.
 
If you get an error ".pch/debug-shared/QtCore", this is because Qt-4.3 enables precompiled headers if your gcc supports it, but for some reason it doesn't work for you. If you use distcc, configure qt with -no-pch. If you use icecream, update to the latest icecream from svn trunk.
 
Try running any Qt program, like {{program|assistant}}. '''Note:''' You may need to run <tt>xhost +local:kde-devel</tt> as your regular kde3 user to run this application.  If it crashes in QSpanData::adjustSpanMethods, then your problem is the oxygen style. Try removing {{path|lib/kde4/plugins/styles/kstyle-oxygen.so}} and {{path|lib/kde4/plugins/styles/oxygen.so}} if they exist in the KDE install prefix.
 
== HAL ==
 
{{tip|You can use qdbusviewer to see if you have org.freedesktop.hal. If not, you might need a newer version of hal. If you have org.freedesktop.hal, you probably don't need to, and don't ''want'' to, roll your own HAL.}}
 
If your system requires you to build a newer version of HAL, there's a decent chance you'll need to build other stuff as well, some of which may not be straight forward. However, this should only be required for older distros.
 
== kdesupport ==
 
{{warning|Don't forget to read the [[Getting_Started/Build/KDE4#Setting_up_the_environment|Setting Up The Environment]] section first.}}
 
There are several libraries that KDE applications rely on in the kdesupport module. This includes Strigi and Soprano for file metadata and search, QImageBlitz for image manipulation needed in kdebase, eigen for visual effects in applications such as Kalzium, taglib for music players and qca for some cryptographic needs. 
 
Strigi itself has a few dependencies as well: you will need the libraries and headers for libz, libbz2, openssl (libcrypto or libssl), libclucene (>=0.9.16a but watch out: version 0.9.17 does '''not''' work), and either libxml2 or libexpat.
 
Please remember that if you use openSUSE, you can install the needed packages from the KDE:KDE4 buildservice repository and do not have to bother with fiddling the details below. Skip to the kdelibs section. 
 
=== The Recipe ===
<!--'cs' and 'cb' are NOT typos!-->
 cs # [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|'cs' is a bash function, click here to learn more]]
 svn checkout svn://anonsvn.kde.org/home/kde/trunk/kdesupport/
 cd kdesupport
 cmakekde
 
=== What's Happening ===
We change to the base source directory (line 1). We download the sources in kdesupport using subversion (line 2), go into the new {{path|~/kde/src/kdesupport}} directory (line 3), and commence the build (line 4). This will leave us in the kdesupport build directory after the build is completed.
 
=== Troubleshooting ===
If you get 
   cmakekde: command not found
then you have to go manually into the kdesupport directory in ~ and execute the command cmakekde. if this still doesn't work, then something is wrong with your bashrc.
 
If you get 
 CMake Error: This project requires some variables to be set,
 and cmake can not find them.
 Please set the following variables:
 LIBXML2_INCLUDE_DIR (ADVANCED)
you should install the development package for libxml2.
 
If you get 
 CMake Error: Could NOT find REDLAND
then you need librdf from the Redland.
If your distribution does not provide the librdf package, you can download the source there: [http://download.librdf.org/source/ http://download.librdf.org/source/] and build it.
(Gentoo users: The ebuild for librdf is named dev-libs/redland)
 
If you get
 Fetching external item into 'kdesupport/admin'
 Error validating server certificate for 'https://...'
see [http://techbase.kde.org/Getting_Started/Sources/Using_Subversion_with_KDE Using Subversion with KDE]
 
If you get
 FILE cannot create directory: /usr/lib[64]/qt4/plugins/crypto. Maybe need administrative privileges.
 
 make: *** [install] Error 255
take a second look in the .bashrc file described above, are paths correct?  ($QTDIR and $PATH are used to get the QT installation path)
Alternatively, you may see this error if you decided to use a distribution installed version of qt4 and skipped the Qt install above.  Either install qt-copy as describe above, or "sudo make install". If you use "sudo make install", make sure that you change the ownership back to your user for some of the ~/kde subdirectories that were effected by using sudo (ie. "<tt>sudo chown -R kde-devel:kde-devel ~/kde</tt>").
 
If you get a message related to 
   target libQtTest.so not found
you may need to recompile qt-copy. This time you should take out
   -nomake demos -nomake examples
from the configure command, so that Qt generates library QtTest.
 
== kdelibs ==
 
We can now move on to building KDE's base libraries.
 
=== The Recipe ===
 cd   
 cs # [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|'cs' is a bash function, click here to learn more]]
 mkdir KDE && cd KDE
 svn checkout svn://anonsvn.kde.org/home/kde/branches/KDE/4.0/kdelibs
 cd kdelibs
 cmakekde
 
=== What's Happening ===
We change to the base source directory (line 1) then make and go into the KDE directory (line 2). We download the sources for kdelibs using subversion (line 3), go into the new {{path|~/kde/src/KDE/kdelibs}} directory (line 4), and commence the build (line 5). This will leave us in the <tt>kdelibs</tt> build directory after the build is completed.
 
{{tip|There might be missing dependencies on your system! They are easily overlooked in the output of <tt>cmakekde</tt>.
You might want to do a <tt>cmake $KDE_SRC/KDE/MODULE_NAME</tt> prior to compiling any kde modules (like kdelibs, kdepimlibs etc.)}}
 
=== Additional KDE-specific CMake modules ===
There are additional CMake modules in {{path|kdelibs/cmake/modules/}} that are necessary for building KDE4 applications. These will be installed for you when  kdelibs itself is installed.
 
=== Troubleshooting ===
If you have problems compiling kdelibs, first make sure the software in the [[Getting_Started/Build/KDE4#Software_Requirements|Required Software]] section above is installed and works. Other possible hints include:
* If the <tt>cmakekde</tt> command fails stating that CMake requires an out of source build directory, remove {{path|~/kde/src/KDE/kdelibs/CMakeCache.txt}}, and try again.
 
If <tt>cmakekde</tt> still gives the same error then try this 
 cd
 cmake -DCMAKE_INSTALL_PREFIX=$KDEDIR \
 -DCMAKE_BUILD_TYPE=debugfull \
 -DKDE4_BUILD_TESTS=ON \
 ~/kde/src/KDE/kdelibs
 make
 make install
* If you received an error stating "Please create a separate build directory and run 'cmake path_to_kdelibs [options]' there.", then you need to change to your build directory before running cmakekde. (e.g <tt>cs KDE/kdelibs && cb && cmakekde</tt>) If the message stays, run 'svn status' in the kdelibs directory and remove all files labeled with '?'.
* If Qt wasn't found or the wrong version of Qt was found, make sure that the qmake from the Qt you need is the first qmake in the path.
* If qmake wasn't found and you are using Debian packages, /usr/bin/qmake probably points to a wrong qmake version. To fix this run as root:
 update-alternatives --config qmake
* If the problems persist, try the CMake make-option <tt>--keep-going</tt>.
* Here you need the libungif library, otherwise you will get an error message like "<tt>Could NOT find GIF</tt>".
* Qt-4.3 upgrade: if you get a link error in kjsembed talking about QScriptEngine, edit CMakeCache.txt in kdelibs and remove the lines that talk about QT_QTUITOOLS_LIBRARY, then type make again (that static library has a new dependency, and the cmake code that adds it needs to run).
* if you get <syntaxhighlight lang="text">CMake Error: KDE Requires Qt to be built with SSL support
</code>, install openssl-devel, remove CMakeCache.txt and re-compile QT.
* if you get <syntaxhighlight lang="text">kdelibs/kimgio/ico.cpp:188: undefined reference to `QImage::jumpTable()'</code> it means you compiled QT without QT3 support(no, linking to a true QT3 install won't work)
* if none of the errors above match yours, you might just try a quick'n'dirty <syntaxhighlight lang="text">make clean</code> in kdelibs.
 
== kdepimlibs ==
After <tt>kdelibs</tt>, but before ''kdebase'', you need to build and install ''kdepimlibs''.
 
=== The Recipe ===
<!--'cs' and 'cb' are NOT typos!-->
 cs KDE # [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|'cs' is a bash function, click here to learn more]]
 svn checkout svn://anonsvn.kde.org/home/kde/branches/KDE/4.0/kdepimlibs
 cd kdepimlibs
 cmakekde
 
=== What's Happening ===
We go into the KDE source directory (line 1), download the source code for kdepimlibs using subversion (line 2) and then go into the new {{path|~/kde/src/KDE/kdepimlibs}} directory (line 3). We then commence the build (line 4). This will leave us in the <tt>kdepimlibs</tt> build directory after the build is completed.
 
=== Troubleshooting ===
If you have trouble compiling kdepimlibs:
* the cmakekde command may require a later version of the gpgme library.  This is available from the project's web site: http://www.gnupg.org/(en)/download/index.html - please note that the build of gpgme also requires libgpg-error, also available from the same location.  Both libraries are installed by the "./configure", "make" and "sudo make install" sequence, with the gpgme library configured with the additional "--with-gpg-error-prefix" parameter.  You may need to overwrite your existing "/usr/bin/gpgme-config" file with the newer version for the kdepimlibs to pick up the new install.
 
== kdebase ==
kdebase is divided into three parts:
* '''apps'''
:This contains applications like Dolphin or KWrite.
* '''runtime'''
:This contains things needed by every application at runtime, like icons. It is a required dependency for each KDE application, so you have to compile and install this.
* '''workspace'''
:This contains things specific to the KDE desktop, like Plasma or the window manager. Most stuff here depends on X11. You only need it if you want to build a full KDE desktop.
 
You can build all of kdebase at once, which is described in the recipe below. If you only want to build kdebase-runtime, which is the only requirement, you can replace <syntaxhighlight lang="bash">cd kdebase</code> with <syntaxhighlight lang="bash">cd kdebase/runtime</code> in the recipe below.
 
=== The Recipe ===
<!--'cs' and 'cb' are NOT typos!-->
 cs KDE # [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|'cs' is a bash function, click here to learn more]]
 svn checkout svn://anonsvn.kde.org/home/kde/branches/KDE/4.0/kdebase
 cd kdebase
 cmakekde
 
=== Troubleshooting ===
If you have troubles compiling kdebase:
* Make sure you have the <tt>libxss headers</tt> installed. (Usually you got undefined references on xscreensaver objects if you do not have those headers)
* <tt>which meinproc</tt> has to deliver {{path|/home/kde-devel/kde/bin/meinproc}}
* if cmakekde can not find the path of kdepimlibs, edit the file {{path|$KDE_BUILD/KDE/kdebase/CMakeCache.txt}} and manually set <tt>KDEPIMLIBS_INCLUDE_DIR:PATH=$KDE_BUILD/kdepimlibs</tt>
* if you get an error saying "Please set the following variables: X11_XTest_LIB (ADVANCED)", install the devel package of <tt>Xtst</tt>. On some systems, this is packaged separately from <tt>xext</tt> and called <tt>x11proto-xext-dev</tt> or <tt>libxtst-dev</tt>. You may also need to remove the CMakeCache.txt file in the build dir after installing the package.
* the same for "X11_Xinerama_LIB (ADVANCED)" where you will need the devel package for <tt>xinerama</tt>.
* if you get an error complaining about a missing variable X11_Xrandr_LIB, you need the devel package for libxrandr (libxrandr-devel on ubuntu-systems)
* if you get the error "Please set the following variables: FONTCONFIG_INCLUDE_DIR, FONTCONFIG_LIBRARIES (ADVANCED)", then you need to install  the libfontconfig headers
* if you get the error "CMake Error: This project requires some variables to be set, and cmake can not find them. Please set the following variables: KMETADATA_LIBRARIES", you need to install soprano from kdesupport and to rebuild kdelibs
* if you get the error "‘XserverRegion’ does not name a type" make sure you have libxcomposite headers installed (<tt>libxcomposite-dev</tt> in ubuntu)
* if you get the error "CMake Error: This project requires some variables to be set, and cmake can not find them. Please set the following variables: QT_QTOPENGL_LIBRARY (ADVANCED) ", try editing CMakeCache.txt and setting QT_QTOPENGL_LIBRARY:FILEPATH=/home/kde-devel/qt-copy/lib/libQtOpenGL.so
 
* if you get messages as "KDE4_INSTALL_HANDBOOK() is deprecated. Remove it please. Now all is done in KDE4_CREATE_HANDBOOK." then, either find the files containing the offending line and comment it out manually, or run the following script in ~/kde/src/KDE/kdebase: [http://www.plamadeala.com/files/macros_corrector.sh macros_corrector.sh]. It will just REMOVE the line that has "kde4_create_handbook" in it from all the found files.
*If you get an error (in ubuntu) concerning libxtst.so install the libxtst-dev package
* If you get the message "kdebase/workspace/kcontrol/kxkb/x11helper.cpp:131: error: ‘KGlobal’ has not been declared", you might need to install libxklavier development packages.
* If you get "/home/kde-devel/kde/lib/libkio.so: undefined reference to `Strigi::AnalysisResult::AnalysisResult(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, long, Strigi::IndexWriter&, Strigi::StreamAnalyzer&)'" you probably have an outdated version of strigi installed by your distro.
 
== Running KDE 4 programs ==
 
You can now run KDE 4 programs (e.g. kwrite) by typing:
 ssh -X kde-devel@localhost
 kwrite 
 
=== Troubleshooting ===
 
* If you get 
 KUniqueApplication: Cannot find the D-Bus session server
check if you can access the display, e.g. type
 xclock
and see if a clock appears on the screen.
 
* If you get something like
 Error: standard icon theme "oxygen" not found!
 
 ASSERT: "!isEmpty()" in file /home/kde-devel/qt-copy/include/QtCore/../../src/corelib/tools/qlist.h, line 245
 Aborted (core dumped)
You need to install kdebase - see above. It is enough to install the "runtime" directory from kdebase.
 
== Generating local API documentation ==
Although the API documentation for KDE is available online at [http://api.kde.org api.kde.org], it is sometimes useful to have it on your own disk, for example when you want to use [[Getting_Started/Set_up_KDE_4_for_development#KDevelop|KDevelop]] for browsing the documentation or when you are not able to be online all the time.
 
Be aware that generating the API documentation can take several hours and takes almost half a gigabyte of diskspace.
The generation is handled by a script in {{path|kdelibs/doc/api}}, you need <tt>doxygen</tt> to be able to run it. 
 
To build the API documentation for kdelibs, type the following:
<!--'cs' and 'cb' are NOT typos!-->
 cs KDE/kdelibs # [[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc|'cs' is a bash function, click here to learn more]]
 $KDE_SRC/KDE/kdelibs/doc/api/doxygen.sh \
 --doxdatadir=$KDE_SRC/KDE/kdelibs/doc/common .
 
Repeat for other modules as desired.<br>
 cd <module home>
 $KDE_SRC/KDE/kdelibs/doc/api/doxygen.sh \
 --doxdatadir=$KDE_SRC/KDE/kdelibs/doc/common .
 
Another, even easier method involves downloading this [[Doxyfile]] to your local system. Then simply change directory to where you want to create the documentation and run
<syntaxhighlight lang="bash">
% doxygen /path/to/Doxyfile
</code>
Then review the file {{path|doxygen.log}} to see the doxygen errors and warnings. You'll find the actual documentation in the {{path|apidocs}} subdirectory.
 
== Staying up to date ==
 
In order to keep the kde4 installation up to date, each of the modules installed should be updated periodically. As Monday is the day for big changes in kdelibs, Tuesday may be the best day to do this. For each module checked out, run <tt>svn up</tt> and <tt>make</tt>.
 
For example:
<syntaxhighlight lang="bash">
cs kdesupport # cs is not a typo
svn up
cb # cb is not a typo
make -j2 VERBOSE=1 && make install
</code>
 
Note: it is not necessary to run cmakekde for updates.
 
== Installing a subset of a module ==
 
Many modules in KDE contain a large number of programs which could take a long time to download and compile. In cases where you want to work only on a particular program or programs in a module, it is possible to download and compile particular folders. In some cases, certain folders are required for any build of the module. This is determined in the CMakeLists.txt file of the module. For example the [http://websvn.kde.org/branches/KDE/4.0/kdegames/CMakeLists.txt?view=markup kdegames CMakeLists.txt file] lists:
 
<syntaxhighlight lang="text">
add_subdirectory(libkdegames)
add_subdirectory(libkmahjongg)
 
macro_optional_add_subdirectory(doc)
macro_optional_add_subdirectory(lskat)
macro_optional_add_subdirectory(katomic)
</code>
 
So, the libkdegames and libkmahjongg directories are required to build any of kdegames. The cmake directory will also usually be required. All the other directories (doc, katomic etc) are optional. They will be built if present on your machine. In this example, we build kmahjongg and kbattleship:
 
<syntaxhighlight lang="bash">
cs KDE
svn co -N kdegames # The -N switch performs a non-recursive checkout
cd kdegames
svn up libkdegames # Get required directories
svn up libkmahjongg
svn up cmake
svn up kbattleship # Get optional directories
svn up kmahjongg
cmakekde 
</code>
 
== General troubleshooting ==
 
What can happen over time, after some <tt>svn up</tt> commands, is that some of the tools used in the KDE build chain change their output format. For example, <tt>kcfg</tt> files are read by <tt>kconfig_compiler</tt> to produce configuration dialogs. CMake cannot detect those changes, and the compilation might fail. A workaround is to always force a re-generation of all such files:
 find $KDE_SRC/KDE/kdebase -name "*.kcfg" | xargs touch
The same applies to <tt>ui</tt> files as produced by Qt designer.
 
=== Locked sessions ===
When installing KDE 4 as a user, one will not be able to unlock a locked session. To work around this issue you can either:
 su chown root.root $KDEDIR/lib/kde4/libexec/kcheckpass
or
 chmod 755 $KDEDIR/lib/kde4/libexec/kcheckpass
 
Also you have to add a "kde" service in /etc/pam.d/ folder
 
For example for RH/Fedora based distros:
<syntaxhighlight lang="text"> 
 #%PAM-1.0
 auth       include      system-auth
 account    include      system-auth
 password   include      system-auth
 session    include      system-auth
</code>
 
== Success! ==
 
You are now ready to start building other svn modules in the same fashion as you built kdebase, running and testing KDE4 or writing your own patches and applications.
 
See the [[Getting Started/Set up KDE 4 for development|Set up KDE 4 for development]] tutorial for how to start KDE 4 applications and how to use KDevelop to work on them.
 
[[Category:Build KDE]]
[[Category:KDE4]]

KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal