Difference between revisions of "Archive:Getting Started/Build/KDE4/Kubuntu and Debian (zh CN)"

Jump to: navigation, search
(2 intermediate revisions by one user not shown)
Line 1: Line 1:
 
<!--fortruth初稿!-->
 
<!--fortruth初稿!-->
{{Template:I18n/Language Navigation Bar|Getting_Started/Build/KDE4/Kubuntu and Debian}}
+
 
 
本页将详细介绍在 Kubuntu 7.10 (Gutsy) 和 Debian (Testing/Unstable) 中安装 KDE4 的所有需求。如果你的系统只是一个只有基本功能的桌面,你需要安装以下必需的包:
 
本页将详细介绍在 Kubuntu 7.10 (Gutsy) 和 Debian (Testing/Unstable) 中安装 KDE4 的所有需求。如果你的系统只是一个只有基本功能的桌面,你需要安装以下必需的包:
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install build-essential cdbs debhelper cmake \
 
sudo aptitude install build-essential cdbs debhelper cmake \
 
kdesdk-scripts subversion ssh xserver-xephyr doxygen dbus-x11 \
 
kdesdk-scripts subversion ssh xserver-xephyr doxygen dbus-x11 \
Line 9: Line 9:
 
libboost-dev libgpgme11-dev libxine-dev libqimageblitz-dev libbz2-dev \
 
libboost-dev libgpgme11-dev libxine-dev libqimageblitz-dev libbz2-dev \
 
libdbus-1-dev libpam0g-dev libpcre3-dev libkrb5-dev
 
libdbus-1-dev libpam0g-dev libpcre3-dev libkrb5-dev
</code>
+
</syntaxhighlight>
  
 
以上包像 build essential 等是构建系统的前提,包括了基本所有编译 KDE4 (不包括QT4) 的需求和支持 https 所需的包 libssl-dev。更多所需的可选包参看以下列表。
 
以上包像 build essential 等是构建系统的前提,包括了基本所有编译 KDE4 (不包括QT4) 的需求和支持 https 所需的包 libssl-dev。更多所需的可选包参看以下列表。
Line 15: Line 15:
 
安装所有可选包:
 
安装所有可选包:
  
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install build-essential cdbs debhelper cmake  \
 
sudo aptitude install build-essential cdbs debhelper cmake  \
 
kdesdk-scripts subversion ssh xserver-xephyr doxygen graphviz libqt4-dev \
 
kdesdk-scripts subversion ssh xserver-xephyr doxygen graphviz libqt4-dev \
Line 30: Line 30:
 
libqca2-dev libqca2-dev libqca2-dev libsvn-dev libsvncpp-dev \
 
libqca2-dev libqca2-dev libqca2-dev libsvn-dev libsvncpp-dev \
 
libcommoncpp2-dev
 
libcommoncpp2-dev
</code>
+
</syntaxhighlight>
  
 
编译稳定版的 KDE4 (kde4.0) 还需要安装
 
编译稳定版的 KDE4 (kde4.0) 还需要安装
Line 39: Line 39:
 
可以从下面的命令来安装:
 
可以从下面的命令来安装:
 
(译者:cs 是 kde 提供的一个.bashrc 中的命令用于创建~/kde/src。详见:[[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc]]。
 
(译者:cs 是 kde 提供的一个.bashrc 中的命令用于创建~/kde/src。详见:[[Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc]]。
<code bash>
+
<syntaxhighlight lang="bash">
 
cs #注:cs不是错误
 
cs #注:cs不是错误
 
svn checkout svn://anonsvn.kde.org/home/kde/trunk/qt-copy
 
svn checkout svn://anonsvn.kde.org/home/kde/trunk/qt-copy
Line 52: Line 52:
 
else make install; fi;
 
else make install; fi;
  
</code>
+
</syntaxhighlight>
  
 
安装完所需要和要求的包后,请继续参看[[Getting_Started/Build/KDE4#kdelibs|building KDE 4]].
 
安装完所需要和要求的包后,请继续参看[[Getting_Started/Build/KDE4#kdelibs|building KDE 4]].
Line 59: Line 59:
 
在 Kubuntu 7.10 (Gutsy) 和 Debian (Testing/Unstable) 中用以下方法安装构建的必要前提:
 
在 Kubuntu 7.10 (Gutsy) 和 Debian (Testing/Unstable) 中用以下方法安装构建的必要前提:
  
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install build-essential cdbs debhelper cmake \
 
sudo aptitude install build-essential cdbs debhelper cmake \
 
kdesdk-scripts subversion ssh xserver-xephyr
 
kdesdk-scripts subversion ssh xserver-xephyr
</code>
+
</syntaxhighlight>
  
  
 
用于生成 API 文档资料的可选包:
 
用于生成 API 文档资料的可选包:
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install doxygen graphviz
 
sudo aptitude install doxygen graphviz
</code>
+
</syntaxhighlight>
  
 
== kdelibs 的依赖包 ==
 
== kdelibs 的依赖包 ==
  
 
用以下方法安装 Kdelibs 的依赖包:
 
用以下方法安装 Kdelibs 的依赖包:
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libqt4-dev dbus-x11 \
 
sudo aptitude install libqt4-dev dbus-x11 \
 
libstreamanalyzer-dev libstrigiqtdbusclient-dev \
 
libstreamanalyzer-dev libstrigiqtdbusclient-dev \
 
libxml2-dev libxslt1-dev shared-mime-info libgif-dev libpcre3-dev
 
libxml2-dev libxslt1-dev shared-mime-info libgif-dev libpcre3-dev
</code>
+
</syntaxhighlight>
  
 
=== 推荐的包 ===
 
=== 推荐的包 ===
Line 84: Line 84:
 
* libpcre3-dev - 正则表达式库。 支持 Javascript 所推荐的.
 
* libpcre3-dev - 正则表达式库。 支持 Javascript 所推荐的.
  
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libssl-dev libbz2-dev libpcre3-dev
 
sudo aptitude install libssl-dev libbz2-dev libpcre3-dev
</code>
+
</syntaxhighlight>
  
 
=== 其他可选的包 ===
 
=== 其他可选的包 ===
Line 96: Line 96:
 
* libopenexr-dev - 图象处理库image processing library
 
* libopenexr-dev - 图象处理库image processing library
 
* libxml2-utils - 用于生成有效的 doc 文件。
 
* libxml2-utils - 用于生成有效的 doc 文件。
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libxml2-utils libpcre3-dev libopenexr-dev \
 
sudo aptitude install libxml2-utils libpcre3-dev libopenexr-dev \
 
libjasper-dev libenchant-dev libavahi-common-dev libaspell-dev \
 
libjasper-dev libenchant-dev libavahi-common-dev libaspell-dev \
 
libasound2-dev
 
libasound2-dev
</code>
+
</syntaxhighlight>
  
 
== kdepimlibs 的依赖包 ==
 
== kdepimlibs 的依赖包 ==
 
kdepimlibs 的依赖包安装如下如示:
 
kdepimlibs 的依赖包安装如下如示:
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libboost-dev libgpgme11-dev
 
sudo aptitude install libboost-dev libgpgme11-dev
</code>
+
</syntaxhighlight>
  
 
=== kdepimlibs 的推荐包 ===
 
=== kdepimlibs 的推荐包 ===
 
* libldap2-dev - 在 kde4 中支持 ldap。
 
* libldap2-dev - 在 kde4 中支持 ldap。
 
* libsasl2-dev - imap 和筛选 kioslaves 所必需的
 
* libsasl2-dev - imap 和筛选 kioslaves 所必需的
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libldap2-dev libsasl2-dev
 
sudo aptitude install libldap2-dev libsasl2-dev
</code>
+
</syntaxhighlight>
  
 
== kdebase 的依赖包 ==
 
== kdebase 的依赖包 ==
 
kdebase-runtime 的依赖包安装如下如示:
 
kdebase-runtime 的依赖包安装如下如示:
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libxine-dev
 
sudo aptitude install libxine-dev
</code>
+
</syntaxhighlight>
  
 
{{Note|注意 libxine1-dev 依赖于 gnome 包,这是 kubuntu gutsy 打包时的一个 bug (在 hardy 中已经修复). 在 kubuntu 中 xinelib 包的版本是 1.1.8, 在播放短一点的声音时会有一些障碍 (在xinelib 1.1.9 中已经修复)。
 
{{Note|注意 libxine1-dev 依赖于 gnome 包,这是 kubuntu gutsy 打包时的一个 bug (在 hardy 中已经修复). 在 kubuntu 中 xinelib 包的版本是 1.1.8, 在播放短一点的声音时会有一些障碍 (在xinelib 1.1.9 中已经修复)。
Line 125: Line 125:
  
 
kdebase-apps 的依赖包安装如下如示:
 
kdebase-apps 的依赖包安装如下如示:
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libqimageblitz-dev
 
sudo aptitude install libqimageblitz-dev
</code>
+
</syntaxhighlight>
  
 
=== kdebase-apps 的可选包 ===
 
=== kdebase-apps 的可选包 ===
Line 135: Line 135:
 
* libsmbclient-dev - 用于在 KDE4 中支持 samba。
 
* libsmbclient-dev - 用于在 KDE4 中支持 samba。
  
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libsmbclient-dev libxkbfile-dev libxcb1-dev
 
sudo aptitude install libsmbclient-dev libxkbfile-dev libxcb1-dev
</code>
+
</syntaxhighlight>
  
 
=== kdebase-workspace 的可选包 ===
 
=== kdebase-workspace 的可选包 ===
Line 152: Line 152:
 
* libpam0g-dev - 论证模块
 
* libpam0g-dev - 论证模块
 
* libnm-util-dev  - 构建带有网络管理的 solid 所需要的
 
* libnm-util-dev  - 构建带有网络管理的 solid 所需要的
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libxklavier11-dev libxdamage-dev libxcomposite-dev \
 
sudo aptitude install libxklavier11-dev libxdamage-dev libxcomposite-dev \
 
libbluetooth-dev libusb-dev libcaptury-dev network-manager-dev \
 
libbluetooth-dev libusb-dev libcaptury-dev network-manager-dev \
 
libsmbclient-dev libsoprano-dev libsensors-dev libpam0g-dev libnm-util-dev
 
libsmbclient-dev libsoprano-dev libsensors-dev libpam0g-dev libnm-util-dev
</code>
+
</syntaxhighlight>
  
 
== kdeedu ==
 
== kdeedu ==
Line 170: Line 170:
 
* libnova-dev - A general purpose, 双精度, Celestial Mechanics, Astrometry and Astrodynamics library for KStars.
 
* libnova-dev - A general purpose, 双精度, Celestial Mechanics, Astrometry and Astrodynamics library for KStars.
  
<code bash>
+
<syntaxhighlight lang="bash">
 
sudo aptitude install libusb-dev libcfitsio3-dev libnova-dev libeigen-dev \
 
sudo aptitude install libusb-dev libcfitsio3-dev libnova-dev libeigen-dev \
 
libopenbabel-dev libfacile-ocaml-dev libboost-python-dev  
 
libopenbabel-dev libfacile-ocaml-dev libboost-python-dev  
</code>
+
</syntaxhighlight>
  
 
== koffice ==
 
== koffice ==

Revision as of 13:02, 15 July 2012


本页将详细介绍在 Kubuntu 7.10 (Gutsy) 和 Debian (Testing/Unstable) 中安装 KDE4 的所有需求。如果你的系统只是一个只有基本功能的桌面,你需要安装以下必需的包:

sudo aptitude install build-essential cdbs debhelper cmake \
kdesdk-scripts subversion ssh xserver-xephyr doxygen dbus-x11 \
libstreamanalyzer-dev libstrigiqtdbusclient-dev libsoprano-dev \
libxml2-dev libxslt1-dev shared-mime-info libgif-dev libssl-dev \
libboost-dev libgpgme11-dev libxine-dev libqimageblitz-dev libbz2-dev \
libdbus-1-dev libpam0g-dev libpcre3-dev libkrb5-dev

以上包像 build essential 等是构建系统的前提,包括了基本所有编译 KDE4 (不包括QT4) 的需求和支持 https 所需的包 libssl-dev。更多所需的可选包参看以下列表。

安装所有可选包:

sudo aptitude install build-essential cdbs debhelper cmake  \
kdesdk-scripts subversion ssh xserver-xephyr doxygen graphviz libqt4-dev \
dbus-x11 libstreamanalyzer-dev libstrigiqtdbusclient-dev libxml2-dev \
libxslt1-dev shared-mime-info libgif-dev libpcre3-dev libssl-dev libbz2-dev \
libpcre3-dev libxml2-utils libpcre3-dev libopenexr-dev libjasper-dev \
libenchant-dev libavahi-common-dev libaspell-dev libasound2-dev libboost-dev \
libgpgme11-dev libldap2-dev libsasl2-dev libxine-dev libqimageblitz-dev \
libsmbclient-dev libxkbfile-dev libxcb1-dev libxklavier12-dev libxdamage-dev \
libxcomposite-dev libbluetooth-dev libusb-dev libcaptury-dev \
network-manager-dev libsmbclient-dev libsoprano-dev libsensors-dev \
libpam0g-dev libnm-util-dev libusb-dev libcfitsio3-dev libnova-dev \
libeigen-dev libopenbabel-dev libfacile-ocaml-dev libboost-python-dev \
libqca2-dev libqca2-dev libqca2-dev libsvn-dev libsvncpp-dev \
libcommoncpp2-dev

编译稳定版的 KDE4 (kde4.0) 还需要安装 libqt4-dev.

从 trunk (即将是 KDE4.1 版) 编译 KDE 一定要从源码编译最新的 QT4.4 快照版。在 KDE svn 的 qt-copy仓库里有QT4.4 的拷贝。请先阅读 README.qt-copy 来选择合适的 Qt 选项和了解一些可能存在的问题。

可以从下面的命令来安装: (译者:cs 是 kde 提供的一个.bashrc 中的命令用于创建~/kde/src。详见:Getting_Started/Increased_Productivity_in_KDE4_with_Scripts/.bashrc

cs #注:cs不是错误
svn checkout svn://anonsvn.kde.org/home/kde/trunk/qt-copy
cd qt-copy
./apply_patches
cb #在单独的构建文件夹中构建 QT
../../src/qt-copy/configure <Qt options here> -prefix $QTDIR
make -j2 #使用 'make -j(X+1)' 这里 X 是你的机器处理器的个数,可以加快编译速度
# 如果不安装就请清除那些 obj 文件以节省磁盘空间
if [ "$QTDIR" = "`pwd`" ]; then \
find . -name '*.o' -delete ; \
else make install; fi;

安装完所需要和要求的包后,请继续参看building KDE 4.

Contents

构建的必要条件

在 Kubuntu 7.10 (Gutsy) 和 Debian (Testing/Unstable) 中用以下方法安装构建的必要前提:

sudo aptitude install build-essential cdbs debhelper cmake \
kdesdk-scripts subversion ssh xserver-xephyr


用于生成 API 文档资料的可选包:

sudo aptitude install doxygen graphviz

kdelibs 的依赖包

用以下方法安装 Kdelibs 的依赖包:

sudo aptitude install libqt4-dev dbus-x11 \
libstreamanalyzer-dev libstrigiqtdbusclient-dev \
libxml2-dev libxslt1-dev shared-mime-info libgif-dev libpcre3-dev

推荐的包

  • libssl-dev - 支持 https 等所需要的。
  • libbz2-dev - 在kio_archive 和 GHNS 包中支持 bzip 所需要的。
  • libpcre3-dev - 正则表达式库。 支持 Javascript 所推荐的.
sudo aptitude install libssl-dev libbz2-dev libpcre3-dev

其他可选的包

  • libasound2-dev - Alsa 声音系统。
  • libaspell-dev - 拼写检查支持 (在 kwrite 等软件中)
  • libavahi-common-dev - 发现 avahi/zeroconf 服务service discovery
  • libenchant-dev - 拼写检查外包装库spell checking wrapper library
  • libjasper-dev - 图象处理库image processing library
  • libopenexr-dev - 图象处理库image processing library
  • libxml2-utils - 用于生成有效的 doc 文件。
sudo aptitude install libxml2-utils libpcre3-dev libopenexr-dev \
libjasper-dev libenchant-dev libavahi-common-dev libaspell-dev \
libasound2-dev

kdepimlibs 的依赖包

kdepimlibs 的依赖包安装如下如示:

sudo aptitude install libboost-dev libgpgme11-dev

kdepimlibs 的推荐包

  • libldap2-dev - 在 kde4 中支持 ldap。
  • libsasl2-dev - imap 和筛选 kioslaves 所必需的
sudo aptitude install libldap2-dev libsasl2-dev

kdebase 的依赖包

kdebase-runtime 的依赖包安装如下如示:

sudo aptitude install libxine-dev
noframe
 
Note
注意 libxine1-dev 依赖于 gnome 包,这是 kubuntu gutsy 打包时的一个 bug (在 hardy 中已经修复). 在 kubuntu 中 xinelib 包的版本是 1.1.8, 在播放短一点的声音时会有一些障碍 (在xinelib 1.1.9 中已经修复)。

kdebase-apps 的依赖包安装如下如示:

sudo aptitude install libqimageblitz-dev

kdebase-apps 的可选包

  • libxcb1-dev - X C 的绑定 - 用于支持 xine 中的视频 widget
  • soprano - nepomuk 所推荐的. 详见 #Install soprano from svn
  • libxkbfile-dev - 键盘配置的包keyboard configuration package
  • libsmbclient-dev - 用于在 KDE4 中支持 samba。
sudo aptitude install libsmbclient-dev libxkbfile-dev libxcb1-dev

kdebase-workspace 的可选包

  • libsmbclient-dev - 用于在 KDE4 中支持 samba
  • network-manager-dev - 可以用在网络管理中的 solid 中
  • libcaptury-dev - screencasts 中的视频截取工具
  • libusb-dev - 用于在 solid 中支持 usb
  • libbluetooth-dev - 用于在 solid 中支持蓝牙 (bluetooth)
  • libxcomposite-dev - 用于在 kwin 中支持 compositing
  • libxdamage-dev - 用于在 kwin 中支持 compositing
  • libxklavier11-dev - 虚拟键盘
  • libsoprano-dev - Qt RDF 的存储结构 storage framework
  • libsensors-dev - 支持硬件传感器 (eg, temperature, fans)
  • libpam0g-dev - 论证模块
  • libnm-util-dev - 构建带有网络管理的 solid 所需要的
sudo aptitude install libxklavier11-dev libxdamage-dev libxcomposite-dev \
libbluetooth-dev libusb-dev libcaptury-dev network-manager-dev \
libsmbclient-dev libsoprano-dev libsensors-dev libpam0g-dev libnm-util-dev

kdeedu

如果你打算使用 kstars 你需要安装以下包:

  • libfacile-ocaml-dev - kalzuim 需要的
  • libboost-python-dev - kig 的可选包
  • libreadline-dev - 给 kalgebra 一个终端界面
  • libopenbabel-dev - kalzuim 需要的
  • libeigen-dev - kalzuim 需要的
  • libusb-dev - 给 KStars 提供 INDI 支持
  • libcfitsio3-dev - 给 KStars 提供 FITS 图片支持
  • libnova-dev - A general purpose, 双精度, Celestial Mechanics, Astrometry and Astrodynamics library for KStars.
sudo aptitude install libusb-dev libcfitsio3-dev libnova-dev libeigen-dev \
libopenbabel-dev libfacile-ocaml-dev libboost-python-dev

koffice

  • libqca2-dev - qt 加密支持。

kdepim

  • libqca2-dev - qt 加密支持。

kdenetwork

  • libqca2-dev - qt 加密支持。用在 jabber 协议中。

kdevplatform

  • libsvn-dev - dev platform 的 subversion 支持。
  • libsvncpp-dev - dev platform 的 subversion 支持。
  • libcommoncpp2-dev - 集成的协同作业。

kdevelop

需要 kdevplatform.


返回 building KDE 4.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal