Difference between revisions of "Getting Started/Build/Distributions/openSUSE"

Jump to: navigation, search
(add cyrus-sasl-devel libical-devel, for kdepimlibs)
m (Required Packages)
Line 12: Line 12:
 
Use the following commands to install the needed packages:
 
Use the following commands to install the needed packages:
 
<pre>
 
<pre>
  yast -i alsa-devel automoc4 avahi-devel patch cups-devel kde4-filesystem \
+
  zypper install alsa-devel automoc4 avahi-devel patch cups-devel kde4-filesystem \
 
  libbz2-devel avahi-compat-mDNSResponder-devel hal-devel xorg-x11-devel \
 
  libbz2-devel avahi-compat-mDNSResponder-devel hal-devel xorg-x11-devel \
 
  libQtWebKit-devel libxml2-devel kdesdk4 clucene-core-devel boost-devel \
 
  libQtWebKit-devel libxml2-devel kdesdk4 clucene-core-devel boost-devel \

Revision as of 19:18, 2 July 2012

Contents

Introduction

openSUSE has a very strong and active KDE team with a lot of information on their own wiki:

Required Packages

Use the following commands to install the needed packages:

 zypper install alsa-devel automoc4 avahi-devel patch cups-devel kde4-filesystem \
 libbz2-devel avahi-compat-mDNSResponder-devel hal-devel xorg-x11-devel \
 libQtWebKit-devel libxml2-devel kdesdk4 clucene-core-devel boost-devel \
 libjpeg-devel liblrdf-devel libpng-devel libxslt-devel libredland-devel \
 Mesa-devel giflib-devel subversion gcc-c++ gmp-devel xine-devel \
 libgpgme-devel pcre-devel dbus-1-devel libqt4-devel cmake git \
 doxygen polkit-devel docbook-xsl-stylesheets cyrus-sasl-devel libical-devel 

Build

This section describes how you can get kde to compile so that you can log in graphically (using kdm, the KDE display manager) and call konqueror (contained in KDEBASE, KDE's base package).

kdesupport

You can install kdesupport and its dependencies from SUSE by adding the KDE:KDE4 repository from the openSUSE Build Service to your installation sources. For openSUSE 11.4 add this Repository to your Install Source (Yast)

http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.4/

For older versions of SUSE Linux do:

su
installation_sources -a http://software.opensuse.org/download/KDE:/KDE4:/[YOUR SUSE LINUX VERSION]

Now install kdesupport from SUSE:

yast -i libqca2-devel libsoprano-devel libqimageblitz-devel strigi-devel

Please remember to skip any instructions from Getting_Started/Build that refer to kdesupport. Start to compile with kdelibs.

Using openSUSE Unstable Repositories

openSUSE, via its Build Service, provides a so-called unstable repository which contains weekly snapshots from KDE SVN trunk. These allow you to run a system install of unstable, but does not allow you to keep a stable system install while testing unstable in parallel.

Requirements

You need a supported openSUSE version, that is, at the time of writing, openSUSE 11.0, 11.1, 11.2 or openSUSE Factory (the always-on-development branch of openSUSE).

Installing packages from the unstable repository

You can either use the one-click-install, which can provide pre-arranged sets of packages, namely the basic system (KDE4-BASIS), games (KDE4-GAMES), or a complete development setup (KDE4-DEVEL), or add the repository manually and perform an installation from the command line.

Method 1: one click install

Depending on the openSUSE version use, there are different one-click installs:

Click on the relevant link and YaST will set up the repositories and install the required packages.

Method 2: Addition of the repository

Add the repository. To do so, enter as root

zypper ar http://download.opensuse.org/repositories/KDE:/KDE4:/UNSTABLE:/Desktop/YOUR_SUSE_VERSION/

where YOUR_SUSE_VERSION is either openSUSE_10.3, openSUSE_11.0, openSUSE_11.1, or openSUSE_Factory depending on what you are running.

After that, refresh the package index and update the packages to the unstable version:

zypper ref && zypper up

Post-installation steps

The Desktop repository does not include everything from KDE: for example, Amarok 2 is not present there. To add even more applications, including extragear ones, you need to use the KDE:KDE4:UNSTABLE:Extra_Apps repository.

Alternatively, using zypper:

zypper ar http://download.opensuse.org/repositories/KDE:/KDE4:/UNSTABLE:/Extra-Apps/YOUR_SUSE_VERSION/

zypper ref

followed by the installation the packages you need, for example Amarok 2:

zypper in amarok

Return to Building KDE.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal