Difference between revisions of "Getting Started/Build/Distributions/Debian"

Jump to: navigation, search
m (4.10)
m (Remove libjpeg62-dev package. It results in strange crashing, with an error about mismatched jpeg libraries)
Line 16: Line 16:
 
libboost-dev libboost-program-options-dev libboost-graph-dev libgpgme11-dev \
 
libboost-dev libboost-program-options-dev libboost-graph-dev libgpgme11-dev \
 
libvlccore-dev  libxine-dev libqimageblitz-dev libbz2-dev libdbus-1-dev libpam0g-dev \
 
libvlccore-dev  libxine-dev libqimageblitz-dev libbz2-dev libdbus-1-dev libpam0g-dev \
libpcre3-dev libkrb5-dev libsm-dev libclucene0ldbl libclucene-dev libjpeg62-dev \
+
libpcre3-dev libkrb5-dev libsm-dev libclucene0ldbl libclucene-dev \
 
libxtst-dev xsltproc libxrender-dev libfontconfig1-dev automoc librdf0-dev \
 
libxtst-dev xsltproc libxrender-dev libfontconfig1-dev automoc librdf0-dev \
 
libdbusmenu-qt-dev docbook-xsl docbook-xml libattica-dev libqtwebkit-dev \
 
libdbusmenu-qt-dev docbook-xsl docbook-xml libattica-dev libqtwebkit-dev \

Revision as of 17:42, 9 February 2013

Contents

Introduction

This page details installation of KDE SC 4 build requirements on any recent Kubuntu or Debian system. That is, if you want to build KDE SC 4 Platform, the required (and some strongly recommended) packages are installed with the commands on this page.

Debian Source Builds The Easy Way

For building parts of KDE on Debian using the Debian source packages see Debian the easy way.

KDE 4.x

Install these for any KDE 4.x release, then add specific packages for point releases as below. Then add any optional packages you like, as described below.

sudo aptitude install build-essential xorg-dev cdbs debhelper cmake \
kdesdk-scripts subversion ssh xserver-xephyr doxygen dbus-x11 \
libxml2-dev libxslt1-dev shared-mime-info libical-dev libgif-dev libssl-dev \
libboost-dev libboost-program-options-dev libboost-graph-dev libgpgme11-dev \
libvlccore-dev  libxine-dev libqimageblitz-dev libbz2-dev libdbus-1-dev libpam0g-dev \
libpcre3-dev libkrb5-dev libsm-dev libclucene0ldbl libclucene-dev \
libxtst-dev xsltproc libxrender-dev libfontconfig1-dev automoc librdf0-dev \
libdbusmenu-qt-dev docbook-xsl docbook-xml libattica-dev libqtwebkit-dev \
shared-desktop-ontologies libphonon-dev libqt4-dev dbus-x11 \
libstreamanalyzer-dev libstrigiqtdbusclient-dev libxml2-dev libxslt1-dev \
librdf0-dev libjasper-dev libopenexr-dev libacl1-dev libsasl2-dev

4.10

This (along with the command for 4.x above) installs all compilation requirements for kde 4.10. Some additional packages may be required for 4.10. See the sections below for other packages to install.

sudo aptitude install libx11-xcb-dev libxcb-composite0-dev libxcb-damage0-dev \
libxcb-xfixes0-dev libxcb-randr0-dev libxcb-shape0-dev libxcb-sync0-dev \
libxcb-image0-dev libxcb-render-util0-dev libqjson-dev virtuouso-minimal \
libavcodec-dev libavformat-dev libavdevice-dev libavutil-dev \
libswscale-dev libpostproc-dev libtag1-dev  libgstreamer0.10-dev \
libgstreamer-plugins-base0.10-dev

4.6

This (along with the command for 4.x above) installs all compilation requirements for kde4 (with the exception of qt4) and some strongly recommended packages such as libssl-dev for https support. Further recommended and optional packages are listed below.

sudo aptitude install graphviz libxml2-utils libopenexr-dev libjasper-dev libenchant-dev \
libavahi-common-dev libaspell-dev libasound2-dev libldap2-dev libsasl2-dev \
libsmbclient-dev libxkbfile-dev libxcb1-dev libxklavier-dev libxdamage-dev \
libxcomposite-dev libbluetooth-dev libusb-dev network-manager-dev \
libsensors4-dev libnm-util-dev libcfitsio3-dev libnova-dev libeigen2-dev \
libopenbabel-dev libfacile-ocaml-dev libboost-python-dev libsvn-dev libsvncpp-dev \
libqt4-dev libqca2-dev libstreamanalyzer-dev libstrigiqtdbusclient-dev \
libcommoncpp2-dev libidn11 libidn11-dev libpci-dev libxss-dev libxft-dev \
libpolkit-agent-1-dev libpolkit-backend-1-dev libpolkit-gobject-1-dev git libpoppler-qt4-dev \
libspectre-dev

4.5

sudo aptitude install libv4l-dev # for kdenetworks
sudo aptitude install liblcms1-dev # for kdegraphics

4.4

(Nothing extra needed)

kdelibs dependencies

Optional packages

  • libasound2-dev - The Alsa sound system
  • libaspell-dev - spell checking support (in kwrite etc)
  • libavahi-common-dev - avahi/zeroconf service discovery
  • libenchant-dev - spell checking wrapper library
  • libjasper-dev - image processing library
  • libopenexr-dev - image processing library
  • libxml2-utils - used to validate generate doc files
sudo aptitude install libasound2-dev libaspell-dev \
libavahi-common-dev libenchant-dev libjasper-dev libopenexr-dev \
libxml2-utils

kdepimlibs dependencies

There are no additional optional dependencies

kdebase dependencies

kdebase-apps optional

  • libxcb1-dev - X C binding - Used for video widget support in xine
  • libxkbfile-dev - keyboard configuration package
  • libsmbclient-dev - for samba support in kde4
sudo aptitude install libsmbclient-dev libxkbfile-dev libxcb1-dev

kdebase-workspace optional

  • libsmbclient-dev - for samba support in kde4
  • network-manager-dev - Can be used by solid for network management
  • libusb-dev - for usb support in solid
  • libbluetooth-dev - for bluetooth support in solid
  • libxcomposite-dev - for compositing support in kwin
  • libxdamage-dev - for compositing support in kwin
  • libxklavier-dev - virtual keyboard
  • libsensors-dev - Support for hardware sensors (eg, temperature, fans)
  • libpam0g-dev - Authentication module
  • libnm-util-dev - needed to build solid with network manager
sudo aptitude install libxklavier-dev libxdamage-dev libxcomposite-dev \
libbluetooth-dev libusb-dev libcaptury-dev network-manager-dev \
libsmbclient-dev libsensors-dev libpam0g-dev libnm-util-dev

kdegraphics

  • libpoppler-qt4-dev - PDF support in Okular
  • libspectre-dev - postscript support in Okular
  • liblcms1-dev
  • libexiv2-dev - to build Gwenview

kdeedu

The following packages are recommended if you intend to use kstars:

  • libfacile-ocaml-dev - used by kalzuim.
  • libboost-python-dev - optional for kig.
  • libreadline-dev - Gives kalgebra a console interface.
  • libopenbabel-dev - used by kalzium.
  • libeigen2-dev - used by kalzium.
  • libusb-dev - Provides KStars INDI support.
  • libcfitsio3-dev - Gives KStars support for FITS images.
  • libnova-dev - A general purpose, double precision, Celestial Mechanics, Astrometry and Astrodynamics library for KStars.
sudo aptitude install libusb-dev libcfitsio3-dev libnova-dev libeigen2-dev \
libopenbabel-dev libfacile-ocaml-dev libboost-python-dev

koffice

  • libqca2-dev - qt cryptographic support.

kdepim

  • libqca2-dev - qt cryptographic support.

kdenetwork

  • libqca2-dev - qt cryptographic support. Used for jabber protocol.

kdevplatform

  • libsvn-dev
  • libboost-serialization-dev

kdevelop

  • kdevplatform-dev
  • kdebase-workspace-dev

Other

To enable XMMS support for the 'Now Playing' plasma data engine in kdebase, you will need to either compile XMMS from source, or install the package from a third-party XMMS package repository.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal