Development/CMake KDE 4 4

< Development
Revision as of 19:12, 25 January 2010 by Neundorf (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Changes in the buildsystem from KDE 4.3 to KDE 4.4

As with KDE 4.2 and 4.3, also for KDE 4.4 still CMake >= 2.6.2 is required, so no changes in this regard.

Incompatible Changes

FindQt4.cmake: Imported Targets for the libraries

This change which is under certain circumstances not source compatible.


Other Changes

Commit Policy for kdelibs/cmake/modules/

The commit policy introduced during the 4.3 development cycle has been kept and we try to follow it.

New libraries: knewstuff3, kunitconversion and kdewebkit

New kdecore component KAuth

File MacroAddFileDependencies.cmake removed

We don't ship this file anymore since this file is part of CMake 2.6.2, which we still depend on for KDE 4.4. So it is not necessary to keep an identical copy in KDE.

New Modules

Some completely new installed modules have been added during this cycle:

  • FindHUNSPELL.cmake
  • FindKDevPlatform.cmake
  • FindLibAttica.cmake
  • FindSharedDesktopOntologies.cmake


Also added were FindPolkitQt-1.cmake and FindPolkitQt.cmake, but both are used only internally inside kdelibs and both are not installed.


KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal