Difference between revisions of "Contribute/Bugsquad/KrushDays"

Jump to: navigation, search
(Kopete crash on congigure plugins)
Line 48: Line 48:
 
* no option for 'select on hover' (emilsedgh)
 
* no option for 'select on hover' (emilsedgh)
 
* cannot show thumbnails (it was showing the thumbnails when konqueror was unable to show them, so seems a different bug with konqueror's "cannot show preview" bug, also file properties->preview hasnt the preview anyymore) (emilsedgh)
 
* cannot show thumbnails (it was showing the thumbnails when konqueror was unable to show them, so seems a different bug with konqueror's "cannot show preview" bug, also file properties->preview hasnt the preview anyymore) (emilsedgh)
 +
** fixed by mlaurent (logixoul)
 
* "Empty Trash" does not show up in the file menu when viewing the trash (yuriy)
 
* "Empty Trash" does not show up in the file menu when viewing the trash (yuriy)
 
** Application menus should never be changed dynamically. So an option would be showing "Empty Trash" always. From my point of view using the context menu is enough (at least I'm not aware about any file manager that has "Empty Trash" as part of the file-menu). For further discussions please mail me directly (peter.penz@gmx.at) or just use the kfm-devel mailing list. Thanks! (Peter Penz)
 
** Application menus should never be changed dynamically. So an option would be showing "Empty Trash" always. From my point of view using the context menu is enough (at least I'm not aware about any file manager that has "Empty Trash" as part of the file-menu). For further discussions please mail me directly (peter.penz@gmx.at) or just use the kfm-devel mailing list. Thanks! (Peter Penz)
Line 203: Line 204:
 
* often doesn't load pages properly, for example clicking the login link on a techbase page almost always gets me an empty page (apaku) (frank95com too, gruf too)
 
* often doesn't load pages properly, for example clicking the login link on a techbase page almost always gets me an empty page (apaku) (frank95com too, gruf too)
 
* Cannot show thumbnails (emilsedgh)
 
* Cannot show thumbnails (emilsedgh)
 +
** fixed by mlaurent (logixoul)
 
* Up Button loads a different view, while back button doesn't, when walking through the filesystem. The up button loads a similar view to what you get in dolhpin, while the default view when typing in a local path is a plain iconview (apaku)
 
* Up Button loads a different view, while back button doesn't, when walking through the filesystem. The up button loads a similar view to what you get in dolhpin, while the default view when typing in a local path is a plain iconview (apaku)
 
* When entering already visited directories, the animated logo doesn't stop. (Plain iconview instead of dolphin part?) (Mogger)
 
* When entering already visited directories, the animated logo doesn't stop. (Plain iconview instead of dolphin part?) (Mogger)

Revision as of 13:31, 7 November 2007

{{{3}}}
 
Join us Saturdays on irc in the #kde4-krush channel to work out release critical issues for KDE 4.0. Testers, artists, documenters and programmers are all welcome and encouraged to join in on the fun. Issues that are identified and being worked on will be added to this community scratchpad page.
KDE4 Krush Days
{{{3}}}
 
  • Please attach you nickname in irc when you add a bug to this page.
  • In order to mark a bug as fixed please use <s></s>-tags and mention the revision number(s) of this fix.
Note


{{{3}}}
 

Do not use http://rafb.net/paste/ for your crash backtraces, because those paste URLs there will expire after 24 hours.

Please use http://pastebin.ca/ for crash backtraces and add a link to your paste when you add the crash to the list below.

A backtrace is generally very helpful for developers to identify the reason for the crash. To get good backtraces, read this article.

Crash Backtraces


Contents

Screen Locker (krunner_lock)

  • unlocking the session is impossible as I get "wrong password" (logixoul) (confirmed by goliath23)
    • prolly installed as user - kcheckpass requires setuid root
  • enabling and disabling capslock in the "unlock session" dialog doesn't hide the red "Warning: capslock enabled" label (logixoul) (works fine for TunaTom [rev 731731])

Packaging

  • share/icons/oxygen/22x22/actions/kscd-dock.png is installed by both kdebase and kdemultimedia (jstubbs)

Konsole

  • Try opening tab in konsole, closing it, and opening a new one (for me, it freezes for a minute and then displays "QProcess: Destroyed while process is still running.") (tagx)
    • Note: I [goliath23] cannot confirm this. file->new tab, then rightclick->close tab, and then file->new tab works fine here [rev 732226] (TunaTom: Ctrl-Shift-n -> Ctrl-D -> Ctrl-Shift-n works as well [rev r732048])
    • Note2: (tagx:) Someone on else on irc confirmed it (name begins with t...) he was using gentoo too (I am using gentoo). (jstubbs:) Also confirmed and also with Gentoo.
    • I also have this issue. The system is CentOS 4.4. /yess
  • Selecting text in the default color scheme gives black-on-black selections (jstubbs)(confirmed by annma)(not reproducible by TunaTom)
  • None of the Alt+<letter> menu shortcuts work when the terminal has focus (apaku) (confirmed by TunaTom)
  • Wish: Could the links be not clickable as an option? it really goes on the way as it makes copy/paste too difficult when a link is present in the copied text (annma)
  • Wish: could we have the Start New Session little icon back pleaaaaase? (annma)
    • If you mean the icon that was to the left of the tabs in KDE 3 then no, I do not plan to reintroduce this. It has been replaced by a better set of keyboard shortcuts out of the box. The default shortcut to create a new session is Ctrl+Shift+N (robertknight)
      • Well, too bad you don't even considere it as a config option. I'll start a "New Tab icon" fan club then.
  • crashes when clicking on a link, but konqueror opens successfully ([C]167
  • Changes made with "Edit Current Profile::Appearance" are not

saved. <JRT>

  • "Edit Font" isn't restricted to only monospace fonts. <JRT>

Dolphin

  • Restoring a deleted item from the trash crashes dolphin/konqueror (mbiebl)
    • Fixed by Sergej Melderis and David Faure (Peter Penz)
  • The "Desktop" and "Root" icons in dolphin have a completely different style than the usual folder icon. (mbiebl)
  • Dolphin has no proper icon in taskbar/window decoration. (mbiebl)
    • fixed. (logixoul)
  • Select icon in folder/file properties doesn't show the icons of the selected categories at first. Only after changing the combobox the icons are loaded. (bbroeksema)(I can confirmed that [TunaTom r732119])
  • Edit Locations (F6) doesn't work as expected. Currently it only switches to edit mode and focuses the location bar if it's in navigation mode, otherwise it doesn't do anything. (Mogger)
    • For me, it switches from navigation to edit mode and focuses as well [TunaTom r732119]
      • Yeah same for me, sorry for being unclear. Edited now. (Mogger)
        • Thanks for the report, this issue is fixed now :-) (Peter Penz)
  • no option for 'select on hover' (emilsedgh)
  • cannot show thumbnails (it was showing the thumbnails when konqueror was unable to show them, so seems a different bug with konqueror's "cannot show preview" bug, also file properties->preview hasnt the preview anyymore) (emilsedgh)
    • fixed by mlaurent (logixoul)
  • "Empty Trash" does not show up in the file menu when viewing the trash (yuriy)
    • Application menus should never be changed dynamically. So an option would be showing "Empty Trash" always. From my point of view using the context menu is enough (at least I'm not aware about any file manager that has "Empty Trash" as part of the file-menu). For further discussions please mail me directly (peter.penz@gmx.at) or just use the kfm-devel mailing list. Thanks! (Peter Penz)
  • Several of the F1-F11 do not show up in the "Configure Shortcuts" dialog (e.g. F4) (gissi)
  • Inconsistency (IMHO): F4 in dolphin behaves different than in Konqueror (terminal panel vs. terminal in new window) (gissi)
  • It can only configure mimetype associations individually via properties on a file, and later clicking on a small settings button. To configure mimetypes globally, and not file related, it has to be done with Konqueror settings, as there is no such entry in SystemSettings. IMHO Dolphin or SystemSettings should also get the Konqueror's File association settings panel. (q3xr2).
  • When moving a hidden file to trash this file is not shown in trash. However, it is in ~/.local/share/Trash, so it's not lost. The problem is probably that kiotrash ignores hidden files. (gissi, confirmed by JustinNoel, luca_b and logixoul)
    • Fixed by Sergejs Melderis and David Faure (Peter Penz)
  • When you delete Trash from sidebar, you can't get it back. (amp)

Phonon

  • Can't get any sound to work. Chosen backend is xine. Tried to play an mp3 in juk. juk says its playing, but I get no sound. (mbiebl)

Juk

  • Too much colums in default setting. Not a bug but a bad looking thing. (frank95com)

Oxygen

  • Missing icons for "Appearance" and "Desktop" in systemsettings. (mbiebl)
  • Visual glitches in Oxygen: tabs in konqui, progressbar in dolphin. (mbiebl)
  • konsole, Oxygen: the arrows of the right scrollbar are not visible (black on black). (mbiebl)
  • Chanel icons in KMix could use some Oxygenification (JLP)
  • Too little contrast in the window-list from alt-tab shortcut, people with only slight visual problems won't be able to see the difference between selected/not selected (apaku)
  • Buttons inside konqueror are not drawn properly, text labels are off and often are missing completely. This doesn't happen with plain Qt style, but also with Plastik (apaku)

Plasma

  • Unable to resize the kickoff menu. (mbiebl)
  • The taskbar doesn't remember the position of the clock plasmoid. (mbiebl)
  • Kickoff opens konqueror when clicking on an entry under "My Computer". (mbiebl)
  • The network plasmoid does not automatically selet the active network connection (It uses eth0 by default, but I use wlan0 mostly) (mbiebl)
  • In kickoff, clicking the utilities menu and then clicking back again shows the top menu scrolled to the top rather than where it was before clicking utilities. (jstubbs)
    • Confirmed. Additional strange bahaviour: When opened by clicking on a link in "Storage" for example, Konqueror shows the contents of "/" in an unnamed tab. Right of that tab is another one showing the correct location. If you click that tab, konqeuror crashes. (goliath23)
  • systemtray: starting one juk instance shows two identical icons in the systray.
  • with the plasma toolbox, clicking "add widgets" but releasing the mouse button elsewhere still activates it. (jstubbs)
  • hovering the plasma toolbox for the first time after cleaning config makes buttons slide in from TOP-LEFT rather than TOP-RIGHT. Every subsequent hovering works correctly. (logixoul)
  • can't move panel plasmoids. (logixoul)
  • can't put pager or systray on panel. (logixoul)
  • systray on desktop has no border. (logixoul)
  • MinimizeAnimation doesn't animates correctly to the taskbar, with Kicker it works fine (Plasma should tell KWin where the taskbar-entry is) (boom1992)
  • The dictionary plasmoid doesn't show the results. (Mogger)
    • Looks like fixed in r732655, shows the result, but first changes the box with animation, then changes the result text, also its a bit slow (emilsedgh)
  • krunner hangs on each and every letter typed in after some time working in a kde4 desktop. May be related to manual killing the strigidaemon which goes nuts on CPU usage. Output from console: http://www.apaku.de/vardata/krunner_output_hang (apaku)
  • notes applet should be resized when the text is bigger that current size (emilsedgh)
  • Kickoff: Clicking the applications tab, when the tab is open should return it to top-level.Current catalog-memory is a good feature however, so keep that aswell. (eirik_)
  • Colorpicker and Kickoff plasmoid don't have context menu, so they can't be removed. (TunaTom)
    • context menus are going to be replaced by hover-action-icons (ivan)
    • Lancelot now has context menu and is (re)movable (emilsedgh)
  • Running plasma with QT_FLUSH_PAINT I can see lots of extra repainting. For example the panel is very bad. (rich)
  • Plasma is shown in the Alt+Tab windowlist, this should not happen (especially since switching to this app then does nothing visually except lose focus from the toplevel window) (BCoppens)
  • Analog Clock: add text & seconds indicator. Change size to 400. Is so SLOW that it easily skips 3 seconds per redraw! (Core2 Duo 2.20GHz, Quadro FX 570M, nvidia binary drivers, Thinkpad T61p) (BCoppens)
  • Digital clock is useless by its inconfigurability: I'm not interested in a disorganized list of timezones, no, I want a) the date underneath, b) a less fancy digital font instead of the current one with the distracting 'line' in the middle. (BCoppens)
    • The date format is not affected by the settings in KControl.<JRT>
    • Time Zone list should be redundant in configuration since the TZ should be set in KControl. All that is needed is an option to display it. Note, I think that this is the standard timezone list. If what is wanted is an option to display a TZ other than the user's TZ, this should be a separate context menu item. <JRT>
  • Kickoff does not start firefox. It loads the .desktop file in kwrite (amp)
  • The Lock/Logout Widget has rectangular buttons -- should have square? IAC, icons should be centered on buttons. <JRT>
  • System Tray Widget doesn't work correctly: The Widget doesn't size itself to hold the contents. The contents seem to have the wrong X display priority (they are always on top). It (the contents, not the widget) interacts with windows (snap). The contents are only displayed on Desktop #1. When something triggers a refresh of something, then the SystemTray widget resizes and looks correct but the icons are still not working correctly. They are only on DeskTop #1 and always on top. <JRT>
  • The Application Launcher Widget seems to be stuck in the middle of the screen; I can't drag it. In this position with 1024x768 the menu window does not open correctly. It extends beyond the top of the screen and is cut off. <JRT>
  • The Clock on the Panel slides over and winds up on top of the TaskBar on the Panel.<JRT>

System Settings

  • systemsettings has no menu entry. Typing it into kickoffs search entry doesn't find/list it either. (mbiebl)
  • When clicking on "Appearance", it seems to delete a file. http://rafb.net/p/zzS2fM55.html (Mogger)
    • When I select "Appearance" in "System Settings", three "Progress Dialog" boxes pop up.<JRT>
  • Missing "get root rights" button on pages like Date/Time, thus its impossible to change such settings (apaku)
  • Searching something doesn't seem to limit the displayed modules or highlight any of the search results.
  • no settings to be changed for keyboard shortcuts - everything is empty (nixternal)
    • This is probably a function of your system configuration. IIUC,It reads an X11 file. <JRT>
  • When clicking e.g. "Appearance", the System Settings window doesn't get resized. This causes very ugly (horizontal and vertical) scrollbars (gissi)
  • Default size for the text beneath the icons is too small. I see stuff like 'ppearanc' instead of 'Appearance' and 'ccesibilit'. Some other texts are wide enough, like 'Splash Screen'. (BCoppens)
  • Changing the style to Oxygen changes all windows, EXCEPT the System Settings (BCoppens)
  • Regional & Language::Time & Dates (should that be "Time & Date"?) doesn't have USA style date formats in "Short date format": MM.DD.YYYY & mM.dD.YYYY and should also have formats with only 2 digits for year: YY.

KMix

  • m_qcb->blockSignals( true ); where m_qcb is null from MDWSlider::updateInternal during kmix startup http://pastebin.ca/759601 (jstubbs) Fixed by SVN commit 732246
  • Right click on KMix icon in system tray, select master channel, dialog comes up empty, when you close it KMix icon disappears from the tray (JLP) Fixed by SVN commit 732367

KWin

  • Windows are not fully redrawn when minimizing and then restoring with OpenGL compositing in use (jstubbs)
  • the compositing KCM should provide an easy way to enable the COMPOSITE extension (logixoul)
  • Menu shadows are being left on the desktop (but not on windows, it seems) (Mogger) Fixed by SVN commit 732268
  • Sometimes (tested with Konsole, X.org 7.3, latest nvidia drivers and a Geforce 5900XT), the clicked menus are not displayed and KWin crashes. Backtrace : [1] (idem)
  • After a while the alt-tab window list is completely missing though I can still switch between windows with alt+tab (apaku)
  • alt+tab only allows to switch between windows on the same screen in a multihead setup, its impossible to activate a window on another screen (though its on the same virtual X11 desktop) (apaku)
  • alt+tab (without compositing) shows a list of windows but no indication which window in this list is selected when cycling through them. (goliath23)
  • KWin does not detect compositing ability on my pc with a GeForce 7600 GS (driver version 100.14.19) (goliath23)
  • The Composite Effect 'Demo Liquid' crashes KWin (BCoppens)
  • 'Scale In' effect also scales in Menus and Dropdown boxes from the 'middle' of their target area, this is ugly. Either don't do that for such windows, or let them scale in from their topleft corner (BCoppens)
  • Alt+Shift+Tab for backwards scrolling through Alt+Tab shortcut is not assigned, but I can't remember if this was the case in KDE3 as well or not... (BCoppens)
  • Moving windows with "Display Content" turned off does not display an empty frame. (using an OpenSource driver)<JRT>

KNS

  • KNS uses 100% CPU when 550 is enabled in kdebugdialog (jstubbs)
  • Sometimes KNS dialog is under Settings dialog (Kanagram and KStars) modal/non-modal issue when KNS is invoked from a Config dialog (jstubbs)

KHangMan

  • "Already Guessed" tooltip timer does not work. FIXED annma r732068
  • When changing the "Already Guessed" tim in Config, the current word should stay (KHangMan jumps to a new word). FIXED annma r732068
  • After typing an already typed letter, the focus is left on the guess "button", which means I have to press tab to get back to the letter entry field. If we enable the focus back before tooltip is hidden, it means the tooltip has to be hidden when a new letter is entered. (jstubbs)
    • annma: intented behaviour is that the input is impossible why popup is shown. To leave the kid the time to understand what he is doing. Messing with the tooltip now seems bad to me. It's a WON'T FIX until we have it tested with kids ;) sorry jstubbs!
  • See if the font progressbar can disappear after first run (jstubbs)
    • annma: Removing your ~/.fonts/d dustismo_roman.ttf will make the bug go away. The font will reinstall and then it'll be found. Not sure why it happened...
  • Test what happens for the fonts when no internet connection (jstubbs)
  • Wish: when using the Special chars toolbar, letters should go immediatly in the word or in Missed. Annma is not sure this would work with kids, they maybe won't understand what happens. (jstubbs)
    • annma: maybe a config option for KDE 4.1 as we are in feature freeze now.
  • Language combo in toolbar does not resize correctly when changing language. (jstubbs)
  • Right-clicking "Type accented letters" does not offer the context sensitive help when the option is disabled. (jstubbs)
    • annma: this is from Qt, it's default behaviour for QWhatsThis help.

Kiten

  • Searching for "one" takes a long time to process, during which the application blocks without any feedback. (jstubbs)
  • From the Search menu, selecting Search {with Beginning of Word, Anywhere}, Grade or Strokes does not seem to have any affect (jstubbs)
  • Selecting Verb or Noun from the grammatical element dropdown does not seem to have any affect (jstubbs)

KBruch

  • In fraction tasks, the denominators used sometimes exceed the max denominator that is set. (jstubbs) r732343 attempted to fixe it but not totally

KPercentage

  • When starting a new set of tests, and on various other actions, the window unnecessarily moves to the centre of the screen (jstubbs) Fixed r732700

KGeography

  • Intermittent crash after a placing state on a map (jstubbs) Fixed r732331 (tsdgeos)
  • Selecting zoom when placing state on a map leaves the cursor as the state to be placed - perhaps the cursor should change back to a pointer while in zoom mode? (jstubbs) Fixed r732314 (tsdgeos)
  • With KWin's dimming of inactive windows, it is difficult to relate the colors signfying right/wrong answers back to the map (jstubbs)

KmPlot

  • Editing function does not work as if Enter is not doing anything (rivo, gissi and idem-kde4) Annma cannot reproduce.
    • Note by gissi: For me, only editing a cartesian plot doesn't work, the others work as expected. Don't know wether that's the same for rivo and idem.

KMail

  • Creating a new Imap Account and press "Check what the Server Supports" in Security crashes KMail. Stacktrace / ConsoleLog at http://pastebin.ca/759562 (voltaire)
This is probably a KSSL problem, which will be fixed when the new KSSL arrives in kdelibs --TMG 00:03, 4 November 2007 (CET)
This is a kdelibs (krun) bug, it happens in other apps, like Konsole, as well --TMG 00:03, 4 November 2007 (CET)
Fixed in kdelibs --TMG 21:27, 6 November 2007 (CET)
  • When an IMAP server stops responding KMail popups up the "IMAP Disconnected" dialog with an "Ok" button. Clicking "Ok" crashes KMail. Stack Trace: http://www.pastebin.ca/759969 (JustinNoel)
  • KMail initial account wizard. A process related to the KMail initial setup wizard crashes when "Check for supported security capabilites on..." appears. Console spew suggests something crashed. KMail starts with an IMAP account with an incorrect security configuration. Description/Reproduction Steps/Console Spew: http://www.pastebin.ca/760052 Needs verification as I only have one IMAP server to try. (Justin Noel)
Seems like the same bug above, the one reported by voltaire. --TMG 00:03, 4 November 2007 (CET)
  • KMail with disconnected IMAP: after customizing options and restart, it crashes on startup http://pastebin.ca/764484 (Lure 09:07, 7 November 2007 (CET))

Build issue

Kolf

  • The direction and velocity marker flickers and often cannot be seen. Using opengl compositing. (jstubbs)

KDElibs

  • The tab order of the configure shortcuts dialog is incorrect. (Mogger) Fixed by SVN commit 732404
  • Drag and drop doesn't work in the configure toolbars dialog. (Mogger)
  • Applications crash when downloading something. Traceback from Konsole when clicking on a link: http://rafb.net/p/1aiHyn63.html (Mogger)
  • cannot write Right-To-Left...in kde3 when you start a line with a character of an rtl language, the line goes rtl automatically (emilsedgh)
  • Configure shortcuts dialog is too small at start: I cannot see the action name at all (it says stuff like 'C...' instead of 'Close'). Furthermore, and much worse: I cannot change the width of the columns at all to try to make the action names readable! (BCoppens)

Konqueror

  • Website http://kriptopolis.org it is really bad rendered, however it is fine with Konqueror 3.5.7. (q3xr2)
  • often doesn't load pages properly, for example clicking the login link on a techbase page almost always gets me an empty page (apaku) (frank95com too, gruf too)
  • Cannot show thumbnails (emilsedgh)
    • fixed by mlaurent (logixoul)
  • Up Button loads a different view, while back button doesn't, when walking through the filesystem. The up button loads a similar view to what you get in dolhpin, while the default view when typing in a local path is a plain iconview (apaku)
  • When entering already visited directories, the animated logo doesn't stop. (Plain iconview instead of dolphin part?) (Mogger)
  • Nothing in View -> Sort By, Additional Information, Panels, Navigation Bar submenus (yuriy)
  • Nothing except "home folder" in home folder sidebar (yuriy)
  • Some favicons do not appear in Konqueror's nav bar to titlebar. google.com and kubuntu.org works. kde.org, cnn.com and slashdot.org do not work. (JustinNoel)
  • pressing ctrl+a when focus is on addressbar selects whole webpage instead of the text that is written in the addressbar (only on webpages: khtmlpart?) (emilsedgh)
  • have to keep refreshing pages in order for them to display (nixternal)
  • have quite a few problems trying to edit this page alone (nixternal)
  • In file management mode it can't show hidden files, it doesn't have this option in the View menu, neither there is a shorcut available. (q3xr2)
  • In HTML forms (such as the textbox to edit this wikipage with, or the username box), the initial fontsize is small. Once I click on the form, the font suddenly enlargens. Especially annoying with this editbox, since the place where you think you clicked changes after fontsize change (BCoppens)
  • Asks nicely if it has to store my form data (such as password and username in the Wallet, but does not actually do so (BCoppens)
  • Clicking on a link to an in-page 'tag' (the a href=#tag thing, like there are lots of in the index of this wiki page), results in konqueror showing the 'Drag link' mouse cursor (BCoppens)
  • Not only do I get blank pages, but I get the following on trying to edit this wiki with Konqueror of KDE4: after sending in the changes, it shows a blank page. I press F5, and Konq asks me to resubmit form data. Wiki then shows an almost-empty edit page, with 'Sorry! We could not process your edit due to a loss of session data' (BCoppens)
  • Start Konq. Press 'Next: An Introduction to Konqueror'. The page goes blank, and 'Previous page' also shows up blank. (BCoppens)
  • With Konqui becoming webbrowser as primary task, it would make sense to redesign the start page altogether and remove stuff like Storage media, Trash etc. Show something like "Search the web" which points to a search engine, like Google, yahoo,...
  • Start Konq. Enter '~'. Make a new tab (CtrlShift+N). Type something. Note how the cursor goes OVER the map icon, instead of starting next to it (BCoppens)
  • (Different from the one above) Start Konq. Enter '~'. Make a new tab (CtrlShift+N). Enter '/'. Switch back to the first tab. It's caption suddenly changes from '/home/kde4/' to 'kde4'! Switching to the second tab, removes the '/' and makes that tab nameless) (BCoppens)

IO-slaves

  • Browsing with IO-slaves that require autenthication is broken: SMB, FTP, SSH do not display anything after authentication is entered (luca_b, nixternal, yuriy).
  • When adding RSA keys using fish:/, the buttons to accept/refuse are blank. (luca_b, yuriy)
  • smb:/ ioslave causes crash (nixternal)
  • smb:/ ioslave does not work with shares that need authentication. Console output: http://pastebin.ca/760196 (luca_b)
  • kio_file: After a while I have 100% of CPU usage when running KDE4. top says, the process is kio_file, which is sometimes up to 4 times running (amp)
  • The settings:/ ioslave (accessible through Settings on the welcome screen of Konq) does not work at all. For example, try Appearanc&Themes -> Fonts: it tries to open this with KWrite! (BCoppens)

Color KCM

  • Changing the checkbox "Apply colors to non-KDE4 apps" doesn't trigger the changed signal and thus the apply button in systemsettings stays grayed out (apaku)
  • the same as above applies to the whole Effects tab (apaku)

Kate

Marble

  • Navigate to Minneapolis (search is quick) and then zoom in until "saint paul" appears. Rotating up and down will now cause the text "saint paul" to jump around. (jstubbs)
  • In full screen mode, clicking in the right half of the globe doesn't work. It seems that plasma is getting the events? (jstubbs)

Kinfocenter

  • Most of the Items are empty (emilsedgh)

Kopete

  • Adding an account a second time (same protocol, same user id as an existing) makes kopete crash (moi1392, idem-kde4). http://pastebin.ca/759660. More verbose fix in the works (Earthwings). http://lists.kde.org/?l=kopete-devel&m=119411618226111&w=2
  • I can't get my Google Talk account to finish it's authentication process, however I can login without any troubles with my jabber.org account. I don't know if the trouble it's related to the SSL login or qca-tls which I have installed (q3xr2).
    • Google Talk did not work before for me, but it works now (with today's SVN version), maybe you should retest with current SVN version.
  • Configure->Plugins results in consistent crash here http://pastebin.ca/764575 (Lure 12:34, 7 November 2007 (CET))

kfind

  • kfind crashes when the find is stopped (by pressing "stop" button) during the find process (shaga)
  • the stop button has to be pressed twice, the first click is lost (shaga)

Gwenview

  • Random crashes when navigating to directories, or when editing the path manually. Backtrace http://pastebin.ca/760077 (luca_b)

Login Manager KCM

  • There are numbers on the tabs (yuriy)
    • yes - the kcm is too big to have non-clashing letter shortcuts.

kscd

  • crashes when inserting a CD. Problem is an assert thats hit (apaku):
 kscd(31228)/kdecore (KConfigSkeleton) KConfigSkeleton::readConfig: KConfigSkeleton::readConfig()
 kscd(31228)/libkcddb KCDDB::Cache::lookup: Looking up  "ae0cdb0e"  in CDDB   cache
 kscd(31228)/libkcddb KCDDB::CDInfo::load: Loaded CDInfo for  "ae0cdb0e"
 kscd(31228)/libkcddb KCDDB::Client::lookup: Found  1  hit(s)
 ASSERT: "info.numberOfTracks() == cddbInfo.numberOfTracks()" in   file /home/andreas/KDE-work/4.0/kdemultimedia/kscd/kscd.cpp, line 753
  • crashes when starting up (but not if the user does not have permissions to acces the cdrom) backtrace: http://pastebin.ca/760172 (yuriy)

KFontChooser

  • It doesn't work correctly for the bit mapped fonts Fixed[Misc] & Fixed[Sony] which come with X11 are the best example of this since they might be used in Konsole. This is mainly a Konsole issue. <JRT>
    • There should be only 2 sizes of Fixed[Sony] which works correctly in KDE3 it displays only two sizes. I'm not 100% clear on how this works if you have a screen resolution other than 75 or 100, but xfontsel lists two point sizes for 100 dpi: 12 & 17 and this agrees with the KFontSel dialog. But in KDE4 it lists the usual list of sizes from 4 to 64.
    • There are several sizes of Fixed[Misc], according to xfonsel they are: 5, 6, 7, 8, 10, 11, 12, & 14. KDE has this fairly close to correct -- close enough that it works OK. It also lists 4 which may be a 75 dpi font and it lists 9 but not 12. Could these be rounding errors? IAC, KDE4 is the same as with Fixed[Sony], it has the standard list of 4 to 64.
  • We need to first ask if this is a Qt bug/error as are other font issues.
    • The Fixed{Misc} fonts are not a uniform set of fonts and I don't think that there is any way that Qt can deal with this issue.

Akregator

  • Crashes while trying to delete a feed.

Kontact

  • Crashes starting the application.
We need a backtrace, otherwise we can't do anything. It doesn't crash for us. --TMG 21:24, 6 November 2007 (CET)

KDEPrint

  • Printing a html file from konqueror. The "HTML Settings" tab has an odd layout. It seems to miss a proper border. (mbiebl)

KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal