Difference between revisions of "Contribute/Bugsquad/BugDays/KMailDay4/Bugs needing attention from KMail developers"

Jump to: navigation, search
m
m
 
Line 54: Line 54:
  
 
* {{bug|149999​}} - Often password prompts are confusing to users. [[User:Ruchir|Ruchir]]
 
* {{bug|149999​}} - Often password prompts are confusing to users. [[User:Ruchir|Ruchir]]
 +
 +
* {{bug|151136​}} - Can reproduce on trunk but not sure if it shoul dbe implemented. [[User:Ruchir|Ruchir]]

Latest revision as of 14:28, 24 April 2009

[edit] Bugs needing attention from KMail developers

Add bugs here if you need to find out whether the observed behaviour is inteded, or if there's some other reason that it would be useful for a KMail developer to take a look at. Make sure you indicate why the bug needs attention. A second common reason to put a bug here is if it has already been heavily commented on by the application's developer. In the latter case please only add bugs you can reproduce.

noframe
 
Warning
Always defer policy decisions to developers.


  • bug #159213 - Anti-virus filtering. I can't figure out which anti-virus tool KMail is using (or if it's not using any). Possible high-priority. Lemma
  • bug #159634 - autosaved messages are removed on KMail startup making you loose them if you quit KMail before the next autosave triggers. Lemma
  • bug #160881 - GPG encrypted mail not working. There was a commit but the bug's still open. Lemma
  • bug #163235 - No phishing protection for links in HTML messages - Fixed in KDE4, user wants backport to KDE3.5. This should be decided by the developers. lytenyn
  • bug #161702 - Identities can only be used for new account after changes have been "applied". Maybe a popup on changing the configuration area with an option to "discard" or "apply" (see Systemsettings->Appearance) would be a solution? Lemma
  • bug #161758 - locale problem with accented filename in attachment: can't open in OOo (non UTF8 system). Works for me but I have a different locale (UTF-8). Lemma
  • bug #164448 - Crash on removing a filter while filtering is in progress. I don't manage to remove the filter (too slow or not possible any longer?) Lemma
  • bug #159846 - Incorrect folder size? Seems like the behaviour is what's to be expected. Lemma
  • bug #162360 Performance issue: I'm not able to reproduce but I've a powerful PC, maybe on slower system it could be more evident. FiNeX
  • bug #166653 Performance issue discovered on big local mail directories. Some coding hints has been provided. Develpers could give an eye on this problem. FiNeX
  • bug #147178 - mail check interval related. I think this is already implemented in KMAccount::checkDone(). Lemma
  • bug #149999 - Im quite sure that described behaviour is correct. Should be WONTFIX imho. dtritscher 12:53, 5 April 2009 (UTC)
  • bug #162314 - Was able to reproduce the crash, but the backtrace I got differed from the reporter's. CondorDes
  • bug #146346 - The provided email is malformed -- it's missing the charset in the Content-Type header. However, KMail might want to fallback on the encoding specified in the XML/HTML headers. Devs should decide. CondorDes
  • bug #168358​ - Not sure if it's correct behavior. HTML editor should not get all html tags but just formatted message. Ruchir

This page was last modified on 24 April 2009, at 14:28. This page has been accessed 2,554 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal