Difference between revisions of "Contribute/Bugsquad/BugDays/KDEPIMKrush1/KOrganizer"

Jump to: navigation, search
m (Bugs)
(Bugs)
 
(29 intermediate revisions by 7 users not shown)
Line 15: Line 15:
 
|-
 
|-
 
|[[User:finex|FiNeX]]||svn r811489 || testing ||
 
|[[User:finex|FiNeX]]||svn r811489 || testing ||
 +
|-
 +
|[[User:Talavis|talavis]] || svn r818299 || testing ||
 +
|-
 +
|[[User:Doviende|doviende]] || svn r846116 || testing ||
 
|}
 
|}
  
Line 20: Line 24:
 
Please list all bugs found in the application below here. Remember to sign every comment you write on this wiki page with <nowiki>~~~</nowiki>.
 
Please list all bugs found in the application below here. Remember to sign every comment you write on this wiki page with <nowiki>~~~</nowiki>.
  
*[[User:finex|FiNeX]] On the calendar views (month/day/week) after selecting a range, if you start type a new event is created. You can do this only one time, after you have to close/restart korganizer for repeat this behaviour.
+
*<s>[[User:finex|FiNeX]] On the calendar views (month/day/week) after selecting a range, if you start type a new event is created. You can do this only one time, after you have to close/restart korganizer for repeat this behaviour.</s>
**[[User:finex|FiNeX]] Moreover on 3.5 what you typed were used as event title, this doesn't happen anymore.
+
**<s>[[User:finex|FiNeX]] Moreover on 3.5 what you typed were used as event title, this doesn't happen anymore.</s>
 +
**[[User:vkrause|Volker]] Fixed in revision 813635.
  
*[[User:finex|FiNeX]] crash on "file"->"Export"->"upload new hot stuff". No backtrace, this is the shell output: http://pastebin.ca/1028758
+
*<s>[[User:finex|FiNeX]] crash on "file"->"Export"->"upload new hot stuff". No backtrace, this is the shell output: http://pastebin.ca/1028758</s>
** [[User:Krop|Krop]] Backtrace : http://pastebin.com/m7171fc13  
+
**<s> [[User:Krop|Krop]] Backtrace : http://pastebin.com/m7171fc13 </s>
 +
** Filed as {{Bug|165076}} [[User:Grundleborg|Grundleborg]]
  
* [[User:finex|FiNeX]] start/end date on "event" dialog is too small: the first two digits of the year are cutted out. http://img338.imageshack.us/img338/6388/korganizerdateshq1.jpg
+
*<s> [[User:finex|FiNeX]] start/end date on "event" dialog is too small: the first two digits of the year are cutted out. http://img338.imageshack.us/img338/6388/korganizerdateshq1.jpg</s>
  
* [[User:finex|FiNeX]] "Edit reminders" dialog: the offset column text is between "<html>...</html>".
+
*<s>[[User:finex|FiNeX]] "Edit reminders" dialog: the offset column text is between "<html>...</html>".</s>
* [[User:finex|FiNeX]] "Edit event" file dialog: "Calendar:..." label too near to "Categories" label. It is confusing.
+
*<s>[[User:finex|FiNeX]] "Edit event" file dialog: "Calendar:..." label too near to "Categories" label. It is confusing.</s>
  
* [[User:finex|FiNeX]] "Manage templates" dialog: if you have zero templates and you click on "apply template" the "new" button is disabled.
+
*<s> [[User:finex|FiNeX]] "Manage templates" dialog: if you have zero templates and you click on "apply template" the "new" button is disabled.</s>
** I've wrote a small patch for disabling the "apply template" when there are zero templates: http://pastebin.ca/1028787. Should I ask on the korganizer ML if I can commit it?
+
**<s> [[User:finex|FiNeX]] Patch for disabling the "apply template" button when there are zero templates: http://pastebin.ca/1028787 committed (authorized by winterz)</s>
 +
 
 +
*<s> [[User:finex|FiNeX]] Tooltips on events display "&amp;nbsp;"</s>
 +
 
 +
* <s> Menu item "help > about korganizer" change icon when hovering.</s> -- gemegik, [[User:Med|Med]]
 +
 
 +
*<s> A lot of menu items (most?) are missing when Korganizer is run stand-alone, but they are there when using kontact to browse the korganizer parts.</s> [[User:Talavis|talavis]]
 +
 
 +
* <s>Opening korganizer stand-alone will open only the part last selected in Kontact, and it's impossible to show any toolbars or anything (related to the above bug?) [[User:Talavis|talavis]]</s>
 +
** <s>[[User:finex|FiNeX]] It is probably related to that bug. Currently both issue seems fixed in trunk.</s>
 +
 
 +
* create new event, change start time to "7am", hit "ok".  i get a window saying "please specify a valid start time, for example '04:18 am', and then the whole event window closes, dropping all my information.  This should just let me continue to edit the event, unless i decide to press "cancel" instead of "ok".  Also, "7am" and "7pm" should be recognized as times, IMHO. [[User:Doviende|Doviende]]
 +
** [[User:finex|FiNeX]] Confirmed, it shouldn't loose informations.
 +
 
 +
*<s> create new event, enable "time associated", set the start and end time, then make it a new template by going to "manage templates" and pressing "new".  Then go make another event and apply this template...it will enable "time associated" for you, but it won't set the times. [[User:Doviende|Doviende]]</s>
 +
** <s>[[User:finex|FiNeX]] Do you suggest to set ONLY the time, or even the date? I've reported it on bugzilla: http://bugs.kde.org/show_bug.cgi?id=169146</s>
 +
 
 +
*<s> in events, "19:00" is not recognized as a time, forced to use only "07:00 pm" [[User:Doviende|Doviende]]
 +
** [[User:finex|FiNeX]] It depends to the time format set on systemsettings.</s>
 +
 
 +
* severe bug in dates:  create a new event, enable "time associated", click on the "end" date field and press the up-arrow.  notice that the "08" for the year will now say just "8", and it actually means the year "8" instead of "2008".  if you hit "apply" now, it'll say that your end time is before your start time.  You can not fix the field back to 2008 without cancelling the event entirely and starting over again. [[User:Doviende|Doviende]]
 +
** do the previous action, then click on "start date" field and press up-arrow.  start date will now be 2000 years back too, but look at the end date now.  it will have an additional 2000 years subtracted, and it will say "-1993" for the year.  [[User:Doviende|Doviende]]
 +
** [[User:finex|FiNeX]] Created bug number #169127.

Latest revision as of 10:36, 15 August 2008

Contents

[edit] KOrganizer

[edit] Application specific tips

any application specific tips go here.

I just recently rewrote the todo view completely. The rewrite is done, would be great if you could give it a throughout test. (nick:chiefaua, svn:thrainer)

[edit] Testers

Please put your IRC nickname and KDE PIM svn revision number in the table if you are testing this app.

IRC Nickname KDE PIM svn revision number tested. Testing details
Grundleborg svn trunk r803492 not tested yet
FiNeX svn r811489 testing
talavis svn r818299 testing
doviende svn r846116 testing

[edit] Bugs

Please list all bugs found in the application below here. Remember to sign every comment you write on this wiki page with ~~~.

  • FiNeX On the calendar views (month/day/week) after selecting a range, if you start type a new event is created. You can do this only one time, after you have to close/restart korganizer for repeat this behaviour.
    • FiNeX Moreover on 3.5 what you typed were used as event title, this doesn't happen anymore.
    • Volker Fixed in revision 813635.
  • FiNeX start/end date on "event" dialog is too small: the first two digits of the year are cutted out. korganizerdateshq1.jpg
  • FiNeX "Edit reminders" dialog: the offset column text is between "<html>...</html>".
  • FiNeX "Edit event" file dialog: "Calendar:..." label too near to "Categories" label. It is confusing.
  • FiNeX "Manage templates" dialog: if you have zero templates and you click on "apply template" the "new" button is disabled.
  • FiNeX Tooltips on events display "&nbsp;"
  • Menu item "help > about korganizer" change icon when hovering. -- gemegik, Med
  • A lot of menu items (most?) are missing when Korganizer is run stand-alone, but they are there when using kontact to browse the korganizer parts. talavis
  • Opening korganizer stand-alone will open only the part last selected in Kontact, and it's impossible to show any toolbars or anything (related to the above bug?) talavis
    • FiNeX It is probably related to that bug. Currently both issue seems fixed in trunk.
  • create new event, change start time to "7am", hit "ok". i get a window saying "please specify a valid start time, for example '04:18 am', and then the whole event window closes, dropping all my information. This should just let me continue to edit the event, unless i decide to press "cancel" instead of "ok". Also, "7am" and "7pm" should be recognized as times, IMHO. Doviende
    • FiNeX Confirmed, it shouldn't loose informations.
  • create new event, enable "time associated", set the start and end time, then make it a new template by going to "manage templates" and pressing "new". Then go make another event and apply this template...it will enable "time associated" for you, but it won't set the times. Doviende
  • in events, "19:00" is not recognized as a time, forced to use only "07:00 pm" Doviende
    • FiNeX It depends to the time format set on systemsettings.
  • severe bug in dates: create a new event, enable "time associated", click on the "end" date field and press the up-arrow. notice that the "08" for the year will now say just "8", and it actually means the year "8" instead of "2008". if you hit "apply" now, it'll say that your end time is before your start time. You can not fix the field back to 2008 without cancelling the event entirely and starting over again. Doviende
    • do the previous action, then click on "start date" field and press up-arrow. start date will now be 2000 years back too, but look at the end date now. it will have an additional 2000 years subtracted, and it will say "-1993" for the year. Doviende
    • FiNeX Created bug number #169127.

This page was last modified on 15 August 2008, at 10:36. This page has been accessed 5,001 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal