Difference between revisions of "Contribute/Bugsquad/BugDays/KDEPIMKrush1/Akregator"

Jump to: navigation, search
(Bugs: build fixed. sure of this one. ;))
(Bugs)
 
(2 intermediate revisions by 2 users not shown)
Line 23: Line 23:
 
|-
 
|-
 
|[[User:Blauzahl|Blauzahl]] || svn trunk pimlibs r816572 apps r816865 || doing
 
|[[User:Blauzahl|Blauzahl]] || svn trunk pimlibs r816572 apps r816865 || doing
 +
|-
 +
|[[User:Gkiagia|gkiagia]]||svn trunk r846201 || in progress ||
 
|}
 
|}
  
Line 34: Line 36:
 
* Bug: When I hide the 'total' and 'not read' columns from the feed list, they reappear at next startup. -- gemegik
 
* Bug: When I hide the 'total' and 'not read' columns from the feed list, they reappear at next startup. -- gemegik
  
* Bug: Feed favicons don't stay between sessions, they only appear when fetching the feed. -- gemegik
+
*<s> Bug: Feed favicons don't stay between sessions, they only appear when fetching the feed. -- gemegik
** Confirmed [[User:Krop|Krop]]
+
** Confirmed [[User:Krop|Krop]]</s>
  
 
* Regression: In 3.5, akregator printed "$feedname ($unread_count)" as the feed title if the 'total' and 'not read' columns were hidden. -- gemegik
 
* Regression: In 3.5, akregator printed "$feedname ($unread_count)" as the feed title if the 'total' and 'not read' columns were hidden. -- gemegik
Line 43: Line 45:
 
* [[User:Krop|Krop]] Settings/Archive/"limit feed archive size to..." doesn't accept values > 99 (same thing for "delete articles older than...")
 
* [[User:Krop|Krop]] Settings/Archive/"limit feed archive size to..." doesn't accept values > 99 (same thing for "delete articles older than...")
  
* [[User:Krop|Krop]] Settings/Archive/"keep all articles" and "disable archiving" buttons is always unchecked when you open settings.
+
* <s>[[User:Krop|Krop]] Settings/Archive/"keep all articles" and "disable archiving" buttons is always unchecked when you open settings.</s>
  
* [[User:Krop|Krop]] Settings/Advanced : the "Configure" button is always greyed whatever choice you make.
+
* <s>[[User:Krop|Krop]] Settings/Advanced : the "Configure" button is always greyed whatever choice you make.</s>
  
 
* [[User:Med|Med]] When a new feed entry is received, it it contains an apostrophe in the title, it will be displayed as &apos;. It works when marking a message as unread too. If i restart akregator, the apostrophes are displayed correctly. Images that illustrate the problem [http://mboquien.free.fr/akregator_1.png receiving a new entry] and [http://mboquien.free.fr/akregator_2.png after having clicked on this entry].
 
* [[User:Med|Med]] When a new feed entry is received, it it contains an apostrophe in the title, it will be displayed as &apos;. It works when marking a message as unread too. If i restart akregator, the apostrophes are displayed correctly. Images that illustrate the problem [http://mboquien.free.fr/akregator_1.png receiving a new entry] and [http://mboquien.free.fr/akregator_2.png after having clicked on this entry].
Line 61: Line 63:
  
 
*(Usability) When opening, "Feeds" is very narrow compared to the other fields, or at least it is narrow enough that I can't see what any of the default feeds are. I figure this is probably the most important field, but at first I didn't realize it was something I wanted to be reading.[[User:Blauzahl|Blauzahl]]
 
*(Usability) When opening, "Feeds" is very narrow compared to the other fields, or at least it is narrow enough that I can't see what any of the default feeds are. I figure this is probably the most important field, but at first I didn't realize it was something I wanted to be reading.[[User:Blauzahl|Blauzahl]]
 +
 +
* [[User:Gkiagia|gkiagia]] (Usability) When opening a page in a new tab, the new tab opens after the web server has responded. However, if the web server doesn't respond, the tab will not open immediately but only after a few minutes, showing a timeout error. That confuses users as they think they didn't click on the link or that akregator is broken. Solution: open the new tab before negociating with the remote server.

Latest revision as of 15:03, 13 August 2008

Contents

[edit] Akregator

[edit] Application specific tips

any application specific tips go here.

[edit] Testers

Please put your IRC nickname and KDE PIM svn revision number in the table if you are testing this app.

IRC Nickname KDE PIM svn revision number tested. Testing details
Grundleborg svn trunk r803492 not tested yet
reldruh 4.1 Beta1 done
gemegik 4.0.74-1 debian experimental done
FilledVoid 4.1 Beta1 done
krop svn trunk r812273
andy_ svn trunk r818102
Blauzahl svn trunk pimlibs r816572 apps r816865 doing
gkiagia svn trunk r846201 in progress

[edit] Bugs

Please list all bugs found in the application below here. Remember to sign every comment you write on this wiki page with ~~~.

  • Bug: when loading the full site in the preview pane (advanced option) and scolling and article with the mouse whell, scroll goes out of page boundaries and the preview pane only displays garbage then. -- gemegik
  • Bug: When I hide the 'total' and 'not read' columns from the feed list, they reappear at next startup. -- gemegik
  • Bug: Feed favicons don't stay between sessions, they only appear when fetching the feed. -- gemegik
  • Regression: In 3.5, akregator printed "$feedname ($unread_count)" as the feed title if the 'total' and 'not read' columns were hidden. -- gemegik
  • Regression: Doesn't follow the konqueror preferences for smooth scrolling (active in akregator while disabled in konqui). -- gemegik
  • Krop Settings/Archive/"limit feed archive size to..." doesn't accept values > 99 (same thing for "delete articles older than...")
  • Krop Settings/Archive/"keep all articles" and "disable archiving" buttons is always unchecked when you open settings.
  • Krop Settings/Advanced : the "Configure" button is always greyed whatever choice you make.
  • Med When a new feed entry is received, it it contains an apostrophe in the title, it will be displayed as '. It works when marking a message as unread too. If i restart akregator, the apostrophes are displayed correctly. Images that illustrate the problem receiving a new entry and after having clicked on this entry.
  • When opening an article in a new tab, ctrl+w does not close it. Med
    • One liner patch. Link sent on #kontact but i put it here too in case it would be lost. Med 03:15, 28 May 2008 (CEST)
  • When opening an article in a tab, if the page contains an error, a small red bug is displayed at the bottom of the screen. Unfortunately they are not removed when a tab is closed. I think the expected behaviour would be that the bug is present only in relation to the active tab (therefore no bug would be displayed if there are bugs in inactive pages). Med
  • When sorting articles after Date, new articles of are showing between Yesterday and Thursday, see here. -- andy_
  • When toggling View Modes ( Normal -> Combined -> Normal ) the feed preview list becomes empty. However does change back on clicking on another feed and returning back. See here -- FilledVoid
  • Marking an article with a shortcut does not work (ctrl+I for important, ctrl+U for unread, etc.). It works when right-clicking and selecting in the menu though. Med
  • (Usability) When opening, "Feeds" is very narrow compared to the other fields, or at least it is narrow enough that I can't see what any of the default feeds are. I figure this is probably the most important field, but at first I didn't realize it was something I wanted to be reading.Blauzahl
  • gkiagia (Usability) When opening a page in a new tab, the new tab opens after the web server has responded. However, if the web server doesn't respond, the tab will not open immediately but only after a few minutes, showing a timeout error. That confuses users as they think they didn't click on the link or that akregator is broken. Solution: open the new tab before negociating with the remote server.

This page was last modified on 13 August 2008, at 15:03. This page has been accessed 4,795 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal