Difference between revisions of "Archive:Getting Started/Build/KDE4/Prerequisites (zh TW)"

Jump to: navigation, search
m (Text replace - "</code>" to "</syntaxhighlight>")
 

Latest revision as of 16:22, 23 June 2013

Template:I18n/Language Navigation Bar (zh TW)

Template:TutorialBrowser (zh TW)

Contents

[edit] 摘要

部分或所有這些套件應該可以從您的發行版安裝。如果提供夠新的版本,安裝發行版套件是一個不錯的主意;可以方便安裝和升級。建構 KDE 4 的軟體須求包括:

  • gcc 和 g++,最好是4.2或更高版本
  • svn,subversion 版本控制客戶端
  • pkg-config
  • X11、OpenGL(mesa-common-dev和libglu1-mesa-dev)、libjpeg、libpng、libungif、librdf、libxml2以及libxslt的開發庫和標頭檔
  • kdesdk 中的 makeobj 腳本。You can install it from kdesdk (kdesdk-scripts on Debian) or similar packages, or download at WebSVN
  • the shared-mime-info package, is the freedesktop MIME standard now used in KDE
  • the shared-desktop-ontologies package is required to build and run all Nepomuk semantic desktop/desktop search modules.
  • boost, used by kdebase; after build and/or install, in order to make cmake aware about its location (FindBoost), add the boost directory (which contains the include subdirectory) to CMAKE_INCLUDE_PATH or set a environment variable called BOOST_ROOT that points to the boost directory.

[edit] D-Bus

QtDBus 和 KDE 使用的 D-Bus 版本為0.62和0.92或更高的版本。0.60和0.61版可能可以運作但未經測試。0.90和0.91版確定無法運作。我們建議使用1.0版(最低0.94),所以如果你還沒有該版本,請考慮升級。

You may skip this section if you have a recent D-Bus version or if you don't want to upgrade. You probably want to skip building the bindings until/unless you know you will be building HAL (see below).

Before running these steps in the recipe, make sure your X11 headers and libraries are available. The configure script run on line 5 of the following instructions should output:

Building X11 code:        yes


[edit] 方法

Template:Tip (zh TW) (NOTE: on my intrepid installation, I had to additionally set my CFLAGS to '-D_GNU_SOURCE' for this to work)

cs # 'cs' is a bash function, click here to learn more 
wget http://dbus.freedesktop.org/releases/dbus/dbus-1.0.2.tar.gz
tar -xvzf dbus-1.0.2.tar.gz
cd dbus-1.0.2/
./configure --prefix=$DBUSDIR --localstatedir=/var
make
sudo make install
sudo dbus-uuidgen --ensure
cs # see above
wget http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-0.74.tar.gz
tar -xvzf dbus-glib-0.74.tar.gz
cd dbus-glib-0.74/
./configure --prefix=$DBUSDIR
make
sudo make install
cd
sudo chown -R kde-devel:kde-devel *

[edit] 發生什麼事

After changing into the source directory (line 1), D-Bus source code is downloaded from freedesktop.org (line 2) and unpacked (line 3). After going into the newly created D-Bus directory (line 4), the build is set up using the supplied configure script (line 5). After building (line 6) and installing (line 7) D-Bus, we use the dbus-uuidgen tool to install a machine identification file that allows the bus to start automatically when the desktop session starts (line 8).

Note that you need write access to /var for the last two steps. If your system does not have the sudo command, you can use the su command instead, e.g. su -c "make install".

The steps for building the glib bindings are similar to the above.

When these two packages are done building, we must fix the file ownership because 'sudo make install' has created root owned files and directories in ~kde-devel/kde.

[edit] 疑難排解

If you get the error: "configure: error: DBus development libraries not found" do this: export PKG_CONFIG_PATH=/lib/pkgconfig/

[edit] CMake

Skip this if you have CMake >=2.6.2 installed. You should be able to directly use the binary packages available on the CMake site. There are also distribution specific packages available.

[edit] 方法

cs # 'cs' is a bash function, click Here to learn more 
wget http://www.cmake.org/files/v2.6/cmake-2.6.2.tar.gz
tar -zxf cmake-2.6.2.tar.gz
mkdir cmake-build
cd cmake-build 
../cmake-2.6.2/bootstrap
make
sudo make install

[edit] 發生什麼事

First, we go back to the kde-devel user's source directory (line 1), get the CMake sources (line 2) and unpack them (line 3). We create a directory to build CMake in (line 4) and go into it (line 5). We then run the CMake bootstrap script to set up the CMake build (line 6), then make (line 7) and install it (line 8) using the root user.

If your system does not have the sudo command, you can instead do su -c "make install".

[edit] Qt

接下來我們需要取得 Qt 4。KDE 4.3 的建構倚靠 Qt 4.5,但是 KDE trunk 需要 Qt 4.6。如果你計劃持續的建構 trunk,kde-qt 可能更容易追蹤,尤其是 KDE trunk 有時可能需要正式發行前的 Qt 版本。

大部分最新的發行版將有足夠新的 Qt 套件去建構最新的 KDE 穩定分支。一些發行版甚至有 kde-qt 套件;如果有,使用它是一種可行的選擇。如果您使用的發行版不提供需要的 Qt 版本,就必須使用下面的方法。更多資訊可在針對發行版的教學章節找到。

Building qt4.4 with the -no-qt3support option will cause things to break.

Please read the README.kde-qt file for the necessary Qt configure options as well as currently known issues.

[edit] 方法

cs    # Note: cs is not a typo. See  .bashrc 
git clone git://gitorious.org/+kde-developers/qt/kde-qt.git qt-kde
cd qt-kde
./configure [copy/paste configure line from README.kde-qt replacing <installdir> with $QTDIR]
make -j2 # use 'make -j(X+1)' where X is your number of processors, to compile faster
# if we don't install, we'll just clear obj files to
# save disk space
if [ "$QTDIR" = "`pwd`" ]; then \
find . -name '*.o' -delete ; \
else make install; fi;
If ./configure produces errors about missing headers, run the following command before trying again:
QTDIR=`pwd` bin/syncqt

Make sure which qmake delivers something out of $QTDIR, e.g.:

/home/kde-devel/qt-kde/bin/qmake

[edit] 發生什麼事

We switch back to the kde-devel user's home directory (line 1) and download the source code, KDE branch, from gitorious using git (line 2). After changing into the resulting qt-kde directory (line 3), we then set up the build using the configure script (line 4). The various command line options used are explained in the qt-kde/README.kde-qt file. Finally, we build the minimal requirements for KDE (line 6) and install (line 9) Qt. If install dir is the same as the current dir (line 7), then we just free some space (line 8) instead. If you want all the example and demo applications, you can either build them individually or simply do a make from the qt-kde directory.

Note that the installation does not require root as it installs Qt locally into $QTDIR. Installation is necessary if $QTDIR differs from the source directory. In the end, we make sure the cmake macro to find the Qt directory will work. It must be able to find qmake in $QTDIR.

[edit] 疑難排解

If you get "error: X11/Xlib.h: No such file or directory", install the devel package of xorg (the actual name may vary between operating systems, for example it is xorg-dev on Ubuntu based systems such as Kubuntu).

If you get an error in the configure step about missing defines, check the value of $QMAKESPEC. Some distributions set this to point directly to the system-installed Qt. If unset QMAKESPEC solves the problem, you probably want to add it to the ~/.bashrc script.

If you get an error ".pch/debug-shared/QtCore", this is because Qt-4.3 enables precompiled headers if your gcc supports it, but for some reason it doesn't work for you. If you use distcc, configure qt with -no-pch. If you use icecream, update to the latest icecream from svn trunk.

Try running any Qt program, like assistant. Note: You may need to run xhost +local:kde-devel as your regular kde3 user to run this application. If it crashes in QSpanData::adjustSpanMethods, then your problem is the oxygen style. Try removing lib/kde4/plugins/styles/kstyle-oxygen.so and lib/kde4/plugins/styles/oxygen.so if they exist in the KDE install prefix.

[edit] Generating local API documentation

It's nice to have the Qt documentation locally for nice integration with KDevelop, and doing this is really quite easy (also shown in README.kde-qt):

cd $KDE_SRC/qt-kde
make docs
./config.status
make install

Note that it is necessary to do this only once, even if you rebuild Qt later.

[edit] HAL

Template:Tip (zh TW)

If your system requires you to build a newer version of HAL, there's a decent chance you'll need to build other stuff as well, some of which may not be straight forward. This, however, should only be required for older distros.

[edit] kdesupport

Template:Warning (zh TW)

在kdesupport模塊中,有幾個 KDE 應用程式相依的函式庫。This includes Phonon, Strigi and Soprano for file metadata and search, QImageBlitz for image manipulation needed in kdebase, eigen for visual effects in applications such as Kalzium, taglib for music players and qca for some cryptographic needs.

Strigi itself has a few dependencies as well: you will need the libraries and headers for libz, libbz2, openssl (libcrypto or libssl), libclucene (>=0.9.16a but watch out: version 0.9.17 does not work), and either libxml2 or libexpat.

Please remember that if you use openSUSE, you can install the needed packages from the KDE:KDE4 buildservice repository and do not have to bother with fiddling the details below. Skip to the kdelibs section.

[edit] 方法

cs # 'cs' is a bash function, click here to learn more
svn checkout svn://anonsvn.kde.org/home/kde/trunk/kdesupport/
cd kdesupport
cmakekde

[edit] 發生什麼事

We change to the base source directory (line 1). We download the sources in kdesupport using subversion (line 2), go into the new ~/kde/src/kdesupport directory (line 3), and commence the build (line 4). This will leave us in the kdesupport build directory after the build is completed.

[edit] 疑難排解

If you get

  cmakekde: command not found

then you have to go manually into the kdesupport directory in ~ and execute the command cmakekde. if this still doesn't work, then something is wrong with your bashrc.

If you get

CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:
LIBXML2_INCLUDE_DIR (ADVANCED)

you should install the development package for libxml2.

If you get

CMake Error: Could NOT find REDLAND

then you need librdf from the Redland. If your distribution does not provide the librdf package, you can download the source there: http://download.librdf.org/source/ and build it. (Gentoo users: The ebuild for librdf is named dev-libs/redland)

If you get

Fetching external item into 'kdesupport/admin'
Error validating server certificate for 'https://...'

see Using Subversion with KDE

If you get

FILE cannot create directory: /usr/lib[64]/qt4/plugins/crypto. Maybe need administrative privileges.

make: *** [install] Error 255

take a second look in the .bashrc file described above, are paths correct? ($QTDIR and $PATH are used to get the QT installation path) Alternatively, you may see this error if you decided to use a distribution installed version of qt4 and skipped the Qt install above. Either install qt-kde as describe above, or "sudo make install". If you use "sudo make install", make sure that you change the ownership back to your user for some of the ~/kde subdirectories that were effected by using sudo (ie. "sudo chown -R kde-devel:kde-devel ~/kde").

If you get a message related to

  target libQtTest.so not found

you may need to recompile qt-kde. This time you should take out

  -nomake demos -nomake examples

from the configure command, so that Qt generates library QtTest.


If you get

     CMake Error: Qt qmake not found!

Then:

     1) uncomment Qt section in .bashrc script (QTDIR, QT_PLUGINS_DIR,      
           PKG_CONFIG_PATH variable settings).
     2) source ~/.bashrc
     3) cd && cd qt-kde
     4) make confclean
     5) repeat steps for installing Qt (from ./configure line).
     6) retry building kdesupport

If you get

     "CMake Error: Could NOT find BZip2"

then

     sudo apt-get install libbz2-dev

or

     urpmi libbzip2_1-devel

If you get

     message that MySql support cannot be enabled

then

     you need to install corresponding devel package. (libmysqlclient-devel  for SuSe 11.1)

[edit] 下一步

Once all requirements have been installed it is time to install kdelibs


This page was last modified on 23 June 2013, at 16:22. This page has been accessed 2,342 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal