Getting Started/Build/Requirements/kdepim-runtime by module

Jump to: navigation, search

kdepim-runtime Package Dependencies

Package Level Description Comments
Akonadi >= 1.4.91 Required Akonadi server libraries Akonadi is required to build kdepim-runtime.
Boost >= 1.34.0 Required Boost C++ Libraries Required by Akonadi.
Nepomuk Required The Nepomuk libraries Nepomuk extends the search and tagging functionalities in KMail and Akonadi
QtDeclarative >= 4.7 Required Qt Declarative (QML) module Required for building mobile UI
Shared desktop ontologies >= 0.6.51 Required Desktop ontologies Ontologies necessary for the Nepomuk semantic desktop.
SMI >= 0.30 Required SharedMimeInfo SharedMimeInfo is required.
Soprano >= 2.3.70 Required Semantic Desktop Storing Soprano is needed for Nepomuk
xsltproc Required The command line XSLT processor from libxslt Required for building Akonadi.
QtXmlPatterns STRONGLY RECOMMENDED The Qt module QtXmlPatterns (included with Qt) Needed for building Akonadi resources. . Remove -no-exceptions from the Qt configure line if you are missing this library.
LibXML2 Optional Libraries used to develop XML applications Needed for building the knut Akonadi resource.
Strigi Qt D-Bus client library Optional Strigi built with indexing For Akonadi tools such as the message searchprovider
Strigi Optional Strigi desktop search engine

This page was last modified on 7 May 2012, at 14:00. This page has been accessed 1,294 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal