Getting Started/Build/KDE4/LFS (es)

Jump to: navigation, search


Building KDE4 From Source (Linux From Scratch requirements)
Tutorial Series   Getting Started
Previous   Build KDE4.x, D-Bus Configuration
What's Next   Build KDE4.x
Further Reading   Introduction to CMake




Contents

CMake

KDE-4 y algunas librerias de apoyo usan CMake.



Instala la ultima version desde cmake.org



Requerimientos de libreria

Dependencias generales

KDE-4 requiere muchas de las mismas librerias de uso general que KDE-3.




La salida de ejecutar CMake debe listar lo que hace falta -- que generalmente son librerias que necesitas y no discutire mas a fondo.





DBus and HAL

Un sistema deberia tener instalado esto:




DBus
DBus-Glib
HAL
HAL-Info
PolicyKit
EggDBus
polkit
ConsoleKit

(y propiamente configurado) aunque, estrictamente hablando, no son todas dependecias para KDE-4.x.


 

Ver: BLFS para instrucciones de construccion y configuracion.


 

COMO SEA, KDE-4 y las librerias KDESupport pueden necesitar versiones mas recientes que las que estan en BLFS. Asi que probablemente es mejor instalar la ultima version de las dependencias que la version en BLFS.


 

 Librerias Boost C++

Consigue la ultima version (por ejemplo boost_1_42_0.tar.gz) aqui:

 





http://sourceforge.net/projects/boost/files/boost/



 Construir 

La version actual elimina problemas de nombres arcaicos.  The current release eliminates the arcane naming issues. Aunque no es lo mismo que usando autotools, ahora es simple de construir e instalar.

 


Remover los includes de versiones anteriores:

 





/usr/include/boost_<version>

y si tienes un link:

 





/usr/include/boost

removerlo tambien.

 


Entonces:

 





./bootstrap.sh --prefix=/usr
./bjam install

CLucene

Los desarrolladores de CLucene seguieren usar el repositorio GIT desde que no hay versiones recientes. Como sea, KDE-4 actualmente depende de la ultima (antigua) versión:

 





http://downloads.sourceforge.net/project/clucene/clucene-core-stable/0.9.21b/clucene-core-0.9.21b.tar.bz2

No usar CMake para construirlo.

 





Qt

TRUNK

Usar kde-qt desde:

 





git clone git://gitorious.org/+kde-developers/qt/kde-qt.git

Esto instala como Qt-<version>, entonces cuando se actualiza a la siguiente version, no se instalara en el mismo lugar. Esto significa que necesitaras cambiar el <version> a cualquier lugar donde este especificado. Tambien tendras que instalar QCA (y sus complementos) otra ves cuando la version cambia

 





4.4

Puedes usar el GIT clone [ver TRUNK arriba], o puedes usar la ultima version de QT-4.6.x desde Nokia:

 





http://qt.nokia.com/downloads/linux-x11-cpp
BRANCH a 4.3 o una version 4.3.x 

Usar 4.5.3:

 





http://qt.nokia.com/downloads/downloads#lgpl
 Construir 

Probablemente necesitaras usar algunas opciones para configurar Qt. Varias opciones pueden ser apropiadas y/o necesarias dependiendo del sistema, de lo que has instalado, y donde lo has instalado. Ejecutar:

 





 ./configure --help

para ver las opciones. Hay una gran cantidad de ellas, pero los valores por defecto funcion bien para la mayoria.

 


  Configuracion sugerida:

 





./configure -no-separate-debug-info -plugin-sql-mysql -I/usr/include/mysql -plugin-sql-sqlite -optimized-qmake -nomake demos -nomake examples -fast -dbus

{cambiar el include de mysql como sea necesario}

 



Si se instala Phonon desde KDESupport (recomendado), o otro Phonos separado, añadir la opcion de configuracion:

 





-no-phonon

para evitar tener dos versiones de librerias con el mismo numeor SO






 QCA-2.0.2 (Añadido cripto para Qt) 

No usar el que esta en KDESupport o en el SVN de KDE.

 



Descargar la ultima version de gca desde:

 





http://delta.affinix.com/download/qca/2.0/

y los complementos:

 





qca-cyrus-sasl
qca-gnupg
qca-ossl

desde:

 





http://delta.affinix.com/download/qca/2.0/plugins/

NOTA: qca-ossl-2.0.0-beta3 no se construira contra la version actual de OpenSSL sin ser parcheado:

 





http://home.earthlink.net/~tyrerj/kde/KDE-4/qca-ossl.patch

GMM

Si no tienes Getfem++ instalado, obten la ultima version de GMM desde, get the current release of GMM from:

 





http://home.gna.org/getfem/download.html

Qzion and Qedjie

Obtenlos:

 





http://code.openbossa.org/projects/qedje/pages/Home

y la ultima version de la dependencia EET aqui:

 





http://download.enlightenment.org/releases/

PROBLEMA: La RAMA actual de KDE-4.3 requeire QEdje >= 0.4.0 que depende de QZion >= 0.4.0 y la version 0.and the 0.4.0 release of QZion will not build.

 


Si no se construye, checa la linea 13 de este archivo:

 





... /qzion-mainline/python/qzion/qzionobject.sip

Deve ser:

 





const char *name;

Eigen2

Obten la version actual 2.0.x desde:

 





http://eigen.tuxfamily.org

Java Development Kit

Necesitaras un compilador Java con JNI para construir el backend de almacenamiento Sesame2 para soprano y un Java RunTime (JVM) para ejecutarlo.

 





http://java.sun.com/javase/downloads/widget/jdk6.jsp

Recuerda añadir el directorio "bin" a la path y el directorio "lib" al archivo "/etc/ld.so.conf".

 





Raptor, Rasqal, and Redland

Obten:

 





redland-1.0.8
rasqal-0.9.17
raptor-1.4.20

Desde:

 





http://download.librdf.org/source/

Nota: Versiones nuevas de Redland no funcionan.

 


y la version actual (opcional) de la dependencia de Redland 3Store aqui:

 





http://downloads.sourceforge.net/project/threestore/files/

Nota: 3store3-3.0.17 no se construira contra Rasqal-0.9.17. Saltalo por ahora -- es opcional.

 


Cuando construyendo Redland, probablemente necesitaras usar:

 





--with-bdb=

para apuntar el directorio de tu Berkeley DB.

 


Si tu SQLite instalado es > 3.6.16, probablemente tendras que configurar Redland con:

 





--with-sqlite=no

Instalar en este orden:

 





Raptor
Rasqal
Redland

Entonces, "configure" y "make install" Rasqal una segunda vez.

 





Virtuoso Open-Source

Solamente necesario para KDE-4.4 y TRUNK  



La revision actual de SVN de KDE-4.4 BRANCH, KDE-4 TRUN y KDESupport TRUNK requiere virtuoso-opensource-6.1.0. Esto puede no funcinar con versiones anteriores de Soprano. Si tienes un problema, usa el SVN de Soprano en KDESupport TRUNK.



Obten virtuoso-opensource >= 6.1.0 aqui:





http://sourceforge.net/projects/virtuoso/

NOTA: A partir del Martes 9 de Febrero de 2010, a las 17:05:35 hay un problema con la descarga de SF.  



y la version actual de la dependencia iODBC aqui:





http://www.iodbc.org/dataspace/iodbc/wiki/iODBC/Downloads

Si construyes iODBC solamente para KDE, usa el parametro de configuracion:  





--disable-gui

Para construir Virtuoso, estos parametros de configuracion son utiles:  




--with-jdk4=


--without-internal-zlib
--with-pthreads
--with-readline
--with-iodbc=

Si construyes Virtuoso solamente para KDE, (para salvar espacio en el disco) usa el parametro de configuracion:  



--disable-all-vads

KDESupport

TRUNK

usa:  





svn co svn://anonsvn.kde.org/home/kde/trunk/kdesupport

Si no quieres instalar todos los iconos pequeños de SVN:  





cd kdesupport/oxygen-icons
svn rm `find -name "small"`

El trunk actual no es compatible con el FFmpeg instalado en LFS. Usa este parche:  



------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------

Index: strigi/src/streamanalyzer/endplugins/CMakeLists.txt
===================================================================
--- strigi/src/streamanalyzer/endplugins/CMakeLists.txt (revision 1096146)
+++ strigi/src/streamanalyzer/endplugins/CMakeLists.txt (working copy)
@@ -34,9 +34,3 @@
   target_link_libraries(xine ${XINE_LIBRARY})
 endif(XINE_FOUND)
 
-if(FFMPEG_FOUND)
-  include_directories(${FFMPEG_INCLUDE_DIRS})
-  ADD_STRIGIEA(ffmpeg ffmpegendanalyzer.cpp)
-  #set_target_properties( ffmpeg PROPERTIES COMPILE_FLAGS "${FFMPEG_DEFINITIONS}" )
-  target_link_libraries(ffmpeg ${FFMPEG_LIBRARIES})
-endif(FFMPEG_FOUND)
------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------

O, usa la imagen de FFmpeg de la pagina de CBLFS:  





http://cblfs.cross-lfs.org/index.php/FFmpeg

La imagen mas reciente requiere: "libx264.so.83". La imagen  x264 es CBFLS es muy antigua. Este RPM de codigo funciona:  





x264-0.83.2245-1plf2010.1.src.rpm

Google es tu amigo.  





KDE-4.4

Usa:  





svn co svn://anonsvn.kde.org/home/kde/tags/kdesupport-for-4.4

Esto no incluye: Ontologies. Ver abajo.  





BRANCH a 4.3 o una version 4.3.x  

Usar la etiqueta SVN que coincida con tu version de KDE. Por ejemplo para 4.3:  





svn co svn://anonsvn.kde.org/home/kde/tags/kdesupport-for-4.3/kdesupport
 Construir  

El QCA en KDESupport no es usado actualmente (ver QCA-2.0.2 arriba) entonces:  





svn rm qca

NOTA: Tu puedes necesitar añadir estos parametros a la linea de comandos de CMake:  





-DENABLE_FAM:BOOL=ON
-DENABLE_EXPAT:BOOL=ON
-DENABLE_INOTIFY:BOOL=ON
-DGAIM_LIBS:STRING=<path>/lib
-DGAMIN_LIBRARIES:STRING=<path>/lib

Ontologies

Solamente necesario para KDE-4.4 y TRUNK.  



If you checked out KDESupport from TRUNK, you have the package. Otherwise, get it here:





svn co https://oscaf.svn.sourceforge.net/svnroot/oscaf/trunk/ontologies

and install with the same: "CMAKE_INSTALL_PREFIX" as KDESupport.






Phonon

KDE-4.4 and TRUNK only.




Phonon has been moved to 





http://gitorious.org/phonon

Get it with the command:






git clone git://gitorious.org/phonon/phonon.git

and install with the same CMAKE_INSTALL_PREFIX as KDESupport.




KDEBindings-4.4.x will not build against Phonon from the GIT repository.





PolKit-KDE-1

TRUNK

TO DO






KDE-4.4

Use:






ftp://ftp.kde.org/pub/kde/stable/apps/KDE4.x/admin/polkit-kde-1-0.95.1.tar.bz2
Build

The tarball from the KDE FTP site will not install correctly. You need to apply this patch:




------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------

diff -Naur polkit-kde-1-0.95.1.old/agent/CMakeLists.txt polkit-kde-1-0.95.1/agent/CMakeLists.txt
--- polkit-kde-1-0.95.1.old/agent/CMakeLists.txt	2009-12-23 04:31:29.000000000 -0700
+++ polkit-kde-1-0.95.1/agent/CMakeLists.txt	2010-03-25 15:54:12.000000000 -0700
@@ -11,7 +11,7 @@
 
 target_link_libraries(polkit-kde-authentication-agent-1
                                          ${KDE4_KDEUI_LIBS}
-                                         ${POLKITQT-1_AGENT_LIBRARY}
+                                         ${POLKITQT-1_LIBRARIES} 
 )
 
 configure_file(polkit-kde-authentication-agent-1.desktop.in ${CMAKE_BINARY_DIR}/polkit-kde-authentication-agent-1.desktop)
@@ -25,4 +25,4 @@
   set (DESKTOP_INSTALL_DIR /etc/xdg/autostart)
 endif (DESKTOP_INSTALL_DIR)
 
-install(FILES ${CMAKE_BINARY_DIR}/polkit-kde-authentication-agent-1.desktop DESTINATION ${DESKTOP_INSTALL_DIR})
+install(FILES ${CMAKE_BINARY_DIR}/polkit-kde-authentication-agent-1.desktop DESTINATION ${KDE4_AUTOSTART_INSTALL_DIR})
------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------8<------

shared-mime-info

Get the current release from:






http://www.freedesktop.org/wiki/Software/shared-mime-info

You need to install this with the same prefix as KDE4 (even if you already have it installed in "/usr") to eliminate missing MIME type errors. Currently, KDELibs won't build unless you do this. And, even if it does, you will get run time errors -- popup windows saying that certain MIME types can not be found.




This appears to be a bug that needs to be looked into, but this workaround does seem to work.





KIPI Plugins

Get the current release from:






http://sourceforge.net/projects/kipi/

This package is dependent on KDEGraphics. The package has a lot of optional dependencies which you need to satisfy only if you want the corresponding plugins built. You should install it in the same directory where you installed KDE-4.x.y.




To get it to build, you need to add these parameters to the CMake command line:





-DKEXIV2_LOCAL_FOUND:FILEPATH=<prefix>/include/libkexiv2/kexiv2.h
-DKEXIV2_LOCAL_FOUND_IN_LIBS:FILEPATH=<prefix>/lib/libkexiv2.so
-DKDCRAW_LOCAL_FOUND:FILEPATH=<prefix>/include/libkdcraw/kdcraw.h
-DKDCRAW_LOCAL_FOUND_IN_LIBS:FILEPATH=<prefix>/lib/libkdcraw.so
-DKIPI_LOCAL_FOUND:FILEPATH=<prefix>/include/libkipi/plugin.h
-DKIPI_LOCAL_FOUND_IN_LIBS:FILEPATH=<prefix>/lib/libkipi.so

where <prefix> is the $KDEDIR -- where you installed KDE.






Oxygen Icons

If you checked out KDESupport from TRUNK or the TAG: "kdesupport-for-4.4", you have them.




If you checked out KDESupport from a tag "kdesupport-<version>" up to 4.3, you need to get them. If you are using SVN, that would be:





svn co svn://anonsvn.kde.org/home/kde/tags/KDE/<version>/oxygen-icons

{where <version> is the latest release for the branch you are using (e.g. 4.3.4 for the 4.3 branch)}




Or, you can simply use TRUNK:





svn co svn://anonsvn.kde.org/home/kde/trunk/kdesupportsvn/oxygen-icons

LibSSH

TRUNK and KDE-4.4 require libssh. Get the current release >= 0.4.0 from:






http://www.libssh.org/

Dependencies for specific KDE modules

KDEBindings

SIP and PyQt

To build the Python bindings for KDE, you need the current releases of SIP and PyQt from here:






http://www.riverbankcomputing.com/software/sip/download
http://www.riverbankcomputing.com/software/pyqt/download

Install: "SIP" first and then: "PyQt". These are both Python addons so they install with:






python configure.py
make
make install

Unless you want to get into serious complications, you should only build PyQt against one version of Qt and you should only install one version of KDEBindings. If you try to build against multiple versions of Qt or install multiple versions of KDEBindings, with a single instance of Python (or other languages), you will install two versions of the same file in the same place.




PyQt will find Qt based on your environment variables. So, if you want to install for a version of KDE other than the one that you are currently using, be sure that these are set correctly:





QTDIR
QT_PLUGIN_PATH

KDEBindings is dependent on KDEGraphics (specifically Okular).




Other language dependencies are optional. If you have other supported languages installed on your system, installing KDEBindings will build bindings for them.





KDENetwork

LibV4l




Only required for KDE-4.4 and TRUNK



Get the current release here:





http://people.fedoraproject.org/~jwrdegoede/

and follow the build instructions in the README file.






Optional Dependencies

Telepathy-Qt4 is the Qt bindings for Telepathy. Since this has general usage, you should probably install it along with its semi-optional dependency telepathy-glib.




Get the current releases here:





http://telepathy.freedesktop.org/releases/telepathy-glib/
http://telepathy.freedesktop.org/releases/telepathy-qt4/

Install: "telepathy-glib" first and then: 'telepathy-qt4".




The output from CMake lists several other optional dependencies. It appears that these are needed to support specific functions in KDENetwork. So, if you need those functions, you need to install them. You will probably also need to install the corresponding Telepathy addons from here:





http://telepathy.freedesktop.org/releases/

TO DO: more information needed.


This page was last modified on 19 July 2012, at 16:44. This page has been accessed 1,935 times. Content is available under Creative Commons License SA 3.0 as well as the GNU Free Documentation License 1.2.
KDE® and the K Desktop Environment® logo are registered trademarks of KDE e.V.Legal